Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » External command exit code is not picked up by Jubula
External command exit code is not picked up by Jubula [message #756184] Fri, 11 November 2011 12:19 Go to next message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 120
Registered: July 2009
Senior Member
Hello,

We are running Jubula 1.1.0 on Windows XP and have found a problem when running external commands.
It seems like Jubula always picks up exit code 1 even though the command results in exit code 0.

We have verified this problem by creating a .cmd file with a single line:
"EXIT 0".
We have also changed the expected exit code back and forth but the problem remains.

Is this a bug?

Regards,

Anders
Re: External command exit code is not picked up by Jubula [message #756207 is a reply to message #756184] Fri, 11 November 2011 13:34 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1163
Registered: July 2009
Senior Member
Hi Anders,

The behaviour you describe with the cmd file exiting with 1 does indeed sound like a bug. Open a ticket for it and add as much information as possible (log files if applicable etc) and we'll have a look at it.

Best regards,
Alex
Re: External command exit code is not picked up by Jubula [message #756236 is a reply to message #756207] Fri, 11 November 2011 15:26 Go to previous message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 120
Registered: July 2009
Senior Member
Thanks, I created https://bugs.eclipse.org/bugs/show_bug.cgi?id=363586
Previous Topic:ComponentNotFoundException
Next Topic:How to ensure the correct application is tested
Goto Forum:
  


Current Time: Sat Nov 22 00:30:47 GMT 2014

Powered by FUDForum. Page generated in 0.02020 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software