Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » egit ssh with domain\username@reposerver(egit ssh login to linux machine, which is in windows domain membership)
egit ssh with domain\username@reposerver [message #754762] Fri, 04 November 2011 08:58 Go to next message
dekobas is currently offline dekobasFriend
Messages: 2
Registered: November 2011
Junior Member
Dear Sirs and Madam,

a git repository has been created on a linux machine. No local user are set up on that machine, though it is member of active directory domain.

Users are able to login using DOMAIN\username@machineX with putty, tortoireGIT, etc...



Wizard of egit, while trying to clone a remote git repository does not succeed to login.
It does not accept an username formed as DOMAIN\Username in the username field. The wizard tries to resolve DOMAIN as a host name if entered.

Anybody any idea?

Best regards
Denis


Re: egit ssh with domain\username@reposerver [message #754831 is a reply to message #754762] Fri, 04 November 2011 14:16 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
dekobas skrev 2011-11-04 09.58:
> Dear Sirs and Madam,
>
> a git repository has been created on a linux machine. No local user are set up on that machine, though it is member of active directory domain.
> Users are able to login using DOMAIN\username@machineX with putty, tortoireGIT, etc...
>
>
>
> Wizard of egit, while trying to clone a remote git repository does not succeed to login.
> It does not accept an username formed as DOMAIN\Username in the username field. The wizard tries to resolve DOMAIN as a host name if entered.
>
> Anybody any idea?

Obviously we don't parse the URL properly. Should we consider \ specially or
are there other less-common characters to allow, like °!"#€%&/()= or even space.
For what I know a username can contain almost any character, though anything but
[a-z0-9-] are not very common.

-- robin
Re: egit ssh with domain\username@reposerver [message #754868 is a reply to message #754762] Fri, 04 November 2011 16:56 Go to previous messageGo to next message
Robin Rosenberg is currently offline Robin RosenbergFriend
Messages: 332
Registered: July 2009
Senior Member
dekobas skrev 2011-11-04 09.58:
> Dear Sirs and Madam,
>
> a git repository has been created on a linux machine. No local user are set up on that machine, though it is member of active directory domain.
> Users are able to login using DOMAIN\username@machineX with putty, tortoireGIT, etc...
>
>
>
> Wizard of egit, while trying to clone a remote git repository does not succeed to login.
> It does not accept an username formed as DOMAIN\Username in the username field. The wizard tries to resolve DOMAIN as a host name if entered.

Patch posted at http://egit.eclipse.org/r/#change,4548

-- robin
Re: egit ssh with domain\username@reposerver [message #754881 is a reply to message #754868] Fri, 04 November 2011 18:24 Go to previous messageGo to next message
dekobas is currently offline dekobasFriend
Messages: 2
Registered: November 2011
Junior Member
Dear Robin,
thank you for your fast action on that subject.
Next monday I will test it out; and close this question here.
best regards
Denis
Re: egit ssh with domain\username@reposerver [message #755106 is a reply to message #754881] Mon, 07 November 2011 12:22 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 612
Registered: July 2009
Senior Member
The change has reached the nightly build so you may try it installing egit from http://download.eclipse.org/egit/updates-nightly
Previous Topic:Desynchronizing
Next Topic:Default repository folder is too inflexible
Goto Forum:
  


Current Time: Fri Nov 28 07:26:12 GMT 2014

Powered by FUDForum. Page generated in 0.09408 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software