Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » ECMAScript Compliance Level 3 -> 5?
ECMAScript Compliance Level 3 -> 5? [message #754304] Wed, 02 November 2011 00:59 Go to next message
Andrei Pozolotin is currently offline Andrei Pozolotin
Messages: 2
Registered: November 2011
Junior Member
Hello;

ECMAScript Compliance Level is locked at "ECMAScript 3"

is there any way to get it to "ECMAScript 5"? Smile

may be there is some experimental AST parser available?

thank you;

Andrei.
Re: ECMAScript Compliance Level 3 -> 5? [message #764940 is a reply to message #754304] Tue, 13 December 2011 06:03 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2310
Registered: July 2009
Senior Member
No, there is no way to get it to version 5, but we'll look at patches if someone wants to jump start the effort. I don't have a firm grasp on which release it will fall under, otherwise.

---
Nitin Dahyabhai
Eclipse WTP, IBM

[Updated on: Tue, 13 December 2011 06:04]

Report message to a moderator

icon5.gif  Re: ECMAScript Compliance Level 3 -> 5? [message #893306 is a reply to message #764940] Tue, 03 July 2012 13:50 Go to previous message
Nabor Gilgalad is currently offline Nabor Gilgalad
Messages: 1
Registered: July 2012
Junior Member
What needs to be done to get the possibility of switching ECMAScript to 5 or 6 (Harmony)

As fare as I found out there is only one IDE out there, that supports Harmony, and this IDE is not free.

I'm really interested in using Eclipse for JavaScript development and for now ECMAScript 3 is fare away from being good enough to develop for Mozilla Addon SDK...
Previous Topic:Tomcat - Multiple Root Context
Next Topic:Prevent Eclispe content-assistance from xsd for the namespace, which is not declared in xml
Goto Forum:
  


Current Time: Thu Oct 23 15:28:19 GMT 2014

Powered by FUDForum. Page generated in 0.02656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software