Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » An internal error occurred during: "Processing Dirty Regions". Java heap space(Eclipse Error)
An internal error occurred during: "Processing Dirty Regions". Java heap space [message #754244] Tue, 01 November 2011 11:48 Go to next message
saeed17 is currently offline saeed17
Messages: 1
Registered: November 2011
Junior Member
Hi all,

I'm using Eclipse PDT, since Friday it has been freezing up and throwing error messages;

First I get this error:
'An internal error occurred during: "Processing Dirty Regions".
Java heap space'

Then I get the following prompt:
'An internal error occurred while showing an internal error. You are recommended to exit the workbench. Subsequent errors may happen and may terminate the workbench without warning. See .log file for more details. Do you want to exit the workbench?'

I select no and atempt to carry on working until it pops up again.

I deselected the 'Build Automatically' option from the project menu as this is what was freezing it up.

I am on Windows 7, Version: Helios Service Release 2, Build id: 20110301-1815.

Sincerely appreciate any help, I've been searching for the past couple of days but couldn't find a solution.


Re: An internal error occurred during: "Processing Dirty Regions". Java heap space [message #770256 is a reply to message #754244] Fri, 23 December 2011 14:01 Go to previous messageGo to next message
Andre  is currently offline Andre
Messages: 1
Registered: December 2011
Junior Member
Same problem here on a Mac 10.6.8

Version: Helios Release
Build id: 20100617-1415

[Updated on: Fri, 23 December 2011 14:04]

Report message to a moderator

Re: An internal error occurred during: "Processing Dirty Regions". Java heap space [message #891784 is a reply to message #770256] Mon, 25 June 2012 18:33 Go to previous message
Gloria Muse is currently offline Gloria Muse
Messages: 5
Registered: June 2012
Junior Member
I'm having the same problem on Mac 10.7.3,
Eclipse version:
Eclipse IDE for PHP Developers 1.3.0.20100617-0520 epp.package.php
Eclipse Platform 3.6.0.I20100608-0911 org.eclipse.platform.ide
EPP PHP Feature 1.3.0.20100617-0520 org.eclipse.epp.package.php.feature.feature.group

I unchecked the "Build Automatically", but it is still happening!

should this be reported in "Bugs"?
Previous Topic:Debug with query string
Next Topic:Custom Validation Issues
Goto Forum:
  


Current Time: Sat Jul 26 13:18:11 EDT 2014

Powered by FUDForum. Page generated in 0.01824 seconds