Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces'
Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #753632] Fri, 28 October 2011 07:12 Go to next message
borobudur Missing name is currently offline borobudur Missing name
Messages: 15
Registered: March 2010
Junior Member
Hi, I can't start the following bundle from the spring bundle repository in the virgo server:
    com.springsource.org.apache.xerces-2.8.1.jar

The depending two bundles are installed properly:
    com.springsource.org.apache.xml.resolver-1.2.0.jar
    com.springsource.org.apache.xmlcommons-1.3.4.jar

I get this error message:
[2011-10-15 14:58:23.297] fs-watcher                   <DE0000I> Installing bundle 'com.springsource.org.apache.xmlcommons' version '1.3.4'. 
[2011-10-15 14:58:23.319] fs-watcher                   <DE0001I> Installed bundle 'com.springsource.org.apache.xmlcommons' version '1.3.4'. 
[2011-10-15 14:58:23.332] fs-watcher                   <DE0004I> Starting bundle 'com.springsource.org.apache.xmlcommons' version '1.3.4'. 
[2011-10-15 14:58:23.344] start-signalling-5           <DE0005I> Started bundle 'com.springsource.org.apache.xmlcommons' version '1.3.4'. 
[2011-10-15 14:58:40.359] fs-watcher                   <HD0001I> Hot deployer processing 'CREATED' event for file 'com.springsource.org.apache.xml.resolver-1.2.0.jar'. 
[2011-10-15 14:58:40.485] fs-watcher                   <DE0000I> Installing bundle 'com.springsource.org.apache.xml.resolver' version '1.2.0'. 
[2011-10-15 14:58:40.526] fs-watcher                   <DE0001I> Installed bundle 'com.springsource.org.apache.xml.resolver' version '1.2.0'. 
[2011-10-15 14:58:40.531] fs-watcher                   <DE0004I> Starting bundle 'com.springsource.org.apache.xml.resolver' version '1.2.0'. 
[2011-10-15 14:58:40.534] start-signalling-5           <DE0005I> Started bundle 'com.springsource.org.apache.xml.resolver' version '1.2.0'. 
[2011-10-15 15:14:39.405] fs-watcher                   <HD0001I> Hot deployer processing 'CREATED' event for file 'com.springsource.org.apache.xerces-2.8.1.jar'. 
[2011-10-15 15:14:39.643] fs-watcher                   <DE0000I> Installing bundle 'com.springsource.org.apache.xerces' version '2.8.1'. 
[2011-10-15 15:14:42.739] fs-watcher                   <ME0003I> Dump 'serviceability/dump/2011-10-15-15-14-655' generated 
[2011-10-15 15:14:42.745] fs-watcher                   <DE0002E> Installation of bundle 'com.springsource.org.apache.xerces' version '2.8.1' failed. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' at version '2.8.1': Cannot resolve: com.springsource.org.apache.xerces
    Resolver report:
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)

[2011-10-15 15:14:42.747] fs-watcher                   <DE0003E> Install failed for bundle 'com.springsource.org.apache.xerces' version '2.8.1'. 
[2011-10-15 15:14:42.748] fs-watcher                   <DE0500E> Unable to install application from URI 'file:/home/athene/bin/virgo-tomcat-server-3.0.1.RELEASE/pickup/com.springsource.org.apache.xerces-2.8.1.jar'. Cannot satisfy constraints for bundle 'com.springsource.org.apache.xerces' version '2.8.1'. Cannot resolve: com.springsource.org.apache.xerces
    Resolver report:
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1
. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' at version '2.8.1': Cannot resolve: com.springsource.org.apache.xerces
    Resolver report:
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)

[2011-10-15 15:14:42.752] fs-watcher                   <HD0002E> Hot deploy failed for file 'com.springsource.org.apache.xerces-2.8.1.jar'. org.eclipse.virgo.kernel.deployer.core.DeploymentException: Dependency satisfaction failed
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:288)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)
Caused by: org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' at version '2.8.1': Cannot resolve: com.springsource.org.apache.xerces
    Resolver report:
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	... 9 common frames omitted
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754044 is a reply to message #753632] Mon, 31 October 2011 15:10 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Perhaps the diagnostics could be a little clearer, but it seems likely that the xerces bundles cannot attach to the xmlcommons bundle because the xmlcommons bundle is already resolved.

It would be simpler to place the xerces bundle in repository/usr so that it is automatically installed when xmlcommons is deployed. Please see if that works.

[Updated on: Mon, 31 October 2011 15:10]

Report message to a moderator

Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754091 is a reply to message #754044] Mon, 31 October 2011 17:44 Go to previous messageGo to next message
borobudur Missing name is currently offline borobudur Missing name
Messages: 15
Registered: March 2010
Junior Member
Thanks for your reply. I accually have all of the three xerces bundles in repository/usr and my own bundle I have in pickup which uses them. Same error message!

Well it's an other library which I bundled myself which uses xerces. The library is com.hp.hpl.jena. I'm not really sure where the problem is. I find it strange that I can't install xerces just at the beginning.
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754181 is a reply to message #754091] Tue, 01 November 2011 08:40 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
The event log extra above shows xmlcommons being deployed in pickup and if xerces is in repository/usr at the time and its fragment host header matches the xmlcommons version you deployed (which it does - I checked) and if xerces' other dependencies, i.e. xml.resolver, are in repository/usr, then xerces should be automatically installed as xmlcommons is deployed.

Please could you check the behaviour using a fresh install of Virgo and just the three bundles I mentioned. If you get the same behaviour, please raise a bug so we can look into it.
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754254 is a reply to message #754181] Tue, 01 November 2011 16:16 Go to previous messageGo to next message
borobudur Missing name is currently offline borobudur Missing name
Messages: 15
Registered: March 2010
Junior Member
I put the three packages into repository/usr and started a dummy bundle over pickup which uses org.apache.xerces.jaxp.DocumentBuilderFactoryImpl

The error message:

user@organization:/development/bin/virgo-tomcat-server-3.0.1.RELEASE$ bin/startup.sh -clean
[2011-11-01 14:46:54.418] startup-tracker              <KE0001I> Kernel starting. 
[2011-11-01 14:46:59.885] service-monitor-thread-1     <KE0100W> Reference '&objectNameCreator' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.model.management.RuntimeArtifactModelObjectNameCreator)'. 
[2011-11-01 14:47:00.072] kernel-dm-8                  <KE0101I> Reference '&objectNameCreator' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' was satisfied by service with filter '(objectClass=org.eclipse.virgo.kernel.model.management.RuntimeArtifactModelObjectNameCreator)'. 
[2011-11-01 14:47:00.561] startup-tracker              <KE0002I> Kernel started. 
[2011-11-01 14:47:00.928] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-11-01 14:47:01.049] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-11-01 14:47:01.066] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-11-01 14:47:01.073] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-11-01 14:47:01.079] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:01.085] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:01.101] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-11-01 14:47:01.113] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-11-01 14:47:01.116] system-artifacts             <DE0000I> Installing configuration 'osgi.console.telnet' version '0.0.0'. 
[2011-11-01 14:47:01.117] system-artifacts             <DE0000I> Installing configuration 'osgi.console.ssh' version '0.0.0'. 
[2011-11-01 14:47:02.378] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-11-01 14:47:02.379] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-11-01 14:47:02.380] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-11-01 14:47:02.381] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:02.382] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:02.383] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-11-01 14:47:02.384] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-11-01 14:47:02.394] system-artifacts             <DE0001I> Installed configuration 'osgi.console.telnet' version '0.0.0'. 
[2011-11-01 14:47:02.396] system-artifacts             <DE0001I> Installed configuration 'osgi.console.ssh' version '0.0.0'. 
[2011-11-01 14:47:02.396] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-11-01 14:47:02.442] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-11-01 14:47:02.460] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-11-01 14:47:02.462] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.core' version '1.2.1'. 
[2011-11-01 14:47:02.465] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-11-01 14:47:03.122] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.extender' version '1.2.1'. 
[2011-11-01 14:47:03.125] system-artifacts             <DE0004I> Starting bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-11-01 14:47:03.130] start-signalling-1           <DE0005I> Started bundle 'org.springframework.osgi.io' version '1.2.1'. 
[2011-11-01 14:47:03.133] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.149] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.153] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.171] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-11-01 14:47:03.357] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'. 
[2011-11-01 14:47:03.359] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-11-01 14:47:03.383] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'. 
[2011-11-01 14:47:03.401] system-artifacts             <DE0004I> Starting configuration 'osgi.console.telnet' version '0.0.0'. 
[2011-11-01 14:47:03.444] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.529] system-artifacts             <DE0005I> Started configuration 'osgi.console.telnet' version '0.0.0'. 
[2011-11-01 14:47:03.530] system-artifacts             <DE0004I> Starting configuration 'osgi.console.ssh' version '0.0.0'. 
[2011-11-01 14:47:03.579] system-artifacts             <DE0005I> Started configuration 'osgi.console.ssh' version '0.0.0'. 
[2011-11-01 14:47:03.580] system-artifacts             <DE0005I> Started plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'. 
[2011-11-01 14:47:03.768] system-artifacts             <DE0000I> Installing plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'. 
[2011-11-01 14:47:03.771] system-artifacts             <DE0000I> Installing configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2011-11-01 14:47:03.793] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.core' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:03.824] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.tomcat' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:03.830] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.833] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:03.838] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.tomcat.support' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:04.633] system-artifacts             <DE0001I> Installed configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2011-11-01 14:47:04.634] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.core' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:04.635] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.tomcat' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:04.636] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:04.649] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:04.650] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.tomcat.support' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:04.651] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'. 
[2011-11-01 14:47:04.668] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'. 
[2011-11-01 14:47:04.668] system-artifacts             <DE0004I> Starting configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2011-11-01 14:47:04.752] system-artifacts             <DE0005I> Started configuration 'org.eclipse.virgo.web' version '0.0.0'. 
[2011-11-01 14:47:04.753] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.core' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:04.792] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.web.core' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:04.793] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.gemini.web.tomcat' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:05.658] system-artifacts             <TC0000I> Starting Tomcat. 
[2011-11-01 14:47:05.724] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme http on port 8080. 
[2011-11-01 14:47:05.746] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme https on port 8443. 
[2011-11-01 14:47:05.747] system-artifacts             <TC0010I> Creating AJP/1.3 connector with scheme http on port 8009. 
[2011-11-01 14:47:05.749] system-artifacts             <TC0001I> Started Tomcat. 
[2011-11-01 14:47:05.762] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:05.773] system-artifacts             <DE0004I> Starting bundle 'org.eclipse.virgo.web.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:05.774] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.web.dm' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:05.775] system-artifacts             <DE0005I> Started bundle 'org.eclipse.virgo.web.tomcat.support' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:06.127] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.web.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:06.128] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.gemini.web.tomcat' version '2.0.1.RELEASE'. 
[2011-11-01 14:47:06.129] start-signalling-1           <DE0005I> Started plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'. 
[2011-11-01 14:47:06.132] sync Event Dispatcher Thread <UR0001I> User region ready. 
[2011-11-01 14:47:07.141] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.splash-3.0.1.RELEASE.jar'. 
[2011-11-01 14:47:07.294] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.438] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.490] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.492] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE.par'. 
[2011-11-01 14:47:07.493] start-signalling-1           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE' with context path '/'. 
[2011-11-01 14:47:07.826] fs-watcher                   <DE0000I> Installing par 'org.eclipse.virgo.apps.repository' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.827] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.829] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.994] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.995] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.996] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-synthetic.context' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:07.997] fs-watcher                   <DE0001I> Installed par 'org.eclipse.virgo.apps.repository' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.014] fs-watcher                   <DE0004I> Starting par 'org.eclipse.virgo.apps.repository' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.016] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.030] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.044] start-signalling-2           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-11-01 14:47:08.046] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-synthetic.context' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.049] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.admin-3.0.1.RELEASE.plan'. 
[2011-11-01 14:47:08.052] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-synthetic.context' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.237] start-signalling-1           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE' with context path '/'. 
[2011-11-01 14:47:08.238] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.splash' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.513] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:08.588] fs-watcher                   <DE0000I> Installing plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-11-01 14:47:08.630] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.122] fs-watcher                   <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.295] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.304] fs-watcher                   <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.305] fs-watcher                   <DE0001I> Installed plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-11-01 14:47:09.336] fs-watcher                   <DE0004I> Starting plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-11-01 14:47:09.338] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.350] fs-watcher                   <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:09.352] start-signalling-1           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE' with context path '/admin'. 
[2011-11-01 14:47:09.814] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:10.365] start-signalling-2           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-11-01 14:47:10.366] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.1.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:10.367] start-signalling-2           <DE0005I> Started par 'org.eclipse.virgo.apps.repository' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:10.405] start-signalling-1           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE' with context path '/admin'. 
[2011-11-01 14:47:10.406] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.1.RELEASE'. 
[2011-11-01 14:47:10.407] start-signalling-1           <DE0005I> Started plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-11-01 14:48:31.434] fs-watcher                   <HD0001I> Hot deployer processing 'CREATED' event for file 'my.organization.application.layer.module.0.0.1.BUILD-SNAPSHOT.jar'. 
[2011-11-01 14:48:31.465] fs-watcher                   <DE0000I> Installing bundle 'my.organization.application.layer.module' version '0.0.1.BUILD-SNAPSHOT'. 
[2011-11-01 14:48:34.646] fs-watcher                   <ME0003I> Dump 'serviceability/dump/2011-11-01-14-48-520' generated 
[2011-11-01 14:48:34.652] fs-watcher                   <DE0002E> Installation of bundle 'my.organization.application.layer.module' version '0.0.1.BUILD-SNAPSHOT' failed. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'my.organization.application.layer.module' at version '0.0.1.BUILD-SNAPSHOT': Cannot resolve: my.organization.application.layer.module
    Resolver report:
        An Import-Package could not be resolved. Caused by missing constraint in bundle <my.organization.application.layer.module_0.0.1.BUILD-SNAPSHOT>
             constraint: <Import-Package: org.apache.xerces.jaxp; version="2.8.1">
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)

[2011-11-01 14:48:34.654] fs-watcher                   <DE0003E> Install failed for bundle 'my.organization.application.layer.module' version '0.0.1.BUILD-SNAPSHOT'. 
[2011-11-01 14:48:34.655] fs-watcher                   <DE0500E> Unable to install application from URI 'file:/development/bin/virgo-tomcat-server-3.0.1.RELEASE/pickup/my.organization.application.layer.module.0.0.1.BUILD-SNAPSHOT.jar'. Cannot satisfy constraints for bundle 'my.organization.application.layer.module' version '0.0.1.BUILD-SNAPSHOT'. Cannot resolve: my.organization.application.layer.module
    Resolver report:
        An Import-Package could not be resolved. Caused by missing constraint in bundle <my.organization.application.layer.module_0.0.1.BUILD-SNAPSHOT>
             constraint: <Import-Package: org.apache.xerces.jaxp; version="2.8.1">
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1
. org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'my.organization.application.layer.module' at version '0.0.1.BUILD-SNAPSHOT': Cannot resolve: my.organization.application.layer.module
    Resolver report:
        An Import-Package could not be resolved. Caused by missing constraint in bundle <my.organization.application.layer.module_0.0.1.BUILD-SNAPSHOT>
             constraint: <Import-Package: org.apache.xerces.jaxp; version="2.8.1">
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)

[2011-11-01 14:48:34.672] fs-watcher                   <HD0002E> Hot deploy failed for file 'my.organization.application.layer.module.0.0.1.BUILD-SNAPSHOT.jar'. org.eclipse.virgo.kernel.deployer.core.DeploymentException: Dependency satisfaction failed
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:288)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:164)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:78)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)
Caused by: org.eclipse.virgo.kernel.osgi.framework.UnableToSatisfyBundleDependenciesException: Unable to satisfy dependencies of bundle 'my.organization.application.layer.module' at version '0.0.1.BUILD-SNAPSHOT': Cannot resolve: my.organization.application.layer.module
    Resolver report:
        An Import-Package could not be resolved. Caused by missing constraint in bundle <my.organization.application.layer.module_0.0.1.BUILD-SNAPSHOT>
             constraint: <Import-Package: org.apache.xerces.jaxp; version="2.8.1">
        A Fragment-Host could not be resolved. The affected fragment is com.springsource.org.apache.xerces_2.8.1

	at org.eclipse.virgo.kernel.install.pipeline.stage.resolve.internal.QuasiResolveStage.process(QuasiResolveStage.java:45)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.internal.CompensatingPipeline.doProcessTree(CompensatingPipeline.java:72)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.install.pipeline.internal.StandardPipeline.doProcessTree(StandardPipeline.java:62)
	at org.eclipse.virgo.kernel.install.pipeline.stage.AbstractPipelineStage.process(AbstractPipelineStage.java:41)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.driveInstallPipeline(PipelinedApplicationDeployer.java:285)
	... 9 common frames omitted


Do you really think this is a problem of virgo?
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754339 is a reply to message #754254] Wed, 02 November 2011 09:07 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
It could be a bug in Virgo, so please could you raise a bugzilla and attach your minimal test bundle.
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754420 is a reply to message #754339] Wed, 02 November 2011 14:02 Go to previous messageGo to next message
Dmitry Sklyut is currently offline Dmitry Sklyut
Messages: 272
Registered: January 2010
Senior Member
Could it be because part of xerces is bootdelegated?

org.osgi.framework.bootdelegation = \
 org.eclipse.virgo.osgi.extensions.*,\
 org.eclipse.virgo.osgi.launcher.*,\
 org.eclipse.virgo.kernel.authentication,\
 com.sun.*,\
 javax.xml.*,\
 org.apache.xerces.jaxp.*,\
 org.w3c.*,\
 org.xml.*,\
 sun.*


Dmitry
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #754493 is a reply to message #754420] Wed, 02 November 2011 18:16 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
I doubt it because boot delegation doesn't come into play at resolution time AFAIK. I guess we'll find out in a debugger when the bug is raised...
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #757209 is a reply to message #754493] Thu, 17 November 2011 07:00 Go to previous messageGo to next message
borobudur Missing name is currently offline borobudur Missing name
Messages: 15
Registered: March 2010
Junior Member
Raised a bug: https://bugs.eclipse.org/bugs/show_bug.cgi?id=364003
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #757228 is a reply to message #753632] Thu, 17 November 2011 08:58 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Thanks.
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #758808 is a reply to message #757228] Thu, 24 November 2011 15:45 Go to previous messageGo to next message
borobudur Missing name is currently offline borobudur Missing name
Messages: 15
Registered: March 2010
Junior Member
The problem was a version issue: it needs xmlcommons 1.3.3
So it is wrong declared in the spring bundle repository.
Re: Unable to satisfy dependencies of bundle 'com.springsource.org.apache.xerces' [message #758816 is a reply to message #758808] Thu, 24 November 2011 16:05 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
borobudur wrote on Thu, 24 November 2011 15:45
The problem was a version issue: it needs xmlcommons 1.3.3
So it is wrong declared in the spring bundle repository.

Yes, the Enterprise Bundle Repository is calculating the wrong dependency (on xmlcommons 1.3.4) even though the Fragment-Host in the bundle and the Ivy file for the xerces 2.8.1 project correctly specifies a dependency on xmlcommons 1.3.3.

There is, however, a get-out clause on the EBR dependency analysis which we seem to have run into in this case (although I don't know the internals of the app to understand why):
Quote:
The dependency information is calculated by analysing the Import-Package statements in the bundle. The bundles exporting the highest matching package versions are then added to the dependency set, and their dependencies are calculated in turn. Matching attributes and uses clauses are not considered in this analysis, so the results should be taken as indicative but do not guarantee successful resolution in a running OSGi Service Platform.


This is the first time I've seen such a problem.

Previous Topic:Snaps 3.0.1.RELEASE maven repo
Next Topic:First page load takes a long time
Goto Forum:
  


Current Time: Fri Sep 19 02:04:30 GMT 2014

Powered by FUDForum. Page generated in 0.02154 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software