Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Components in Target Platform have no artifacts
Components in Target Platform have no artifacts [message #751208] Tue, 25 October 2011 22:11 Go to next message
Philip Bedingfield is currently offline Philip Bedingfield
Messages: 42
Registered: August 2011
Member
I'm trying to reference an action on a component in the target platform but I get the error ->

CSpec A:osgi.bundle$1.0.0.qualifier has no action, group, or local artifact named "blah"

I can reference it while its in the workspace but not when its part of the target platform.

Is this correct behaviour or a bug?

Thanks in advance.
Re: Components in Target Platform have no artifacts [message #752147 is a reply to message #751208] Wed, 26 October 2011 05:38 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3214
Registered: July 2009
Senior Member
Hi Philip,

Can you see the bundle in the PDE bundle registry?

- thomas

On 2011-10-26 04:11, Philip Bedingfield wrote:
> I'm trying to reference an action on a component in the target platform but I get the error ->
>
> CSpec A:osgi.bundle$1.0.0.qualifier has no action, group, or local artifact named "blah"
>
> I can reference it while its in the workspace but not when its part of the target platform.
>
> Is this correct behaviour or a bug?
>
> Thanks in advance.
Re: Components in Target Platform have no artifacts [message #755877 is a reply to message #752147] Wed, 09 November 2011 17:53 Go to previous messageGo to next message
Philip Bedingfield is currently offline Philip Bedingfield
Messages: 42
Registered: August 2011
Member
What or where is the PDE bundle registry?

[Updated on: Wed, 09 November 2011 17:54]

Report message to a moderator

Re: Components in Target Platform have no artifacts [message #755909 is a reply to message #755877] Thu, 10 November 2011 02:05 Go to previous message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3214
Registered: July 2009
Senior Member
On 2011-11-09 23:53, Philip Bedingfield wrote:
> [quote title=Thomas Hallgren wrote on Wed, 26 October 2011 05:38]Hi Philip,
>
> Can you see the bundle in the PDE bundle registry?
>
> - thomas
>
> What or where is the PDE bundle registry?

In your IDE. You'll find it here:

"Window" -> "Show View" -> "Other" -> "Plug-in Development"

- thomas
Previous Topic:Build Error: Cannot find the class file for org.eclipse.swt
Next Topic:Buckminster and Jenkins
Goto Forum:
  


Current Time: Thu Jul 24 06:52:35 EDT 2014

Powered by FUDForum. Page generated in 0.02236 seconds