Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » JVM problem running test with ant script
JVM problem running test with ant script [message #83747] Mon, 18 September 2006 11:15 Go to next message
Dubois Jean-Jacques is currently offline Dubois Jean-Jacques
Messages: 8
Registered: July 2009
Junior Member
Hi,

I've a problem to run test using an Ant script.
I've a default JVM 1.3 installed on my computer (and I can't change it
because it's the default JVM in my office) and some other 1.4 and 1.5 jvms
(not default).
I start Eclipse with the 1.5 JVM specified in my shortcut and the default
JRE associated with my Eclipse runtime is well the 1.5 but when I launch
an Ant script to execute test with TPTP he used the defaut JVM installed
on my computer and that doesn't work because Ant needs a 1.4.1 or higher...

How can I specify an other JVM for Ant inside TPTP?
Re: JVM problem running test with ant script [message #83762 is a reply to message #83747] Mon, 18 September 2006 15:06 Go to previous messageGo to next message
Joe Toomey is currently offline Joe Toomey
Messages: 79
Registered: July 2009
Member
Hi Jean-Jacques,

If you're running your ant script from within eclipse, you can change
the JRE by modifying the preferences in Window -> Preferences -> Java ->
Installed JREs. Of course, to run ant tasks that include compile steps,
you'll need to configure using a JDK so you get tools.jar.

If you're running ant from outside eclipse, just set your JAVA_HOME
variable to point to the root of your JDK install directory.

Hope this helps,
--Joe

dubois jean-jacques wrote:
> Hi,
>
> I've a problem to run test using an Ant script.
> I've a default JVM 1.3 installed on my computer (and I can't change it
> because it's the default JVM in my office) and some other 1.4 and 1.5
> jvms (not default).
> I start Eclipse with the 1.5 JVM specified in my shortcut and the
> default JRE associated with my Eclipse runtime is well the 1.5 but when
> I launch an Ant script to execute test with TPTP he used the defaut JVM
> installed on my computer and that doesn't work because Ant needs a 1.4.1
> or higher...
>
> How can I specify an other JVM for Ant inside TPTP?
>
Re: JVM problem running test with ant script [message #83806 is a reply to message #83762] Tue, 19 September 2006 05:55 Go to previous message
Dubois Jean-Jacques is currently offline Dubois Jean-Jacques
Messages: 8
Registered: July 2009
Junior Member
Joe,

I've verified the preferences and the referenced JRE is the good one (1.5).
I've tried to set the JAVA_HOME variable but that doesn't work... :s
When I run an Ant script to build a Eclipse plug-in, I don't have this
problem but with TPTP it takes the default JVM.
This problem seems occurs when Ant use a class from the ant-tptp jar but I
don't see why...

Thx for your help :)

Jean-Jacques
Previous Topic:jvmti agent
Next Topic:Editor extensions
Goto Forum:
  


Current Time: Thu Oct 23 04:50:13 GMT 2014

Powered by FUDForum. Page generated in 0.02636 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software