Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » IMP (with LPG) on OS X
IMP (with LPG) on OS X [message #7383] Fri, 28 September 2007 11:16 Go to next message
Eclipse User
Originally posted by: sven.efftinge.de

Hi,

we at openArchitectureWare (and M2T, MWE as well) are very interested in
(and excited about :-)) IMP. We work on frameworks for DSLs as well as
on languages for model2model transformation, code generation and
validation. So the abstractions provided by IMP might be very useful here.

I'm currently trying the release from sourceforge under OS X 10.4.
Unfortunately the LPG builder doesn't work (NPE in
org.eclipse.imp.lpg.builder.LPGBuilder.isSourceFile(LPGBuild er.java:96))
In addition I'm not able to open the preferences for LPG
(IllegalArgumentException "Unable to find LPG executable at
lpgexe/lpg-macosx_x86 in bundle lpg.runtime").

Did I miss something or is it a bug?
Or is it that OS X is not supported?

Thanks,
Sven
Re: IMP (with LPG) on OS X [message #7456 is a reply to message #7383] Tue, 02 October 2007 17:41 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Sven Efftinge wrote:
> Hi,
>
> we at openArchitectureWare (and M2T, MWE as well) are very interested in
> (and excited about :-)) IMP. We work on frameworks for DSLs as well as
> on languages for model2model transformation, code generation and
> validation. So the abstractions provided by IMP might be very useful here.

Great!

> I'm currently trying the release from sourceforge under OS X 10.4.
> Unfortunately the LPG builder doesn't work (NPE in
> org.eclipse.imp.lpg.builder.LPGBuilder.isSourceFile(LPGBuild er.java:96))
> In addition I'm not able to open the preferences for LPG
> (IllegalArgumentException "Unable to find LPG executable at
> lpgexe/lpg-macosx_x86 in bundle lpg.runtime").
>
> Did I miss something or is it a bug?
> Or is it that OS X is not supported?

It looks like a little of both. I.e. a bug, and not supported, that is. :-)

We only recently got some Macs here, so some of us are just starting to run on
that platform. There are a couple of missing pieces, like the binary for the LPG
parser generator, as you discovered. We have built a MacOS X binary for LPG, and
we'll add that to the LPG plugin soon.

In the meantime, you can get the LPG source from sourceforge and compile it with
gcc (I think either v3 or v4 should work fine). Then copy it into the

lpg.runtime.java/lpgexe

folder inside the 'plugins' folder of your Eclipse installation. The binary should
be named 'lpg-macosx_x86', as the error message indicates.

As for the NPE in the builder, we'll have to look into that.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://eclipse-imp.sourceforge.net)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Re: IMP (with LPG) on OS X [message #566870 is a reply to message #7383] Tue, 02 October 2007 17:41 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Sven Efftinge wrote:
> Hi,
>
> we at openArchitectureWare (and M2T, MWE as well) are very interested in
> (and excited about :-)) IMP. We work on frameworks for DSLs as well as
> on languages for model2model transformation, code generation and
> validation. So the abstractions provided by IMP might be very useful here.

Great!

> I'm currently trying the release from sourceforge under OS X 10.4.
> Unfortunately the LPG builder doesn't work (NPE in
> org.eclipse.imp.lpg.builder.LPGBuilder.isSourceFile(LPGBuild er.java:96))
> In addition I'm not able to open the preferences for LPG
> (IllegalArgumentException "Unable to find LPG executable at
> lpgexe/lpg-macosx_x86 in bundle lpg.runtime").
>
> Did I miss something or is it a bug?
> Or is it that OS X is not supported?

It looks like a little of both. I.e. a bug, and not supported, that is. :-)

We only recently got some Macs here, so some of us are just starting to run on
that platform. There are a couple of missing pieces, like the binary for the LPG
parser generator, as you discovered. We have built a MacOS X binary for LPG, and
we'll add that to the LPG plugin soon.

In the meantime, you can get the LPG source from sourceforge and compile it with
gcc (I think either v3 or v4 should work fine). Then copy it into the

lpg.runtime.java/lpgexe

folder inside the 'plugins' folder of your Eclipse installation. The binary should
be named 'lpg-macosx_x86', as the error message indicates.

As for the NPE in the builder, we'll have to look into that.

--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IMP Team Lead (http://eclipse-imp.sourceforge.net)
X10: Productivity for High-Performance Parallel Programming (http://x10.sf.net)
Previous Topic:JavaScript and IMP
Next Topic:editing portions of a file
Goto Forum:
  


Current Time: Thu Oct 23 17:27:19 GMT 2014

Powered by FUDForum. Page generated in 0.02177 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software