Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » "Premature end of file" error when using some clients
"Premature end of file" error when using some clients [message #7381] Fri, 25 May 2007 18:24 Go to next message
Ali B. is currently offline Ali B.
Messages: 66
Registered: July 2009
Member
Since the Forum is *raging* with spams, I had to post this here to get help.

When I use the SVNKit client or the Subclipse default JAVA SVN client I
I get an error connecting to any repository (screenshot linked below).
When I switch to Native JavaHL, everything works ok.

http://picasaweb.google.com/dmondark/Public/photo#5065713818 188004738

Now when right clicking on the errors and selecting details->Advanced, I
get the following:

Quote:
PROPFIND request failed on '/wordpress'
Processing PROPFIND request response failed: Premature end of file.
(/wordpress)



The versions (Clean installations):

PDT: 0.7 RC3
Subversive: 1.1.2
JAVA SVN: 1.0.4
SVNKit:1.1.1
Native JavaHL: 1.4.3

Any idea why is this happening??


Cheers,
Ali
Re: "Premature end of file" error when using some clients [message #7433 is a reply to message #7381] Fri, 08 June 2007 07:59 Go to previous messageGo to next message
Igor Vinnykov is currently offline Igor Vinnykov
Messages: 61
Registered: July 2009
Member
Hello Ali,

Thank you for the report. What version of SVN do you try to connect? Could
you please also inform us about any specific in your environment and
repository, because the problem is pretty unusual.

Best regards,
Igor Vinnykov

"Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
news:f37nl0$bj9$1@build.eclipse.org...
> Since the Forum is *raging* with spams, I had to post this here to get
> help.
>
> When I use the SVNKit client or the Subclipse default JAVA SVN client I I
> get an error connecting to any repository (screenshot linked below). When
> I switch to Native JavaHL, everything works ok.
>
> http://picasaweb.google.com/dmondark/Public/photo#5065713818 188004738
>
> Now when right clicking on the errors and selecting details->Advanced, I
> get the following:
>
> Quote:
> PROPFIND request failed on '/wordpress'
> Processing PROPFIND request response failed: Premature end of file.
> (/wordpress)
>
>
>
> The versions (Clean installations):
>
> PDT: 0.7 RC3
> Subversive: 1.1.2
> JAVA SVN: 1.0.4
> SVNKit:1.1.1
> Native JavaHL: 1.4.3
>
> Any idea why is this happening??
>
>
> Cheers,
> Ali
Re: "Premature end of file" error when using some clients [message #7455 is a reply to message #7433] Fri, 08 June 2007 09:09 Go to previous messageGo to next message
Ali B. is currently offline Ali B.
Messages: 66
Registered: July 2009
Member
Hi Igor,

Thank you for responding.

I am not sure what are the versions of the SVN servers, the issue occurs
on all of the 3 repositories I tried: Wordpress, Joomla development and
Lifetype.
The problem is almost consistent. The behavior looked much like a
network issue at first. What made me not consider that is that it never
happens when using Native JavaHL, and I am not behind a firewall other
than my own software one, in which I made sure java and javaw is allowed
to traffic in/out.

I am running subversive on a clean all-in-one PDT installation.
I am not sure what more information is needed here..Please let me know
if any further details is needed.

Thank you for your help.

Cheers,
Ali


Igor Vinnykov wrote:
> Hello Ali,
>
> Thank you for the report. What version of SVN do you try to connect? Could
> you please also inform us about any specific in your environment and
> repository, because the problem is pretty unusual.
>
> Best regards,
> Igor Vinnykov
>
> "Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
> news:f37nl0$bj9$1@build.eclipse.org...
>> Since the Forum is *raging* with spams, I had to post this here to get
>> help.
>>
>> When I use the SVNKit client or the Subclipse default JAVA SVN client I I
>> get an error connecting to any repository (screenshot linked below). When
>> I switch to Native JavaHL, everything works ok.
>>
>> http://picasaweb.google.com/dmondark/Public/photo#5065713818 188004738
>>
>> Now when right clicking on the errors and selecting details->Advanced, I
>> get the following:
>>
>> Quote:
>> PROPFIND request failed on '/wordpress'
>> Processing PROPFIND request response failed: Premature end of file.
>> (/wordpress)
>>
>>
>>
>> The versions (Clean installations):
>>
>> PDT: 0.7 RC3
>> Subversive: 1.1.2
>> JAVA SVN: 1.0.4
>> SVNKit:1.1.1
>> Native JavaHL: 1.4.3
>>
>> Any idea why is this happening??
>>
>>
>> Cheers,
>> Ali
>
>
Re: "Premature end of file" error when using some clients [message #7466 is a reply to message #7455] Mon, 18 June 2007 09:28 Go to previous messageGo to next message
Igor Vinnykov is currently offline Igor Vinnykov
Messages: 61
Registered: July 2009
Member
Hello Ali,

The only thing we can suppose here is the porblem with JavaSVN/SVNKit. We
will forward information about that problem to TMate, which is author of
JavaSVN and SVNKit.

Best regards,
Igor Vinnykov

"Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
news:f4bka5$oc1$1@build.eclipse.org...
> Hi Igor,
>
> Thank you for responding.
>
> I am not sure what are the versions of the SVN servers, the issue occurs
> on all of the 3 repositories I tried: Wordpress, Joomla development and
> Lifetype.
> The problem is almost consistent. The behavior looked much like a network
> issue at first. What made me not consider that is that it never happens
> when using Native JavaHL, and I am not behind a firewall other than my own
> software one, in which I made sure java and javaw is allowed to traffic
> in/out.
>
> I am running subversive on a clean all-in-one PDT installation.
> I am not sure what more information is needed here..Please let me know if
> any further details is needed.
>
> Thank you for your help.
>
> Cheers,
> Ali
>
>
> Igor Vinnykov wrote:
>> Hello Ali,
>>
>> Thank you for the report. What version of SVN do you try to connect?
>> Could you please also inform us about any specific in your environment
>> and repository, because the problem is pretty unusual.
>>
>> Best regards,
>> Igor Vinnykov
>>
>> "Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
>> news:f37nl0$bj9$1@build.eclipse.org...
>>> Since the Forum is *raging* with spams, I had to post this here to get
>>> help.
>>>
>>> When I use the SVNKit client or the Subclipse default JAVA SVN client I
>>> I get an error connecting to any repository (screenshot linked below).
>>> When I switch to Native JavaHL, everything works ok.
>>>
>>> http://picasaweb.google.com/dmondark/Public/photo#5065713818 188004738
>>>
>>> Now when right clicking on the errors and selecting details->Advanced, I
>>> get the following:
>>>
>>> Quote:
>>> PROPFIND request failed on '/wordpress'
>>> Processing PROPFIND request response failed: Premature end of file.
>>> (/wordpress)
>>>
>>>
>>>
>>> The versions (Clean installations):
>>>
>>> PDT: 0.7 RC3
>>> Subversive: 1.1.2
>>> JAVA SVN: 1.0.4
>>> SVNKit:1.1.1
>>> Native JavaHL: 1.4.3
>>>
>>> Any idea why is this happening??
>>>
>>>
>>> Cheers,
>>> Ali
>>
Re: "Premature end of file" error when using some clients [message #8379 is a reply to message #7466] Fri, 20 July 2007 19:11 Go to previous message
Ali B. is currently offline Ali B.
Messages: 66
Registered: July 2009
Member
Hello Igor,

Forgive me for this reply my be a *little* late ;)

Thank you for checking on the issue, I just wanted to ask if any of
those two have pros over the Native JavaHL? The latter is working great
for me, I wouldn't mind if it is not slower or less functionality.

Thanks

Cheers,
Ali

Igor Vinnykov wrote:
> Hello Ali,
>
> The only thing we can suppose here is the porblem with JavaSVN/SVNKit. We
> will forward information about that problem to TMate, which is author of
> JavaSVN and SVNKit.
>
> Best regards,
> Igor Vinnykov
>
> "Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
> news:f4bka5$oc1$1@build.eclipse.org...
>> Hi Igor,
>>
>> Thank you for responding.
>>
>> I am not sure what are the versions of the SVN servers, the issue occurs
>> on all of the 3 repositories I tried: Wordpress, Joomla development and
>> Lifetype.
>> The problem is almost consistent. The behavior looked much like a network
>> issue at first. What made me not consider that is that it never happens
>> when using Native JavaHL, and I am not behind a firewall other than my own
>> software one, in which I made sure java and javaw is allowed to traffic
>> in/out.
>>
>> I am running subversive on a clean all-in-one PDT installation.
>> I am not sure what more information is needed here..Please let me know if
>> any further details is needed.
>>
>> Thank you for your help.
>>
>> Cheers,
>> Ali
>>
>>
>> Igor Vinnykov wrote:
>>> Hello Ali,
>>>
>>> Thank you for the report. What version of SVN do you try to connect?
>>> Could you please also inform us about any specific in your environment
>>> and repository, because the problem is pretty unusual.
>>>
>>> Best regards,
>>> Igor Vinnykov
>>>
>>> "Ali B." <dmondark@gmail.com> ???????/???????? ? ???????? ?????????:
>>> news:f37nl0$bj9$1@build.eclipse.org...
>>>> Since the Forum is *raging* with spams, I had to post this here to get
>>>> help.
>>>>
>>>> When I use the SVNKit client or the Subclipse default JAVA SVN client I
>>>> I get an error connecting to any repository (screenshot linked below).
>>>> When I switch to Native JavaHL, everything works ok.
>>>>
>>>> http://picasaweb.google.com/dmondark/Public/photo#5065713818 188004738
>>>>
>>>> Now when right clicking on the errors and selecting details->Advanced, I
>>>> get the following:
>>>>
>>>> Quote:
>>>> PROPFIND request failed on '/wordpress'
>>>> Processing PROPFIND request response failed: Premature end of file.
>>>> (/wordpress)
>>>>
>>>>
>>>>
>>>> The versions (Clean installations):
>>>>
>>>> PDT: 0.7 RC3
>>>> Subversive: 1.1.2
>>>> JAVA SVN: 1.0.4
>>>> SVNKit:1.1.1
>>>> Native JavaHL: 1.4.3
>>>>
>>>> Any idea why is this happening??
>>>>
>>>>
>>>> Cheers,
>>>> Ali
>
Previous Topic:Any news on a release to support Mylin?
Next Topic:*.svn-base not hidden
Goto Forum:
  


Current Time: Fri Apr 18 17:07:01 EDT 2014

Powered by FUDForum. Page generated in 0.01739 seconds