Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Status cache not updating on Commit.
Status cache not updating on Commit. [message #743652] Fri, 21 October 2011 16:35 Go to next message
Markus Jarderot is currently offline Markus JarderotFriend
Messages: 2
Registered: October 2011
Junior Member
When I commit my changes, the SVN status in the Package Explorer doesn't update. If I change something in a file, save, I see that the file is marked as "modified". But when I commit, the status icon still says "modified". It also thinks I still have the SVN lock, so the "Lock file" dialog won't open. The file becomes read-only until I restart Eclipse, and reacquire the lock.

Disabling the SVN status cache in Eclipse Settings makes it work as expected, but I would like to be able to use the status cache.

Eclipse Version: Indigo Release
Eclipse Build id: 20110615-0604

Plugins:
Subversive SVN Connectors (2.2.2.I20110819-1700)
Subversive SVN Team Provider (Incubation) (0.7.9.I20110819-1700)
SVNKit 1.3.5 Implementation (Optional) (2.2.2.I20110819-1700)

OS: Windows 7 Professional (SP1)

I also use TortoiseSVN 1.6.16 (Subversion 1.6.17) for Windows integration, which I used for checking out the project.

I had the same problem in Windows XP on the same machine.

Have anyone else had this problem?
Have someone found the reason why it doesn't work?
Have someone found a solution (except disabling the SVN status cache)?

[Updated on: Fri, 21 October 2011 16:36]

Report message to a moderator

Re: Status cache not updating on Commit. [message #744687 is a reply to message #743652] Sat, 22 October 2011 09:05 Go to previous message
Mauro Molinari is currently offline Mauro MolinariFriend
Messages: 280
Registered: July 2009
Senior Member
Il 21/10/2011 18:35, Markus Jarderot ha scritto:
> Have anyone else had this problem?
> Have someone found the reason why it doesn't work?
> Have someone found a solution (except disabling the SVN status cache)?

See my previous post: "Problems committing changes in Indigo".

See also bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=329555
Please, comment on it. Disabling the SVN Status Cache is a good
workaround I didn't know of.

Mauro.
Previous Topic:Port reset after restart eclipse
Next Topic:SVN Actions From Eclipse Helios
Goto Forum:
  


Current Time: Fri Nov 28 16:15:00 GMT 2014

Powered by FUDForum. Page generated in 0.03865 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software