Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » URL exception
icon4.gif  URL exception [message #743334] Fri, 21 October 2011 11:09 Go to next message
Calo Missing name is currently offline Calo Missing nameFriend
Messages: 2
Registered: October 2011
Junior Member
Hello

I've been searching on Internet for this problem but there is not a really solution for this.

I've installed eclipse with enterprice pack (from Oracle download page, becouse i need weblogic server)
I imported a project and all *.jsp file dosn't get open becpouse of
an exception

java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters
in escape (%) pattern - For input string: "=r"


which is located her:
<link rel="stylesheet" type="text/css" href="..<%=request.getContextPath() %>/content_common.css" />


i resolved it this way:
<%
String hrefPath = "href='..'" + request.getContextPath() + "/content_common.css";
%>
<html>
      <head>
            <title>
                  Search Results (DlrSearchResults)
            </title>
            <META HTTP-EQUIV="expires" CONTENT="0">
            <META HTTP-EQUIV="Pragma" CONTENT="no-cache">
            <META HTTP-EQUIV="Cache-Control" CONTENT="no-cache">
            <%= %>
            <link rel="stylesheet" type="text/css" <%=hrefPath%>>
      </head>


but what is the reason of this exception. I've many jsp this way and a don't reale have to chance all of them.

Best regards.
Re: URL exception [message #743580 is a reply to message #743334] Fri, 21 October 2011 15:37 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2704
Registered: July 2009
Senior Member

With which editor are you trying to open those JSPs? The Open With context menu on your JSP file will help you find out.

Nitin Dahyabhai
Eclipse WTP
IBM Emerging Technologies
Re: URL exception [message #757783 is a reply to message #743580] Mon, 21 November 2011 16:15 Go to previous message
Greg Mising name is currently offline Greg Mising nameFriend
Messages: 2
Registered: November 2011
Location: Los Angeles
Junior Member
When I try to open a jsp page using the context menu of the JSP file I get the following exception:

java.lang.NullPointerException
at org.eclipse.jst.jsf.common.metadata.query.internal.taglib.TaglibDomainContextImpl.<init>(TaglibDomainContextImpl.java:48)
at org.eclipse.jst.jsf.common.metadata.query.internal.MetaDataQueryContextFactory.createTaglibDomainModelContext(MetaDataQueryContextFactory.java:65)
at org.eclipse.jst.pagedesigner.editors.palette.TagImageManager.getSmallIconImage(TagImageManager.java:80)
at org.eclipse.jst.pagedesigner.converter.jsp.JSPConverterFactory$MyLabelProvider.getImage(JSPConverterFactory.java:96)
at org.eclipse.jst.pagedesigner.converter.HiddenTagConverter.getVisualImage(HiddenTagConverter.java:91)
at org.eclipse.jst.pagedesigner.parts.ElementEditPart.createHiddenProvider(ElementEditPart.java:238)
at org.eclipse.jst.pagedesigner.parts.ElementEditPart.refresh(ElementEditPart.java:275)
at org.eclipse.jst.pagedesigner.parts.ElementEditPart.refresh(ElementEditPart.java:264)
at org.eclipse.gef.editparts.AbstractEditPart.addNotify(AbstractEditPart.java:253)
at org.eclipse.gef.editparts.AbstractGraphicalEditPart.addNotify(AbstractGraphicalEditPart.java:223)
at org.eclipse.jst.pagedesigner.parts.NodeEditPart.addNotify(NodeEditPart.java:104)
at org.eclipse.jst.pagedesigner.parts.ElementEditPart.addNotify(ElementEditPart.java:155)
at org.eclipse.gef.editparts.AbstractEditPart.addChild(AbstractEditPart.java:212)
at org.eclipse.gef.editparts.AbstractEditPart.refreshChildren(AbstractEditPart.java:781)
at org.eclipse.jst.pagedesigner.parts.DocumentEditPart.refreshChildren(DocumentEditPart.java:134)
at org.eclipse.jst.pagedesigner.parts.DocumentEditPart.refreshChildren(DocumentEditPart.java:126)
at org.eclipse.gef.editparts.AbstractEditPart.refresh(AbstractEditPart.java:726)
at org.eclipse.gef.editparts.AbstractGraphicalEditPart.refresh(AbstractGraphicalEditPart.java:644)
at org.eclipse.jst.pagedesigner.parts.DocumentEditPart.refresh(DocumentEditPart.java:114)
at org.eclipse.gef.editparts.AbstractEditPart.addNotify(AbstractEditPart.java:253)
at org.eclipse.gef.editparts.AbstractGraphicalEditPart.addNotify(AbstractGraphicalEditPart.java:223)
at org.eclipse.jst.pagedesigner.parts.NodeEditPart.addNotify(NodeEditPart.java:104)
at org.eclipse.gef.editparts.AbstractEditPart.addChild(AbstractEditPart.java:212)
at org.eclipse.gef.editparts.SimpleRootEditPart.setContents(SimpleRootEditPart.java:105)
at org.eclipse.gef.ui.parts.AbstractEditPartViewer.setContents(AbstractEditPartViewer.java:617)
at org.eclipse.gef.ui.parts.AbstractEditPartViewer.setContents(AbstractEditPartViewer.java:626)
at org.eclipse.jst.pagedesigner.editors.SimpleGraphicalEditor.setModel(SimpleGraphicalEditor.java:430)
at org.eclipse.jst.pagedesigner.editors.HTMLEditor.connectDesignPage(HTMLEditor.java:364)
at org.eclipse.jst.pagedesigner.editors.HTMLEditor.createPages(HTMLEditor.java:444)
at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:348)
at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)
at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)
at org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:289)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2945)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2850)
at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2842)
at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2793)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2789)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2773)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2756)
at org.eclipse.ui.ide.IDE.openInternalEditorOnFileStore(IDE.java:1216)
at org.eclipse.ui.internal.ide.application.DelayedEventsProcessor$1.run(DelayedEventsProcessor.java:106)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

I am using eclipse version version 3.7.0 build I20110613-1736 with the Oracle Enterprise Pack for Eclipse version 11.1.1.7.3

This is really frustrating. Any help would be greatly appreciated.

Thanks,

Greg
Previous Topic:Reading an XML's schema via the Web Tools editor
Next Topic:CMDocument for an internal subset?
Goto Forum:
  


Current Time: Sun Jul 31 09:59:47 GMT 2016

Powered by FUDForum. Page generated in 0.01730 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software