Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Support Subversion 1.7
Support Subversion 1.7 [message #742588] Thu, 20 October 2011 12:18 Go to next message
sNop is currently offline sNop
Messages: 281
Registered: July 2009
Senior Member
Hi,

where dou you plan support for Subversion 1.7 ?
Re: Support Subversion 1.7 [message #742675 is a reply to message #742588] Thu, 20 October 2011 14:11 Go to previous messageGo to next message
sNop is currently offline sNop
Messages: 281
Registered: July 2009
Senior Member
sry, I want to write, when do you plan support for Subversion 1.7 ?

On 20. 10. 2011 18:18, sNop wrote:
> Hi,
>
> where dou you plan support for Subversion 1.7 ?
>
Re: Support Subversion 1.7 [message #743665 is a reply to message #742675] Fri, 21 October 2011 12:45 Go to previous messageGo to next message
Markus Jarderot is currently offline Markus Jarderot
Messages: 2
Registered: October 2011
Junior Member
SVNKit are currently working on it:
www.svnkit.com/download.php
Lastest stable version of SVNKit (1.3.6.1) is not compatible with Subversion 1.7.0 working copy format. However, SVNKit 1.7.0 is under development now and we plan to release it end of November 2011. Before that there will be a preview version available.

Right now you may use SVNKit 1.7.0-SNAPSHOT version, which is available in our maven repository or build SVNKit 1.7.0 from sources. SVNKit 1.7.0-SNAPSHOT is compatible both with the new and old working copy formats, but does not yer support all the Subversion operations.
Re: Support Subversion 1.7 [message #752294 is a reply to message #743665] Wed, 26 October 2011 06:46 Go to previous messageGo to next message
Tomas  is currently offline Tomas
Messages: 1
Registered: October 2011
Junior Member
Is there any way one could "plug" snapshot version of svnkit library to Subversive?
Re: Support Subversion 1.7 [message #752553 is a reply to message #742588] Wed, 26 October 2011 08:36 Go to previous messageGo to next message
Katie  is currently offline Katie
Messages: 1
Registered: October 2011
Junior Member
What kind of support do you need?
Are you looking for free support or paid support? Smile
Re: Support Subversion 1.7 [message #753386 is a reply to message #752553] Wed, 26 October 2011 20:30 Go to previous messageGo to next message
sNop is currently offline sNop
Messages: 281
Registered: July 2009
Senior Member
Hi Katie,

sry, I had in mind complatibility and no support. ;)

On 26. 10. 2011 14:36, Katie wrote:
> What kind of support do you need?
> Are you looking for free support or paid support? :)
Re: Support Subversion 1.7 [message #755587 is a reply to message #743665] Tue, 08 November 2011 16:16 Go to previous messageGo to next message
Lars Sonchocky-Helldorf is currently offline Lars Sonchocky-Helldorf
Messages: 13
Registered: July 2009
Junior Member
Markus Jarderot wrote on Fri, 21 October 2011 12:45
SVNKit are currently working on it:
www.svnkit.com/download.php
Lastest stable version of SVNKit (1.3.6.1) is not compatible with Subversion 1.7.0 working copy format. However, SVNKit 1.7.0 is under development now and we plan to release it end of November 2011. Before that there will be a preview version available.

Right now you may use SVNKit 1.7.0-SNAPSHOT version, which is available in our maven repository or build SVNKit 1.7.0 from sources. SVNKit 1.7.0-SNAPSHOT is compatible both with the new and old working copy formats, but does not yer support all the Subversion operations.


Couldn't Subversive add support for at least SVNKit 1.3.6 or 1.3.6.1 for now so that Subversion 1.6.17 is supported? I am currently getting all kind of strange behaviours when connecting to a Subversion 1.6.16 repository using the SVNKit 1.3.5 connector of polarion.

thanks,

Lars
Re: Support Subversion 1.7 [message #755616 is a reply to message #743665] Tue, 08 November 2011 20:49 Go to previous messageGo to next message
sNop is currently offline sNop
Messages: 281
Registered: July 2009
Senior Member
And what about JavaHL?

As I can see it support 1.7.x branch without problems:
http://subclipse.tigris.org/subclipse_1.8.x/changes.html

On 21. 10. 2011 18:45, Markus Jarderot wrote:
> SVNKit are currently working on it:
> www.svnkit.com/download.php
>> Lastest stable version of SVNKit (1.3.6.1) is not compatible with Subversion 1.7.0 working copy format. However, SVNKit 1.7.0 is under development now and we plan to release it end of November 2011. Before that there will be a preview version
>> available.
>>
>> Right now you may use SVNKit 1.7.0-SNAPSHOT version, which is available in our maven repository or build SVNKit 1.7.0 from sources. SVNKit 1.7.0-SNAPSHOT is compatible both with the new and old working copy formats, but does not yer support all the
>> Subversion operations.
>
Re: Support Subversion 1.7 [message #755858 is a reply to message #755616] Wed, 09 November 2011 15:32 Go to previous message
Lars Sonchocky-Helldorf is currently offline Lars Sonchocky-Helldorf
Messages: 13
Registered: July 2009
Junior Member
sNop wrote on Tue, 08 November 2011 20:49
And what about JavaHL?

As I can see it support 1.7.x branch without problems:
http://subclipse.tigris.org/subclipse_1.8.x/changes.html

On 21. 10. 2011 18:45, Markus Jarderot wrote:
> SVNKit are currently working on it:
> www.svnkit.com/download.php
>> Lastest stable version of SVNKit (1.3.6.1) is not compatible with Subversion 1.7.0 working copy format. However, SVNKit 1.7.0 is under development now and we plan to release it end of November 2011. Before that there will be a preview version
>> available.
>>
>> Right now you may use SVNKit 1.7.0-SNAPSHOT version, which is available in our maven repository or build SVNKit 1.7.0 from sources. SVNKit 1.7.0-SNAPSHOT is compatible both with the new and old working copy formats, but does not yer support all the
>> Subversion operations.
>


Obviously JavaHL is not supported on Mac OS X 10.7 (Lion):

http://stackoverflow.com/questions/6791989/subclipse-in-mac-os-lion

(the above link mentions Subclipse but it talks about JavaHL too)


cheers,

Lars
Previous Topic:Feature Request - Atomic Checkins across Eclipse Projects
Next Topic:Subversive and external JavaHL library in Win64, is it possible?
Goto Forum:
  


Current Time: Fri Aug 29 22:23:07 EDT 2014

Powered by FUDForum. Page generated in 0.03112 seconds