Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Virgo support in STS 2.8.0(Don't know how to add a server adaptor for Virgo in SpringSource Tool Suite 2.8.0)
Virgo support in STS 2.8.0 [message #742507] Thu, 20 October 2011 10:58 Go to next message
Martin W. is currently offline Martin W.
Messages: 8
Registered: June 2011
Junior Member
Hi everybody,

Back in the days I installed SpringSource Tool Suite (STS) 2.6.0 and added support for Virgo as explained at this site: issuetracker.springsource.com/browse/STS-1690 --- Since then I updated my STS several times (finally to 2.8.0) and Virgo can be used fine.

However, trying to setup STS 2.8.0 on two other machines, I faced the problem that I could not add the Virgo support in STS. There is neither any 'dm server extension' or anything named 'Virgo' or 'EclipseRT' in the Extension tab of STS's Dashboard, nor is there anything related in the list if I click 'Download additional server adapters' during adding of a server in the Servers tab.

A solution now was to install STS 2.7.2, but that can't be it... Sad

Any ideas how to add Virgo support in a freshly installed STS 2.8.0? Thank you very much in advance for your comments!

All the best,
Martin

Re: Virgo support in STS 2.8.0 [message #742518 is a reply to message #742507] Thu, 20 October 2011 11:08 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Try installing the Virgo tooling that is now part of the Virgo project. It is the STS code donated to Eclipse.org. Admittedly it's still under development, but you should find the milestone is just as stable as the STS support was.

See the wiki for details of how to install the Virgo tooling.

[Updated on: Thu, 20 October 2011 11:09]

Report message to a moderator

Re: Virgo support in STS 2.8.0 [message #742519 is a reply to message #742507] Thu, 20 October 2011 11:10 Go to previous messageGo to next message
Martin Lippert is currently offline Martin Lippert
Messages: 123
Registered: July 2009
Senior Member
Hey Martin!

You are absolutely right, the Virgo tooling isn't yet compatible with the just released STS 2.8.0 version. I will try to fix that for one of the upcoming snapshot builds and post a note once it works again. Meanwhile you would need to stay with STS 2.7.2.

HTH,
Martin
Re: Virgo support in STS 2.8.0 [message #742525 is a reply to message #742519] Thu, 20 October 2011 11:16 Go to previous messageGo to next message
Martin W. is currently offline Martin W.
Messages: 8
Registered: June 2011
Junior Member
I'll try that. Thx a lot to both of you!

Bests,
Martin
Re: Virgo support in STS 2.8.0 [message #755970 is a reply to message #742525] Thu, 10 November 2011 05:58 Go to previous message
arez  is currently offline arez
Messages: 7
Registered: May 2011
Junior Member
Hey I had a hard time finding it too. But if you go this update site http://dist.springsource.com/snapshot/TOOLS/nightly/e3.7 you'll be able to find it and it works on 2.8.0. I've been trying the virgo tools as well but I've been observing some regressions specially the MANIFEST generations. Hopefully the virgo team will fix that quickly Smile
Previous Topic:eclipse 3.5.0M1 release?
Next Topic:Can I replace Bundlor with the Maven Bundle plugin in STS?
Goto Forum:
  


Current Time: Fri Jul 25 06:41:53 EDT 2014

Powered by FUDForum. Page generated in 0.02219 seconds