Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Running tomcat 7.0.22 on Eclipse Helios 3.6.1
Running tomcat 7.0.22 on Eclipse Helios 3.6.1 [message #741526] Wed, 19 October 2011 12:06 Go to next message
Mahmoud Saleh is currently offline Mahmoud Saleh
Messages: 23
Registered: September 2011
Junior Member
hi
i have tomcat 7.0.22 and eclipse Helios 3.6.1
what WTP packages to install so that it will tomcat 7 will work fine with Helios 3.6.1
there are lots of packages in the following URL:

http://download.eclipse.org/webtools/updates

1- Patches.
2- Patches for tests.
3- Project Provided Components.
4- Web Tools Platform (WTP) 3.1.1.
5- Web Tools Platform SDK (WTP SDK) 3.1.1.
6- Web Tools Platform SDK (WTP SDK) 3.1.2.
7- Web Tools Platform Tests (WTP Tests) 3.1.2.
8- Web Tools Platform Tests (WTP Tests) 3.1.2.

will the WTP plugin be enough, or i have to make extra configuration ?
Re: Running tomcat 7.0.22 on Eclipse Helios 3.6.1 [message #741555 is a reply to message #741526] Wed, 19 October 2011 12:37 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1296
Registered: July 2009
Senior Member
On 10/19/2011 12:06 PM, Mahmoud Saleh wrote:
> hi
> i have tomcat 7.0.22 and eclipse Helios 3.6.1
> what WTP packages to install so that it will tomcat 7 will work fine
> with Helios 3.6.1
> there are lots of packages in the following URL:
>
> http://download.eclipse.org/webtools/updates
>
> 1- Patches.
> 2- Patches for tests.
> 3- Project Provided Components.
> 4- Web Tools Platform (WTP) 3.1.1.
> 5- Web Tools Platform SDK (WTP SDK) 3.1.1.
> 6- Web Tools Platform SDK (WTP SDK) 3.1.2.
> 7- Web Tools Platform Tests (WTP Tests) 3.1.2.
> 8- Web Tools Platform Tests (WTP Tests) 3.1.2.
>
> will the WTP plugin be enough, or i have to make extra configuration ?

The "Web Tools Platform (WTP)" will be enough, but you will want to use:

http://download.eclipse.org/webtools/repository/helios

That will let you choose a 3.2.x version for Eclipse 3.6.x. The URL you
cite is offering versions of WTP for Eclipse 3.5.x.

Cheers,
Larry
Re: Running tomcat 7.0.22 on Eclipse Helios 3.6.1 [message #741759 is a reply to message #741555] Wed, 19 October 2011 17:49 Go to previous messageGo to next message
Mahmoud Saleh is currently offline Mahmoud Saleh
Messages: 23
Registered: September 2011
Junior Member
@Larry, thanks i will try that out and tell you the results, but do i have to remove the old plugin first, if so how to do that ?
Re: Running tomcat 7.0.22 on Eclipse Helios 3.6.1 [message #742235 is a reply to message #741759] Thu, 20 October 2011 06:00 Go to previous messageGo to next message
Mahmoud Saleh is currently offline Mahmoud Saleh
Messages: 23
Registered: September 2011
Junior Member
but why the WTP Tests is 3.2.2 not 3.2.4 like the WTP and WTP SDK ?
Re: Running tomcat 7.0.22 on Eclipse Helios 3.6.1 [message #742424 is a reply to message #742235] Thu, 20 October 2011 09:28 Go to previous message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1296
Registered: July 2009
Senior Member
On 10/20/2011 6:00 AM, Mahmoud Saleh wrote:
> but why the WTP Tests is 3.2.2 not 3.2.4 like the WTP and WTP SDK ?

Nothing in the test plug-ins changed since 3.2.2 was released, so it
remains at 3.2.2. Since WTP SDK is the source for WTP, it's to be
expected that their versions will stay in sync when changes occur.

I'd say it is likely that no one has tested installing and uninstalling
WTP 3.1.2 on Eclipse 3.6.1 and then installing WTP 3.2.x. In theory it
should work, but you may be the first to test this scenario. You could
also think about trying a newer version. The "Eclipse IDE for Java EE
Developers" would already include WTP in the package.

Cheers,
Larry
Previous Topic:Classpath validator issue: Projects must be referenced by an EAR or WAR
Next Topic:How to get bundle org.eclipse.jpt.core 2.3.0?
Goto Forum:
  


Current Time: Thu Jul 24 11:39:01 EDT 2014

Powered by FUDForum. Page generated in 0.13403 seconds