Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » XSD » XSD 1.1 invalidated by Xerces 2.9.0(How to update Xerces?)
XSD 1.1 invalidated by Xerces 2.9.0 [message #741126] Wed, 19 October 2011 03:49 Go to next message
Martin Edlman is currently offline Martin Edlman
Messages: 1
Registered: October 2011
Junior Member
Hello,

I have a XSD conforming XSD 1.1 specification, but Eclipse XML/XSD editor displays errors from Xerces validator.

In my .eclipse/793567567/plugins there is org.apache.xerces_2.9.0.v201005080400.jar, but there is Xerces 2.11.0 available from Apache. This 2.11.0 version supports XSD 1.1 so I'd like to replace 2.9.0.

But I don't know how. When I tried to put xercesImpl.jar from Xerces-J-bin.2.11.0-xml-schema-1.1-beta.tar.gz which I downloaded from Apache, it didn't work, it gave errors.

Is it possible to update/replace Xerces plugin?

I tried OxygenXML Eclipse plugin but it uses Xerces 2.9.0 too.

My configuration:
Fedora 15
eclipse-platform-3.6.2-5.fc15.x86_64
java-1.6.0-openjdk-1.6.0.0-59.1.10.3.fc15.x86_64
jdk-1.6.0_27-fcs.x86_64
Re: XSD 1.1 invalidated by Xerces 2.9.0 [message #865979 is a reply to message #741126] Mon, 30 April 2012 13:21 Go to previous message
Olumide Olumide is currently offline Olumide Olumide
Messages: 1
Registered: April 2012
Junior Member
Can the XML schema editor now validate writing XSD 1.1 schemas now that Apache XERCES is XSD 1.1 compliant?

- Olumide
Previous Topic:xml.ecore
Next Topic:Migrating models based on one schema to models based on another schema (versioning)
Goto Forum:
  


Current Time: Tue Jul 29 23:05:21 EDT 2014

Powered by FUDForum. Page generated in 0.06135 seconds