Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Problem updating 4.1.1
Problem updating 4.1.1 [message #740714] Tue, 18 October 2011 20:21 Go to next message
Eclipse UserFriend
Downloaded and Installed
http://mirror.cc.vt.edu/pub/eclipse/eclipse/downloads/drops4/R-4.1.1-201109121510/eclipse-SDK-4.1.1-linux-gtk.tar.gz

But could not install the E4 UI components using the default rep:
e4 0.11 Updates - http://download.eclipse.org/e4/updates/0.11

Am I doing something wrong?

Here is my build: (Why doesn't it say 4.1.1??)
Version: 4.1.0
Build id: M20110912-1510

And the message I get from p2:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse e4 Modeled Workbench (Incubation)
0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
(org.eclipse.e4.ui.feature.feature.group
0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
Software currently installed: Eclipse SDK 4.1.0.M20110912-1510
(org.eclipse.sdk.ide 4.1.0.M20110912-1510)
Only one of the following can be installed at once:
Eclipse e4 Workbench SWT Renderer 0.10.0.v20110614-1530
(org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110614-1530)
Eclipse e4 Workbench SWT Renderer 0.10.0.v20110825-1422
(org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110825-1422)
Cannot satisfy dependency:
From: Eclipse e4 Rich Client Platform
1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781
(org.eclipse.e4.rcp.feature.group
1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781)
To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110825-1422]
Cannot satisfy dependency:
From: Eclipse e4 Modeled Workbench (Incubation)
0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
(org.eclipse.e4.ui.feature.feature.group
0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110614-1530]
Cannot satisfy dependency:
From: Eclipse Platform
4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD
(org.eclipse.platform.feature.group
4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD)
To: org.eclipse.rcp.feature.group
[4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG]
Cannot satisfy dependency:
From: Eclipse RCP 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG
(org.eclipse.rcp.feature.group 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG)
To: org.eclipse.e4.rcp.feature.group
[1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781]
Cannot satisfy dependency:
From: Eclipse Project SDK
4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD
(org.eclipse.sdk.feature.group
4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD)
To: org.eclipse.platform.feature.group
[4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD]
Cannot satisfy dependency:
From: Eclipse SDK 4.1.0.M20110912-1510 (org.eclipse.sdk.ide
4.1.0.M20110912-1510)
To: org.eclipse.sdk.feature.group
[4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD]
Re: Problem updating 4.1.1 [message #740730 is a reply to message #740714] Tue, 18 October 2011 20:48 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5462
Registered: July 2009
Senior Member
What did you selected - all you need to post install is the e4-tools all
other things are already installed.

Tom

Am 18.10.11 22:21, schrieb John E. Conlon:
> Downloaded and Installed
> http://mirror.cc.vt.edu/pub/eclipse/eclipse/downloads/drops4/R-4.1.1-201109121510/eclipse-SDK-4.1.1-linux-gtk.tar.gz
>
>
> But could not install the E4 UI components using the default rep:
> e4 0.11 Updates - http://download.eclipse.org/e4/updates/0.11
>
> Am I doing something wrong?
>
> Here is my build: (Why doesn't it say 4.1.1??)
> Version: 4.1.0
> Build id: M20110912-1510
>
> And the message I get from p2:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse e4 Modeled Workbench (Incubation)
> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
> (org.eclipse.e4.ui.feature.feature.group
> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
> Software currently installed: Eclipse SDK 4.1.0.M20110912-1510
> (org.eclipse.sdk.ide 4.1.0.M20110912-1510)
> Only one of the following can be installed at once:
> Eclipse e4 Workbench SWT Renderer 0.10.0.v20110614-1530
> (org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110614-1530)
> Eclipse e4 Workbench SWT Renderer 0.10.0.v20110825-1422
> (org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110825-1422)
> Cannot satisfy dependency:
> From: Eclipse e4 Rich Client Platform
> 1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781
> (org.eclipse.e4.rcp.feature.group
> 1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781)
> To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110825-1422]
> Cannot satisfy dependency:
> From: Eclipse e4 Modeled Workbench (Incubation)
> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
> (org.eclipse.e4.ui.feature.feature.group
> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
> To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110614-1530]
> Cannot satisfy dependency:
> From: Eclipse Platform
> 4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD
> (org.eclipse.platform.feature.group
> 4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD)
> To: org.eclipse.rcp.feature.group
> [4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG]
> Cannot satisfy dependency:
> From: Eclipse RCP 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG
> (org.eclipse.rcp.feature.group
> 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG)
> To: org.eclipse.e4.rcp.feature.group
> [1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781]
> Cannot satisfy dependency:
> From: Eclipse Project SDK
> 4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD
> (org.eclipse.sdk.feature.group
> 4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD)
> To: org.eclipse.platform.feature.group
> [4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD]
> Cannot satisfy dependency:
> From: Eclipse SDK 4.1.0.M20110912-1510 (org.eclipse.sdk.ide
> 4.1.0.M20110912-1510)
> To: org.eclipse.sdk.feature.group
> [4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD]
Re: Problem updating 4.1.1 [message #740757 is a reply to message #740730] Tue, 18 October 2011 21:30 Go to previous message
Eclipse UserFriend
Hi Tom,

Basically following Lars tutorial:
http://www.vogella.de/articles/EclipseE4/article.html

Just tried to do the same thing with eclipse-SDK-4.1 and it works - I
can install all the Tools and the UI. So it seems this is a problem
with the eclipse-SDK-4.1.1 and/or the compatibility with what is in the
repo.

-------
But with eclipse-SDK-4.1.1
I can't install all the Tools or all the UI. In the case of the tools,
I can't install all the e4-tools, because there is a problem with the
3.x Tools Bridge. When I leave the Tools Bridge out I can install just
the E4 Tools. Here is the message I get when I try to install the Tools
Bridge:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse e4 Tools Bridge for 3.x
(Incubation) 0.11.0.v20110613-2030-7B9M0FIhIexEm5xoUG7Uc
(org.eclipse.e4.tools.e3x.bridge.feature.feature.group
0.11.0.v20110613-2030-7B9M0FIhIexEm5xoUG7Uc)
Software currently installed: Eclipse SDK 4.1.0.M20110912-1510
(org.eclipse.sdk.ide 4.1.0.M20110912-1510)
Only one of the following can be installed at once:
EMF Common 2.7.0.v20110605-0747 (org.eclipse.emf.common
2.7.0.v20110605-0747)
EMF Common 2.7.0.v20110912-0920 (org.eclipse.emf.common
2.7.0.v20110912-0920)
Cannot satisfy dependency:
From: Eclipse e4 Rich Client Platform
1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781
(org.eclipse.e4.rcp.feature.group
1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781)
To: org.eclipse.emf.common.feature.group [2.7.0.v20110912-0920]
Cannot satisfy dependency:
From: Eclipse e4 Tools Bridge for 3.x (Incubation)
0.11.0.v20110613-2030-7B9M0FIhIexEm5xoUG7Uc
(org.eclipse.e4.tools.e3x.bridge.feature.feature.group
0.11.0.v20110613-2030-7B9M0FIhIexEm5xoUG7Uc)
To: org.eclipse.emf.common [2.7.0.v20110605-0747]
Cannot satisfy dependency:
From: EMF Common 2.7.0.v20110912-0920
(org.eclipse.emf.common.feature.group 2.7.0.v20110912-0920)
To: org.eclipse.emf.common [2.7.0.v20110912-0920]
Cannot satisfy dependency:
From: Eclipse Platform
4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD
(org.eclipse.platform.feature.group
4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD)
To: org.eclipse.rcp.feature.group
[4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG]
Cannot satisfy dependency:
From: Eclipse RCP 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG
(org.eclipse.rcp.feature.group 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG)
To: org.eclipse.e4.rcp.feature.group
[1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781]
Cannot satisfy dependency:
From: Eclipse Project SDK
4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD
(org.eclipse.sdk.feature.group
4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD)
To: org.eclipse.platform.feature.group
[4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD]
Cannot satisfy dependency:
From: Eclipse SDK 4.1.0.M20110912-1510 (org.eclipse.sdk.ide
4.1.0.M20110912-1510)
To: org.eclipse.sdk.feature.group
[4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD]



On 10/18/2011 03:48 PM, Tom Schindl wrote:
> What did you selected - all you need to post install is the e4-tools all
> other things are already installed.
>
> Tom
>
> Am 18.10.11 22:21, schrieb John E. Conlon:
>> Downloaded and Installed
>> http://mirror.cc.vt.edu/pub/eclipse/eclipse/downloads/drops4/R-4.1.1-201109121510/eclipse-SDK-4.1.1-linux-gtk.tar.gz
>>
>>
>> But could not install the E4 UI components using the default rep:
>> e4 0.11 Updates - http://download.eclipse.org/e4/updates/0.11
>>
>> Am I doing something wrong?
>>
>> Here is my build: (Why doesn't it say 4.1.1??)
>> Version: 4.1.0
>> Build id: M20110912-1510
>>
>> And the message I get from p2:
>>
>> Cannot complete the install because of a conflicting dependency.
>> Software being installed: Eclipse e4 Modeled Workbench (Incubation)
>> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
>> (org.eclipse.e4.ui.feature.feature.group
>> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
>> Software currently installed: Eclipse SDK 4.1.0.M20110912-1510
>> (org.eclipse.sdk.ide 4.1.0.M20110912-1510)
>> Only one of the following can be installed at once:
>> Eclipse e4 Workbench SWT Renderer 0.10.0.v20110614-1530
>> (org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110614-1530)
>> Eclipse e4 Workbench SWT Renderer 0.10.0.v20110825-1422
>> (org.eclipse.e4.ui.workbench.renderers.swt 0.10.0.v20110825-1422)
>> Cannot satisfy dependency:
>> From: Eclipse e4 Rich Client Platform
>> 1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781
>> (org.eclipse.e4.rcp.feature.group
>> 1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781)
>> To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110825-1422]
>> Cannot satisfy dependency:
>> From: Eclipse e4 Modeled Workbench (Incubation)
>> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74
>> (org.eclipse.e4.ui.feature.feature.group
>> 0.10.0.v20110613-2030-78Ab6FQFxCMosQTedwtB227B74)
>> To: org.eclipse.e4.ui.workbench.renderers.swt [0.10.0.v20110614-1530]
>> Cannot satisfy dependency:
>> From: Eclipse Platform
>> 4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD
>> (org.eclipse.platform.feature.group
>> 4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD)
>> To: org.eclipse.rcp.feature.group
>> [4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG]
>> Cannot satisfy dependency:
>> From: Eclipse RCP 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG
>> (org.eclipse.rcp.feature.group
>> 4.1.0.v20110822-9-CCFg5FjKACDpdMI9ReckBkdNqG)
>> To: org.eclipse.e4.rcp.feature.group
>> [1.1.0.v20110906-1038-7HAM77FTy21UwAhXBk4781]
>> Cannot satisfy dependency:
>> From: Eclipse Project SDK
>> 4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD
>> (org.eclipse.sdk.feature.group
>> 4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD)
>> To: org.eclipse.platform.feature.group
>> [4.1.0.v20110612-1800-9JExGoTFniL2AeFiT_tw1ch-slj6WvTpKS8E4MnmRVSZD]
>> Cannot satisfy dependency:
>> From: Eclipse SDK 4.1.0.M20110912-1510 (org.eclipse.sdk.ide
>> 4.1.0.M20110912-1510)
>> To: org.eclipse.sdk.feature.group
>> [4.1.0.v20110612-1800-7T7fABF8J01GyiOkT-xhpjvsLnrVOEkLT_Ja9Zk2-bCeD]
>
Previous Topic:Question regarding ESelectionService
Next Topic:extension passing messages to e4 UI, how to?
Goto Forum:
  


Current Time: Fri Nov 21 16:48:48 GMT 2014

Powered by FUDForum. Page generated in 0.02121 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software