Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse 4.x RCP feature is not a replacement for Eclipse 3.x RCP feature?
Eclipse 4.x RCP feature is not a replacement for Eclipse 3.x RCP feature? [message #737042] Fri, 14 October 2011 15:43 Go to next message
Ralf Ebert is currently offline Ralf EbertFriend
Messages: 168
Registered: July 2009
Senior Member
Hi,

is there a reason why the feature org.eclipse.rcp doesn't suffice to
run an RCP application on top of the compatibility layer? Both in 4.1
and 4.2 I had to add these plug-ins:

org.eclipse.e4.ui.workbench.addons.swt
org.eclipse.equinox.concurrent
org.eclipse.equinox.ds
org.eclipse.equinox.event
org.eclipse.equinox.util
org.eclipse.platform
org.eclipse.ui.forms
org.eclipse.ui.intro

on top of org.eclipse.rcp to run a RCP application. Shouldn't the
Eclipse 4.x RCP feature be a
drop-in-and-works-out-of-the-box-replacement for the 3.x one?

Greetings,

Ralf
Re: Eclipse 4.x RCP feature is not a replacement for Eclipse 3.x RCP feature? [message #749035 is a reply to message #737042] Tue, 25 October 2011 02:17 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 242
Registered: July 2009
Senior Member
Ralf Ebert wrote on Fri, 14 October 2011 11:43

is there a reason why the feature org.eclipse.rcp doesn't suffice to
run an RCP application on top of the compatibility layer? Both in 4.1
and 4.2 I had to add these plug-ins:


You're completely right:

org.eclipse.rcp should be self-sufficient for an E3.x app using the compatibility layer

org.eclipse.e4.rcp should be self-sufficient for a pure E4.x app.

We had talked about this, and I've filed bug 361877 to track it.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=361877
Previous Topic:How to access the liveeditor
Next Topic:What's new in e4 2011?
Goto Forum:
  


Current Time: Sun Nov 23 19:17:01 GMT 2014

Powered by FUDForum. Page generated in 0.02106 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software