Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Java7 and Deploying
Java7 and Deploying [message #736642] Fri, 14 October 2011 03:27 Go to next message
budili Missing name is currently offline budili Missing name
Messages: 64
Registered: May 2010
Member
Hallo,

i have a rcp application which uses Java7 features. In my IDE all works fine and i can use the java7 features. I have define and set the execution environment on JavaSE 1.7.
All works fine! But if i deploy my application, the code fragments which uses Java7 features dont work. I get the following Exception:

Quote:

For example (using String-Switch):
Cannot switch on a value of type String for source level below 1.7. Only convertible int values or enum constants are permitted.


My application uses the correct runtime (JRE7). I dont know where's the problem.
Can someone help me ...

THX
Budi
Re: Java7 and Deploying [message #739439 is a reply to message #736642] Mon, 17 October 2011 09:31 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 14.10.2011 09:27, budili wrote:
> Hallo,
>
> i have a rcp application which uses Java7 features. In my IDE all
> works fine and i can use the java7 features. I have define and set the
> execution environment on JavaSE 1.7. All works fine! But if i deploy
> my application, the code fragments which uses Java7 features dont
> work. I get the following Exception:
>
> Quote:
>> For example (using String-Switch):
>> Cannot switch on a value of type String for source level below 1.7.
>> Only convertible int values or enum constants are permitted.
>
>
> My application uses the correct runtime (JRE7). I dont know where's
> the problem.
> Can someone help me ...
Maybe you did not use 1.7 to compile the source when doing the export.

Dani
>
> THX
> Budi
Re: Java7 and Deploying [message #740104 is a reply to message #739439] Tue, 18 October 2011 02:49 Go to previous messageGo to next message
budili Missing name is currently offline budili Missing name
Messages: 64
Registered: May 2010
Member
Quote:

Maybe you did not use 1.7 to compile the source when doing the export.


Hm that's possible, but in the Preferences i have set the jre on 1.7. Is this enough?
Re: Java7 and Deploying [message #754417 is a reply to message #740104] Wed, 02 November 2011 09:55 Go to previous message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
On 18.10.2011 08:49, budili wrote:
> Quote:
>> Maybe you did not use 1.7 to compile the source when doing the export.
>
>
> Hm that's possible, but in the Preferences i have set the jre on 1.7.
> Is this enough?
Make sure you also specify the execution environment in the manifest file.

Dani
Previous Topic:Eclipse RCP app slow on secondary display
Next Topic:Given a Bundle, how can I find what extensions it provides?
Goto Forum:
  


Current Time: Wed Apr 16 19:00:02 EDT 2014

Powered by FUDForum. Page generated in 0.02277 seconds