Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Does class diagram support Chinese characters?(When named a class in Chinese, the name is not rendered properly on class diagram.)
Does class diagram support Chinese characters? [message #735201] Tue, 11 October 2011 04:20 Go to next message
zighouse  is currently offline zighouse
Messages: 1
Registered: October 2011
Junior Member
Changes a class' name into Chinese on class diagram, and the name in the class notation dispeared. For example:
1. drop a class into the class diagram;
2. and rename it as '实物';
3. and then, it displayed a class notation with blank name on diagram.

While, in .uml file which encoding as utf-8, there is a class named as '实物' correctly. So as the name shown in project explorer window for .umlclass correctly.

Save it as image file, and get a correctly named png image.

figure1: eclipse window
index.php/fa/4209/0/

figure2: saved as image file
index.php/fa/4210/0/

UML2 Tools SDK (Incubation), version: 0.9.0.v200906190654

Is it a registered or fixed bug? Or it is not considered as a bug?

[Updated on: Tue, 11 October 2011 05:45]

Report message to a moderator

Re: Does class diagram support Chinese characters? [message #736164 is a reply to message #735201] Thu, 13 October 2011 12:55 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 3844
Registered: July 2009
Senior Member
Hi

Make sure that you have set your project to be UTF-8 and if that doesn't
fix it submit a bug.

Regards

Ed Willink

On 11/10/2011 09:20, zighouse wrote:
> Changes a class' name into Chinese on class diagram, and the name in the class notation dispeared. For example:
> 1. drop a class into the class diagram;
> 2. and rename it as '实物';
> 3. and then, it displayed a class notation with blank name on diagram.
>
> While, in .uml file which encoding as utf-8, there is a class named as '实物' correctly. So as the name shown in project explorer window for .umlclass correctly.
>
> Save it as image file, and get a correctly named png image.
>
> figure1: eclipse window
>
>
> figure2: saved as image file
>
>
> UML2 Tools SDK (Incubation), version: 0.9.0.v200906190654
>
> Is it a registered or fixed bug? Or it is not considered as a bug?
>
Previous Topic:Problem installing UML Tools on Eclipse Galileo
Next Topic:About state charts, how can I add entry/exit/do/transitions actions?
Goto Forum:
  


Current Time: Sun Apr 20 15:49:33 EDT 2014

Powered by FUDForum. Page generated in 0.02684 seconds