Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit » install fails in eclipse classic/java developers
install fails in eclipse classic/java developers [message #734764] Sun, 09 October 2011 20:32 Go to next message
julius  is currently offline julius Friend
Messages: 17
Registered: October 2011
Junior Member
hi,

ive installed egit on a 32bit linux system without problems, but i cant install egit on a 32bit windows machine in the current eclipse.

eclipse classis and eclipse for java developers both say:
Unable to connect to repository http___download.eclipse.org/egit/updates/content.xml
Unable to connect to repository http___download.eclipse.org/egit/updates/content.xml
Connection refused: connect


why is that?

NOTE: http___ is of course http semocilon slash slash, the forum does not allow users with less than 5 posts to post links.

[Updated on: Sun, 09 October 2011 20:33]

Report message to a moderator

Re: install fails in eclipse classic/java developers [message #734789 is a reply to message #734764] Sun, 09 October 2011 23:10 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 612
Registered: July 2009
Senior Member
- Did you check if you can reach other p2 repositories on
http://download.eclipse.org from this machine ?
- Maybe you are behind a firewall and need to adjust Eclipse proxy settings ?
Re: install fails in eclipse classic/java developers [message #734958 is a reply to message #734789] Mon, 10 October 2011 14:20 Go to previous messageGo to next message
julius  is currently offline julius Friend
Messages: 17
Registered: October 2011
Junior Member
yes i am behind a firewall that i do not control.
but outgoing connections are not a problem, i can retrieve the content from http___download.eclipse.org/egit/updates/ with firefox.

in general -> netweork connections -> active provider is set to native.
in proxy entries is one active, HTTP 127.0.0.1 57717 native false

i did not change these settings...but this cant be a eclipse default? or does eclipse come with its own proxy software?


EDIT: setting this option to direct and installing worked

[Updated on: Mon, 10 October 2011 14:29]

Report message to a moderator

Re: install fails in eclipse classic/java developers [message #736126 is a reply to message #734958] Thu, 13 October 2011 16:10 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 612
Registered: July 2009
Senior Member
Maybe it depends on OS if native Proxy Provider works.
Previous Topic:New Java project from "local" repo
Next Topic:Can one have the standard eclipse workspace and a standard git repository?
Goto Forum:
  


Current Time: Tue Nov 25 00:38:49 GMT 2014

Powered by FUDForum. Page generated in 0.13484 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software