Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Cannot create a data set
Cannot create a data set [message #733698] Wed, 05 October 2011 12:59 Go to next message
Fabiano  is currently offline Fabiano
Messages: 4
Registered: October 2011
Junior Member
Hi everyone, I have BIRT 2.6.2 installed on a Rational Team Concert 3.0.1 package and when I'm creating a data set and after selecting all columns and parameters on the "New Data Set" window, when I click on "Finish" button, nothing happens. Then, if I click on the same button again, the window is closed and the data set is not created and I don't receive any error message from BIRT/RTC.

I have no clue on why this is happening, because the BIRT integration to RTC went successful and I could create a data source. If someone could give me a help on this, I appreciate.
Re: Cannot create a data set [message #733760 is a reply to message #733698] Wed, 05 October 2011 14:57 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Check the workspace metadata folder for a .log file. See if anything is
in the log.

Jason

On 10/5/2011 8:59 AM, Fabiano wrote:
> Hi everyone, I have BIRT 2.6.2 installed on a Rational Team Concert
> 3.0.1 package and when I'm creating a data set and after selecting all
> columns and parameters on the "New Data Set" window, when I click on
> "Finish" button, nothing happens. Then, if I click on the same button
> again, the window is closed and the data set is not created and I don't
> receive any error message from BIRT/RTC.
> I have no clue on why this is happening, because the BIRT integration to
> RTC went successful and I could create a data source. If someone could
> give me a help on this, I appreciate.
Re: Cannot create a data set [message #733807 is a reply to message #733760] Wed, 05 October 2011 17:04 Go to previous messageGo to next message
Fabiano  is currently offline Fabiano
Messages: 4
Registered: October 2011
Junior Member
Hi Jason, I should have checked and posted the log file before. For the first click, I'm getting this error:

!ENTRY org.eclipse.ui 4 0 2011-10-05 09:58:08.609
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NoClassDefFoundError: org/eclipse/datatools/connectivity/oda/design/CustomData

For the second one, a different error:

!ENTRY com.ibm.team.repository.client.util.ThreadCheck 4 1000 2011-10-05 09:58:10.546
!MESSAGE Long-running operations prohibited on this thread
!STACK 0
java.lang.IllegalStateException: Long-running operations prohibited on this thread

I'm attaching part of the log file with these 2 errors, for reference
  • Attachment: birt.log
    (Size: 10.05KB, Downloaded 53 times)
Re: Cannot create a data set [message #733835 is a reply to message #733807] Wed, 05 October 2011 18:12 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What datasource are you using?

Jason

On 10/5/2011 1:04 PM, Fabiano wrote:
> Hi Jason, I should have checked and posted the log file before. For the first click, I'm getting this error:
>
> !ENTRY org.eclipse.ui 4 0 2011-10-05 09:58:08.609
> !MESSAGE Unhandled event loop exception
> !STACK 0
> java.lang.NoClassDefFoundError: org/eclipse/datatools/connectivity/oda/design/CustomData
>
> For the second one, a different error:
>
> !ENTRY com.ibm.team.repository.client.util.ThreadCheck 4 1000 2011-10-05 09:58:10.546
> !MESSAGE Long-running operations prohibited on this thread
> !STACK 0
> java.lang.IllegalStateException: Long-running operations prohibited on this thread
>
> I'm attaching part of the log file with these 2 errors, for reference
Re: Cannot create a data set [message #733839 is a reply to message #733835] Wed, 05 October 2011 18:45 Go to previous messageGo to next message
Fabiano  is currently offline Fabiano
Messages: 4
Registered: October 2011
Junior Member
I'm using the WORKITEMS_SNAPSHOT from a jazz data source repository
Re: Cannot create a data set [message #733848 is a reply to message #733839] Wed, 05 October 2011 18:50 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Is that a scripted data source or an ODA developed by Rational?

Jason

On 10/5/2011 2:45 PM, Fabiano wrote:
> I'm using the WORKITEMS_SNAPSHOT from a jazz data source repository
Re: Cannot create a data set [message #733862 is a reply to message #733848] Wed, 05 October 2011 20:00 Go to previous messageGo to next message
Fabiano  is currently offline Fabiano
Messages: 4
Registered: October 2011
Junior Member
I believe it's a ODA developed by Rational, because I didn't have to create anything, only point BIRT to get data from there.
Re: Cannot create a data set [message #733887 is a reply to message #733862] Wed, 05 October 2011 20:56 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

It looks like the data source oda is either missing or can not locate a
class in the oda. You may need to check with the Rational team.

Jason

On 10/5/2011 4:00 PM, Fabiano wrote:
> I believe it's a ODA developed by Rational, because I didn't have to
> create anything, only point BIRT to get data from there.
Previous Topic:BIRT 3.7
Next Topic:Group date time by 30 min intervals.
Goto Forum:
  


Current Time: Tue Sep 30 12:04:48 GMT 2014

Powered by FUDForum. Page generated in 0.02892 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software