Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » [SOLVED] not recovering a Date field(EclipseLink 2.0 is not recovering a Date field, with TopLink this works perfectly)
icon13.gif  [SOLVED] not recovering a Date field [message #732022] Mon, 03 October 2011 13:49
FiruzzZ Mising name is currently offline FiruzzZ Mising name
Messages: 19
Registered: October 2011
Junior Member
Its not recoverying a simple Date field.

part of the Model

    @Basic(optional = false)
    @Column(name = "fechaalta", nullable = false, insertable = false, updatable = false, columnDefinition = "timestamp with time zone NOT NULL DEFAULT now()")
    @Temporal(TemporalType.TIMESTAMP)
    private Date fechaalta;



I tried with entityManager.find, createNativeQuery (Natives query over this model also doesn't work), createQuery, using "refresh" Hint .. nothing works.
This has been working on TopLink for years
Im using PostgreSQL 8.4


.........24hrs later
Hints usually are String... and IF the hints does not exist, no error is triggers (like "toplink.refresh" indeed "eclipselink.refresh")
From now.. I will use QueryHints.REFRESH so if I change the JPA persistence provider at least I will get a package error.
Well that its all.. and sorry if my english is not clear.

[Updated on: Tue, 04 October 2011 07:26]

Report message to a moderator

Previous Topic:Why does @OrderBy add UPPER() to the ORDER BY clause?
Next Topic:Multi-tenancy and @PersistenceContext
Goto Forum:
  


Current Time: Thu Jul 31 11:49:48 EDT 2014

Powered by FUDForum. Page generated in 0.02242 seconds