Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » submodule and foreach
submodule and foreach [message #731929] Mon, 03 October 2011 13:57 Go to next message
atao Missing name is currently offline atao Missing nameFriend
Messages: 13
Registered: July 2009
Junior Member
I'm trying to use loops as described on
http://wiki.eclipse.org/Riena_Navigation#Loops

But I'm quite lost:
- only "subModule" elements are taken in account;
"submodule" and "foreach" are ignored.
- the "subModule" element doesn't have "typeId" and "instanceId" attributes
but only "nodeId" one: how can I specify its "instanceId" part?

Is there any full exemple using loops?

Pierre
Re: submodule and foreach [message #733441 is a reply to message #731929] Tue, 04 October 2011 18:09 Go to previous messageGo to next message
Christian Campo is currently offline Christian CampoFriend
Messages: 590
Registered: July 2009
Senior Member
Am 03.10.11 15:57, schrieb atao:
> I'm trying to use loops as described on
> http://wiki.eclipse.org/Riena_Navigation#Loops
>
> But I'm quite lost: - only "subModule" elements are taken in account; "submodule" and "foreach" are ignored.
> - the "subModule" element doesn't have "typeId" and "instanceId" attributes
> but only "nodeId" one: how can I specify its "instanceId" part?
>
> Is there any full exemple using loops?
>
> Pierre
>
We discussed that today and believe that the foreach loop used to be in the documentation of the assembly schema (the
first version). Now that we use assembly2 with a different schema, that xml part was removed from the schema because we
just it was first not helpful and because we werenot sure that it ever worked......

Its an oversight that it is still on the wiki page. If you want a for each loop you have to write an assemble (java
code) and iterate in there.....

hope that helps

christian
Re: submodule and foreach [message #743633 is a reply to message #733441] Fri, 21 October 2011 16:19 Go to previous message
atao Missing name is currently offline atao Missing nameFriend
Messages: 13
Registered: July 2009
Junior Member
Christian,

Thank you for your answer.

Pierre
Previous Topic:The horizontal scrollbar is not visible! Why?
Next Topic:to change language after starting an application
Goto Forum:
  


Current Time: Sun Nov 23 08:43:15 GMT 2014

Powered by FUDForum. Page generated in 0.02421 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software