Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Create php file does not create the file in project folder on disk(When I create a new php file from the project in PHP Explorer, it creates the file in my web server root directory instead of in the project folder on disk)
Create php file does not create the file in project folder on disk [message #731449] Sat, 01 October 2011 04:07
Chris Rizzo is currently offline Chris RizzoFriend
Messages: 1
Registered: October 2011
Junior Member
Version info:

-Windows 7
-Eclipse Indigo (Build id: 20110615-0604)
-PHP Development Tools (PDT) SDK Feature 3.0.0.v20110516-1100-77--84_23JBVgSVXO7XGJz0VLa9O

1. With PHP Perspective open, right click my PHP project in PHP Explorer.
2. Select "New" > "PHP File"
3. New PHP File dialog: Source Folder = "/php", File Name = "newfile.php"
4. The new file is under the PHP project in Eclipse PHP Explorer, but the file is not created in the php subdirectory at the Location of the project (or even in the root Location of the project - see attached Project Properties dialog jpg image). For some reason, the new php file is created one level above the project folder in the htdocs folder of the apache server (The php directory is a subdirectory of the htdocs directory).

Is this a bug or could I be doing something wrong?

There are also additional problems finding and running a php file under Xdebug because the paths are all mixed up in PDT. Adding Path Mappings via "Window > Preferences > PHP > PHP Servers > Default PHP Web Server > Edit > Path Mapping" does not work either.
Previous Topic:Class and method definitions on remote server?
Next Topic:Code folding of IF statements, WHILE, FOR loops not available?
Goto Forum:

Current Time: Mon Jun 18 12:01:36 GMT 2018

Powered by FUDForum. Page generated in 0.01610 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top