Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » 'birtutility' is undefined
'birtutility' is undefined [message #730291] Wed, 28 September 2011 01:27 Go to next message
Vivek  is currently offline Vivek
Messages: 2
Registered: September 2011
Junior Member
Hi,
I am using BIRT ECLIPSE VERSION 2010 in windows 7 (with 1GB RAM) with IE8 in
compatible mode as my project doesn't support IE8.
Few days back the report tool was working fine.
However, I am getting some error from the last two days
The error shown by the Browser is:

Webpage error details


Message: 'Constants' is undefined
Line: 1958
Char: 2
Code: 0


Message: 'Constants' is undefined
Line: 1980
Char: 5
Code: 0


Message: Object expected
Line: 2024
Char: 3
Code: 0


Message: 'birtUtility' is undefined
Line: 2048
Char: 4
Code: 0


But I didn't made any changes in the birtutility.js or any other file.
I am attaching the screen shot foe reference.
  • Attachment: birtError.PNG
    (Size: 11.89KB, Downloaded 102 times)
Re: 'birtutility' is undefined [message #730549 is a reply to message #730291] Wed, 28 September 2011 11:30 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

How do you have the viewer deployed? Are you getting this error in the
designer?

Jason

On 9/28/2011 1:27 AM, Vivek wrote:
> Hi,
> I am using BIRT ECLIPSE VERSION 2010 in windows 7 (with 1GB RAM) with IE8 in
> compatible mode as my project doesn't support IE8.
> Few days back the report tool was working fine.
> However, I am getting some error from the last two days
> The error shown by the Browser is:
>
> Webpage error details
>
>
> Message: 'Constants' is undefined
> Line: 1958
> Char: 2
> Code: 0
>
>
> Message: 'Constants' is undefined
> Line: 1980
> Char: 5
> Code: 0
>
>
> Message: Object expected
> Line: 2024
> Char: 3
> Code: 0
>
>
> Message: 'birtUtility' is undefined
> Line: 2048
> Char: 4
> Code: 0
>
>
> But I didn't made any changes in the birtutility.js or any other file.
> I am attaching the screen shot foe reference.
Re: 'birtutility' is undefined [message #730748 is a reply to message #730549] Thu, 29 September 2011 00:10 Go to previous messageGo to next message
Vivek  is currently offline Vivek
Messages: 2
Registered: September 2011
Junior Member
Hi Jason Weathersby,

No I am not getting this error in the designer but I am getting this error when i deployed it on local server using the JBOSS server.
Re: 'birtutility' is undefined [message #730939 is a reply to message #730748] Thu, 29 September 2011 10:49 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

What version of BIRT and JBOSS are you using? How did you deploy it?

Jason

On 9/29/2011 12:10 AM, Vivek wrote:
> Hi Jason Weathersby,
>
> No I am not getting this error in the designer but I am getting this
> error when i deployed it on local server using the JBOSS server.
>
Re: 'birtutility' is undefined [message #765372 is a reply to message #730291] Tue, 13 December 2011 18:24 Go to previous messageGo to next message
Fisco  is currently offline Fisco
Messages: 1
Registered: December 2011
Junior Member
Hi Jason I have the same problem

Could you tell me how didi you solve this problem????

Thanks
Re: 'birtutility' is undefined [message #765750 is a reply to message #765372] Wed, 14 December 2011 10:54 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

I did not get the error. Vivek did. Is yours happening in JBoss as
well? If so what version and how did you deploy?

Jason

On 12/13/2011 6:24 PM, Fisco wrote:
> Hi Jason I have the same problem
> Could you tell me how didi you solve this problem????
>
> Thanks
Re: 'birtutility' is undefined [message #768011 is a reply to message #765750] Mon, 19 December 2011 06:39 Go to previous messageGo to next message
Jeevan Sunkersett is currently offline Jeevan Sunkersett
Messages: 7
Registered: July 2009
Junior Member
Hi,

Is there any solution to this issue ?

I am getting the same error and same screen like originally posted by Vivek (birtError.png)

My environment:
Application server is JBoss 5.1-GA,
Fronted by an Apache httpd server (using mod_jk)
BIRT report viewer: I think the same as what has been mentioned by others in this post. (I do not how to find that out, please explain)


Further to this, my reports work fine when viewed with a local I.P address, eg. 10.0.1.9 (that is inside the local network), but when viewed using the registered domain (e.g. https://www.mydomain.com/reports) , it shows up as originally described by Vivek.

I did a bit of debugging and found,
the URL of the image, is something like

https://online.sai.org.in/frameset?__id=birtViewer&__report=%2FWEB-INF%2Freport%2FOnline_Transaction_History.rptdesign&__masterpage=true&__format=html

Using developer tools (firebug) found the element to be:

<input name="parameter" title="Run report" class="birtviewer_clickable" type="image" alt="Run report" src="birt/images/Report_parameters.gif"/>

if I replace the src parameter with the fully qualified path;
meaning src='https://online.sai.org.in/webcontent/birt/images/Report_parameters.gif'

the image is displayed.

Can somebody shed some light on this/ give me a few pointers ?

thank you,
Jeevan








Re: 'birtutility' is undefined [message #768139 is a reply to message #768011] Mon, 19 December 2011 11:39 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Jeevan,

Look over this thread.
http://www.birt-exchange.org/org/forum/index.php/topic/21462-networking-problem-with-birt-generated-resource-urls/

Jason

On 12/19/2011 6:40 AM, Jeevan Sunkersett wrote:
> Hi,
>
> Is there any solution to this issue ?
>
> I am getting the same error and same screen like originally posted by
> Vivek (birtError.png)
>
> My environment:
> Application server is JBoss 5.1-GA, Fronted by an Apache httpd server
> (using mod_jk)
> BIRT report viewer: I think the same as what has been mentioned by
> others in this post. (I do not how to find that out, please explain)
>
>
> Further to this, my reports work fine when viewed with a local I.P
> address, eg. 10.0.1.9 (that is inside the local network), but when
> viewed using the registered domain (e.g.
> https://www.mydomain.com/reports) , it shows up as originally described
> by Vivek.
>
> I did a bit of debugging and found,
> the URL of the image, is something like
>
> https://online.sai.org.in/frameset?__id=birtViewer&__report=%2FWEB-INF%2Freport%2FOnline_Transaction_History.rptdesign&__masterpage=true&__format=html
>
>
> Using developer tools (firebug) found the element to be:
>
> <input name="parameter" title="Run report" class="birtviewer_clickable"
> type="image" alt="Run report" src="birt/images/Report_parameters.gif"/>
>
> if I replace the src parameter with the fully qualified path; meaning
> src='https://online.sai.org.in/webcontent/birt/images/Report_parameters.gif'
>
>
> the image is displayed.
>
> Can somebody shed some light on this/ give me a few pointers ?
>
> thank you,
> Jeevan
>
>
>
>
>
>
>
>
>
Previous Topic:Drill through to javascript function instead of URL
Next Topic:How to create IReportDocument from stream
Goto Forum:
  


Current Time: Mon Jul 28 06:32:27 EDT 2014

Powered by FUDForum. Page generated in 0.02692 seconds