Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Forcing locale of Eclipse RCP application is ignored
Forcing locale of Eclipse RCP application is ignored [message #729437] Mon, 26 September 2011 07:57 Go to next message
js Missing name is currently offline js Missing name
Messages: 73
Registered: July 2009
Member
I have created an eclipse RCP application with some language fragments in German. When I run the application (myApplication.exe) it starts with the default language fragments (English).

Now I would like to test that it will load German fragments. In the myApplication.ini file I have added:

-nl de

but it still runs the English fragments.

If I specify -nl de during development in the eclipse product configuration under Program Arguments (on the Launching tab) the German fragments are loaded just fine.

Any ideas why the option -nl de is ignored in the exported product?

EDIT:
Adding the option to the target in a shortcut works:

"C:\application\myApplication.exe" -nl de

but still no success when specifying it in the myApplication.ini file.



[Updated on: Mon, 26 September 2011 08:23]

Report message to a moderator

Re: Forcing locale of Eclipse RCP application is ignored [message #730262 is a reply to message #729437] Wed, 28 September 2011 02:44 Go to previous messageGo to next message
karthykeyan Palanisamy is currently offline karthykeyan Palanisamy
Messages: 4
Registered: May 2010
Location: Bangalore
Junior Member

Hi

Create a properties file for the all the widget in german and that will take care of loading the data.

Thanks and regards
Karthikeyan


Thanks and Regards
Karthikeyan
Re: Forcing locale of Eclipse RCP application is ignored [message #730811 is a reply to message #730262] Thu, 29 September 2011 08:45 Go to previous messageGo to next message
js Missing name is currently offline js Missing name
Messages: 73
Registered: July 2009
Member
I have created properties files for all my text and it works fine inside eclipse. But for some reason specifying -nl de in the .ini file of the exported product does not work.
Re: Forcing locale of Eclipse RCP application is ignored [message #731639 is a reply to message #730811] Sun, 02 October 2011 07:48 Go to previous message
sschmitz is currently offline sschmitz
Messages: 9
Registered: July 2011
Junior Member
You must add
"-nl
de"
to your .ini file, not "-nl de". Every option and every argument must be on a seperat line.
Previous Topic:Approach between the two View
Next Topic:eclipse.ini for Windows built on Linux is unix format
Goto Forum:
  


Current Time: Tue Sep 16 13:25:08 GMT 2014

Powered by FUDForum. Page generated in 0.03144 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software