Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu
Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu [message #728454] Fri, 23 September 2011 10:05 Go to next message
Ron  is currently offline Ron Friend
Messages: 3
Registered: September 2011
Junior Member
Hi Guys,

I have downloaded and unziped the virgo-tomcat-server-3.0.1.RELEASE.zip, set the JAVA_HOME then started virgo. The first time around, it shuts itself down and I get this:

[2011-09-23 10:55:50.284] startup-tracker <KE0001I> Kernel starting.
[2011-09-23 10:55:55.889] service-monitor-thread-1 <KE0100W> Reference '&repository' in bundle 'org.eclipse.virgo.kernel.osgi' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.repository.Repository)'.
[2011-09-23 10:55:55.907] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:55:55.909] service-monitor-thread-1 <KE0100W> Reference '&moduleContextAccessor' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.module.ModuleContextAccessor)'.
[2011-09-23 10:55:55.911] service-monitor-thread-1 <KE0100W> Reference '&packageAdminUtil' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.PackageAdminUtil)'.
[2011-09-23 10:55:55.912] service-monitor-thread-1 <KE0100W> Reference '&userRegionBundleContext' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.osgi.framework.BundleContext)(org.eclipse.virgo.kernel.regionContext=true))'.
[2011-09-23 10:55:55.914] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:55:55.924] service-monitor-thread-1 <KE0100W> Reference '&deployer' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.core.ApplicationDeployer)'.
[2011-09-23 10:55:55.926] service-monitor-thread-1 <KE0100W> Reference '&runtimeArtifactModel' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.model.RuntimeArtifactModel)'.
[2011-09-23 10:55:55.927] service-monitor-thread-1 <KE0100W> Reference '&objectNameCreator' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.model.management.RuntimeArtifactModelObjectNameCreator)'.
[2011-09-23 10:55:55.928] service-monitor-thread-1 <KE0100W> Reference '&applicationDeployer' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.core.ApplicationDeployer)'.
[2011-09-23 10:55:55.933] service-monitor-thread-1 <KE0100W> Reference '&globalRegion' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.eclipse.equinox.region.Region)(org.eclipse.virgo.kernel.region.name=global))'.
[2011-09-23 10:55:55.934] service-monitor-thread-1 <KE0100W> Reference '&userRegion' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.eclipse.equinox.region.Region)(org.eclipse.virgo.kernel.region.name=org.eclipse.virgo.region.user))'.
[2011-09-23 10:55:55.935] service-monitor-thread-1 <KE0100W> Reference '&packageAdminUtil' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.PackageAdminUtil)'.
[2011-09-23 10:55:55.937] service-monitor-thread-1 <KE0100W> Reference '&userBundleContext' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.osgi.framework.BundleContext)(org.eclipse.virgo.kernel.regionContext=true))'.
[2011-09-23 10:55:55.939] service-monitor-thread-1 <KE0100W> Reference '&repository' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.repository.Repository)'.
[2011-09-23 10:55:55.941] service-monitor-thread-1 <KE0100W> Reference '&osgiFramework' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.OsgiFramework)'.
[2011-09-23 10:55:55.943] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:55:55.944] service-monitor-thread-1 <KE0100W> Reference '&importExpander' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.ImportExpander)'.
[2011-09-23 10:56:10.889] service-monitor-thread-1 <KE0100W> Reference '&repository' in bundle 'org.eclipse.virgo.kernel.osgi' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.repository.Repository)'.
[2011-09-23 10:56:10.908] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:56:10.913] service-monitor-thread-1 <KE0100W> Reference '&moduleContextAccessor' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.module.ModuleContextAccessor)'.
[2011-09-23 10:56:10.915] service-monitor-thread-1 <KE0100W> Reference '&packageAdminUtil' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.PackageAdminUtil)'.
[2011-09-23 10:56:10.917] service-monitor-thread-1 <KE0100W> Reference '&userRegionBundleContext' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.osgi.framework.BundleContext)(org.eclipse.virgo.kernel.regionContext=true))'.
[2011-09-23 10:56:10.919] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:56:10.925] service-monitor-thread-1 <KE0100W> Reference '&deployer' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.core.ApplicationDeployer)'.
[2011-09-23 10:56:10.927] service-monitor-thread-1 <KE0100W> Reference '&runtimeArtifactModel' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.model.RuntimeArtifactModel)'.
[2011-09-23 10:56:10.929] service-monitor-thread-1 <KE0100W> Reference '&objectNameCreator' in bundle 'org.eclipse.virgo.kernel.shell' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.model.management.RuntimeArtifactModelObjectNameCreator)'.
[2011-09-23 10:56:10.933] service-monitor-thread-1 <KE0100W> Reference '&applicationDeployer' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.deployer.core.ApplicationDeployer)'.
[2011-09-23 10:56:10.936] service-monitor-thread-1 <KE0100W> Reference '&globalRegion' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.eclipse.equinox.region.Region)(org.eclipse.virgo.kernel.region.name=global))'.
[2011-09-23 10:56:10.939] service-monitor-thread-1 <KE0100W> Reference '&userRegion' in bundle 'org.eclipse.virgo.kernel.model' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.eclipse.equinox.region.Region)(org.eclipse.virgo.kernel.region.name=org.eclipse.virgo.region.user))'.
[2011-09-23 10:56:10.941] service-monitor-thread-1 <KE0100W> Reference '&packageAdminUtil' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.PackageAdminUtil)'.
[2011-09-23 10:56:10.944] service-monitor-thread-1 <KE0100W> Reference '&userBundleContext' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(&(objectClass=org.osgi.framework.BundleContext)(org.eclipse.virgo.kernel.regionContext=true))'.
[2011-09-23 10:56:10.947] service-monitor-thread-1 <KE0100W> Reference '&repository' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.repository.Repository)'.
[2011-09-23 10:56:10.949] service-monitor-thread-1 <KE0100W> Reference '&osgiFramework' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.OsgiFramework)'.
[2011-09-23 10:56:10.952] service-monitor-thread-1 <KE0100W> Reference '&quasiFrameworkFactory' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.quasi.QuasiFrameworkFactory)'.
[2011-09-23 10:56:10.954] service-monitor-thread-1 <KE0100W> Reference '&importExpander' in bundle 'org.eclipse.virgo.kernel.deployer' version '3.0.1.RELEASE' is waiting for service with filter '(objectClass=org.eclipse.virgo.kernel.osgi.framework.ImportExpander)'.

[2011-09-23 10:56:21.969] main <ME0003I> Dump 'serviceability/dump/2011-09-23-10-56-086' generated
[2011-09-23 10:56:21.989] System Bundle Shutdown <KE0010I> Shutdown initiated.


If you start it again without doing a -clean you get this:


[2011-09-23 10:56:50.172] startup-tracker <KE0001I> Kernel starting.
[2011-09-23 10:56:51.449] kernel-dm-5 <RP0100W> The repository 'ext' is not available.
[2011-09-23 10:56:54.046] startup-tracker <KE0002I> Kernel started.
[2011-09-23 10:56:54.060] system-artifacts <DE0700E> Cannot find plan 'org.eclipse.virgo.kernel.userregion.springdm' version range '[0.0.0, oo)' in repository 'usr'.
[2011-09-23 10:56:54.063] system-artifacts <DE0700E> Cannot find plan 'org.eclipse.virgo.web.tomcat' version range '[0.0.0, oo)' in repository 'usr'.
[2011-09-23 10:56:54.068] system-artifacts <UR0002E> User region failed while deploying initial artifacts. Shutting down.
[2011-09-23 10:56:54.394] System Bundle Shutdown <KE0010I> Shutdown initiated.

Any ideas on what I am doing wrong?

Cheers,
Ron
Re: Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu [message #728461 is a reply to message #728454] Fri, 23 September 2011 10:12 Go to previous messageGo to next message
Chris Frost is currently offline Chris FrostFriend
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

Sorry to hear your having problems. Can you have a look in $SERVER_HOME/serviceability/dump/2011-09-23-10-56-086 and there should be a file called summary.txt. If you paste the contents of that on here I can tell you what happened.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu [message #728462 is a reply to message #728461] Fri, 23 September 2011 10:15 Go to previous messageGo to next message
Ron  is currently offline Ron Friend
Messages: 3
Registered: September 2011
Junior Member
Thanks Chris.

Here you go:


Date: 23-Sep-2011
Time: 10:56:21 BST

Cause: User region bundle failed to start

Exception:
org.osgi.framework.BundleException: Exception in org.eclipse.virgo.kernel.userregion.internal.Activator.start() of bundle org.eclipse.virgo.kernel.userregion.
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
at org.eclipse.virgo.kernel.userregionfactory.Activator.initialiseUserRegionBundles(Activator.java:345)
at org.eclipse.virgo.kernel.userregionfactory.Activator.createUserRegion(Activator.java:178)
at org.eclipse.virgo.kernel.userregionfactory.Activator.start(Activator.java:133)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:291)
at org.eclipse.virgo.osgi.launcher.FrameworkBuilder.installAndStartBundles(FrameworkBuilder.java:187)
at org.eclipse.virgo.osgi.launcher.FrameworkBuilder.start(FrameworkBuilder.java:159)
at org.eclipse.virgo.osgi.launcher.Launcher.main(Launcher.java:54)
Caused by: java.util.concurrent.TimeoutException: org.eclipse.virgo.repository.Repository
at org.eclipse.virgo.kernel.userregion.internal.Activator.getPotentiallyDelayedService(Activator.java:352)
at org.eclipse.virgo.kernel.userregion.internal.Activator.start(Activator.java:101)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
... 17 more
Re: Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu [message #728470 is a reply to message #728462] Fri, 23 September 2011 10:26 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Hi Ron. What does java -version report?
Re: Vanilla virgo-tomcat-server-3.0.1.RELEASE fails to start on ubuntu [message #728476 is a reply to message #728470] Fri, 23 September 2011 10:35 Go to previous message
Ron  is currently offline Ron Friend
Messages: 3
Registered: September 2011
Junior Member
Hi Glyn,


java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.2) (6b22-1.10.2-0ubuntu1~11.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)


Ron
Previous Topic:snaps grandkids
Next Topic:Pointers on debugging bundle startup times
Goto Forum:
  


Current Time: Sat Dec 20 06:01:34 GMT 2014

Powered by FUDForum. Page generated in 0.04096 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software