Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Parallel execution of JUnits using JUnit PDE on eclipse Ganymede
Parallel execution of JUnits using JUnit PDE on eclipse Ganymede [message #727466] Wed, 21 September 2011 11:37
Sameer Thakur is currently offline Sameer ThakurFriend
Messages: 1
Registered: September 2011
Junior Member
Hello,

I understand that since Junit 4.7 we can parallel execute JUnits using ParallelComputer. I am using Eclipse Ganymede (version 3.4.2) which ships with PDE Junit plugin 3.4. We are using PDE JUnit plugin for execution of JUnits (via the "Junit Plugin Test"option). We are not using the default eclipse JUnit plugin

Now i cannot seem to be able to find a JUnit plugin which is of version 4.7 or above which i can use in the environment described above.

Questions: 1. Is the version of JUnit which can be used at eclipse runtime tied to the version of PDE JUnit plugin? So if i do not change my eclipse version from Ganymede to something higher, the PDE JUnit version cannot change and hence the actual JUnit being used at runtime cannot be changed? (4.3 in this case)

2. Is it possible for me to install a "JUnit plugin version 4.7" which works with PDE JUnit plugin?

Thank you,
Sameer
Previous Topic:Not able to install thrid party plugin in application developed using Eclipse plugins
Next Topic:Plugins for CDO server out of sync?
Goto Forum:
  


Current Time: Fri Nov 28 00:34:38 GMT 2014

Powered by FUDForum. Page generated in 0.01808 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software