Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Nebula » 1 problem, 1 question on GridViewer
1 problem, 1 question on GridViewer [message #726897] Mon, 19 September 2011 20:39 Go to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

Hi,

I've got a GridTreeViewer working pretty well as a tree. I have 1 problem and 1 question.

Problem: I can't seem to get the auto-expand to work. I am using both a label provider and group content provider, but whenever I set the autoexpandlevel it is ignored. Does this need to be set in a particular order? I do the following:

(gtv is my GridTreeViewer - and all the columns and column groups are already set up)
MyLabelProvider eglp = new MyLabelProvider(gtv.getGrid());
MyContentProvider egcp = new MyContentProvider();

gtv.setAutoExpandLevel(2); //yes, I have 4 levels to my tree...so this should work
gtv.setContentProvider(egcp);
gtv.setLabelProvider(eglp);
gtv.setInput(myListOfData); //this is actually EList<MyEMFObject> 


Question:
Is there no label provider type of thing for the footer? Is it just set the text on each column? Just trying to verify this so that I can code accordingly.

Thanks,
Sharon
Re: 1 problem, 1 question on GridViewer [message #735292 is a reply to message #726897] Tue, 11 October 2011 13:16 Go to previous messageGo to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

bump!
Re: 1 problem, 1 question on GridViewer [message #735295 is a reply to message #726897] Tue, 11 October 2011 13:21 Go to previous messageGo to next message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

bump! Any ideas on how to fix the autoexpand?
Re: 1 problem, 1 question on GridViewer [message #809526 is a reply to message #735295] Wed, 29 February 2012 00:43 Go to previous messageGo to next message
Wim Jongman is currently offline Wim Jongman
Messages: 278
Registered: July 2009
Senior Member

Hi Sharon, is this still bugging you?
Re: 1 problem, 1 question on GridViewer [message #809962 is a reply to message #809526] Wed, 29 February 2012 14:02 Go to previous message
Sharon Snyder is currently offline Sharon Snyder
Messages: 56
Registered: September 2010
Member

I never got it working....I used a workaround.

I ended up calling expandToLevel(2) once all the data is added to my datastore, then I refresh the gridTreeViewer.
Previous Topic:How traverse on composite Nebula widget DateChooserCombo
Next Topic:CalendarCombo problem #3 - keyboard processing
Goto Forum:
  


Current Time: Thu Sep 18 07:56:42 GMT 2014

Powered by FUDForum. Page generated in 0.03098 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software