Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT 3.7 internal browser(Preview problem)
BIRT 3.7 internal browser [message #726055] Fri, 16 September 2011 13:27
JulioC Missing name is currently offline JulioC Missing name
Messages: 33
Registered: March 2011
Location: Ottawa, Canada
Member
Hi all

I just installed all-in-one indigo BIRT 3.7 version on a linux box (open suse 11.4)
When I want to preview any report is shows this message "internal browser not available",it shows the preview results using birt report viewer instead (it uses the external browser in my case is firefox).

There is an option to tell BIRT to use either internal or external browser, however the check option for internal browser is not available, it is grey out.

Also I found out that whenever the report has parameters this error shows up

org.eclipse.swt.SWTError: XPCOM error -1041039104
at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:2502)
at org.eclipse.swt.browser.Mozilla.initFactories(Mozilla.java:1723)
at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:757)
at org.eclipse.swt.browser.Browser.<init>(Browser.java:96)
at org.eclipse.birt.report.designer.internal.ui.dialogs.InputParameterHtmlDialog.create

I have the same version on windows and is working fine.

Wondering what is wrong with linux version

Thanks for any ideas on this one.






[Updated on: Fri, 16 September 2011 15:31]

Report message to a moderator

Previous Topic:Birt 2.5.1 Generating Reports inside other Webapplication
Next Topic:Sun JVM birt problem
Goto Forum:
  


Current Time: Thu Oct 23 18:06:36 GMT 2014

Powered by FUDForum. Page generated in 0.06258 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software