Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Issue with Control Mode
Issue with Control Mode [message #724821] Tue, 13 September 2011 05:51
nicholas pacini is currently offline nicholas pacini
Messages: 31
Registered: December 2010
Member
hi all,

i'm running Papyrus 0.8.0 under Indigo, i've tried to use the control/uncontrol mode of papyrus but i've encountered some problems:

1)Diagram loss: after uncontrolling a package, the model is correctly updated, but the diagrams can't be found.

2)Nested Packages and Profiles: there's and odd behavior in the case i wish to control a package that is included in an other package and both of them have the same profile applied: in this case, i get the message: "Unable to create a resource for the specified URI" (and an exception, but i'd rather skip it at the moment since it's quite long). The workaround i've found for this issue is to remove the profile from the "parent" package. Of course this could have many drawbacks.

3)Stereotypes applied to the package that will be controlled are lost in the resource you get from it.

Have anyone of you experienced such problems? Am i doing something wrong? Are they known bugs that hopefully will be addressed before next release?

Thank you for your support,
Nicholas
Previous Topic:Cannot edit Body of OpaqueBehavior
Next Topic:ALF
Goto Forum:
  


Current Time: Wed Jul 30 21:33:52 EDT 2014

Powered by FUDForum. Page generated in 0.01894 seconds