Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Starting Out - Need Help(Cannot load 32-bit SWT libraries on 64-bit JVM)
Starting Out - Need Help [message #724194] Sun, 11 September 2011 10:39 Go to next message
Steve C. is currently offline Steve C.
Messages: 2
Registered: August 2011
Junior Member
I tried to run a simple display of of a window and I received the following error.

Anybody know what I can do to move forward?


Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
at com.w1smc.swt.BlankWindow.main(BlankWindow.java:9)
Re: Starting Out - Need Help [message #724287 is a reply to message #724194] Sun, 11 September 2011 23:33 Go to previous message
Steve C. is currently offline Steve C.
Messages: 2
Registered: August 2011
Junior Member
Corrected myself .....

Downloaded the 64 bit version and imported it into Eclipse after deleting the 32 bit version.

Things appear to be working fine now .....
Previous Topic:Dynamically resizing a CLabel based on text input?
Next Topic:Player avi, mpeg whit SWT
Goto Forum:
  


Current Time: Tue Sep 23 18:29:19 GMT 2014

Powered by FUDForum. Page generated in 0.04545 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software