Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » line coverage tool: library piLLCAgent
line coverage tool: library piLLCAgent [message #77489] Mon, 17 July 2006 04:02 Go to next message
Eclipse User
Originally posted by: prince.pajero.gmail.com

While running the JUnit Plugin test after enabling the code coverage
tool from the Package explorer, I get this:-

Error occurred during initialization of VM
Could not find agent library on the library path or in the local
directory: piLLCAgent

The agent controller is configured properly and running.

Using: eclipse 3.2
TPTP 4.2
Agent Controller 4.2
Re: line coverage tool: library piLLCAgent [message #77505 is a reply to message #77489] Mon, 17 July 2006 07:48 Go to previous messageGo to next message
Paul Slauenwhite is currently offline Paul Slauenwhite
Messages: 970
Registered: July 2009
Senior Member
Hi Prince,
Are you running a TPTP JUnit plug-in test or an Eclipse JUnit plug-in
test? Are all the class for the JUnit plug-in test in the workspace and are
you running using a launch configuration?

Paul
"Prince Singh" <prince.pajero@gmail.com> wrote in message
news:e9fg54$944$1@utils.eclipse.org...
> While running the JUnit Plugin test after enabling the code coverage
> tool from the Package explorer, I get this:-
>
> Error occurred during initialization of VM
> Could not find agent library on the library path or in the local
> directory: piLLCAgent
>
> The agent controller is configured properly and running.
>
> Using: eclipse 3.2
> TPTP 4.2
> Agent Controller 4.2
Re: line coverage tool: library piLLCAgent [message #77532 is a reply to message #77505] Mon, 17 July 2006 08:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: prince.pajero.gmail.com

Hi Paul,

I'm running an Eclipse JUnit plug-in test(Run As > JUnit Plug-in Test)
All the classes are in the workspace.
I'm not using any special launch configuration.

Also, I tried Code coverage for a simple Hello world java project(not a
plugin) but I get the same error. i.e.:-

"Error occurred during initialization of VM
Could not find agent library on the library path or in the local
directory: piLLCAgent"


Paul Slauenwhite wrote:
> Hi Prince,
> Are you running a TPTP JUnit plug-in test or an Eclipse JUnit plug-in
> test? Are all the class for the JUnit plug-in test in the workspace and are
> you running using a launch configuration?
>
> Paul
> "Prince Singh" <prince.pajero@gmail.com> wrote in message
> news:e9fg54$944$1@utils.eclipse.org...
>> While running the JUnit Plugin test after enabling the code coverage
>> tool from the Package explorer, I get this:-
>>
>> Error occurred during initialization of VM
>> Could not find agent library on the library path or in the local
>> directory: piLLCAgent
>>
>> The agent controller is configured properly and running.
>>
>> Using: eclipse 3.2
>> TPTP 4.2
>> Agent Controller 4.2
>
>
Re: line coverage tool: library piLLCAgent [message #77548 is a reply to message #77489] Mon, 17 July 2006 08:35 Go to previous messageGo to next message
Valentina Popescu is currently offline Valentina Popescu
Messages: 23
Registered: July 2009
Junior Member
The line level coverage is collected using a probe instrumentation
technique. From the exception you get it seems that the probe
instrumentation fails to execute.
This may be linked with defect
https://bugs.eclipse.org/bugs/show_bug.cgi?id=130923

What is the jvm version used by your Eclipse client ? There is a known issue
when running line coverage with java 5.

Can you try this workaround:
- launch your JUnit application by using the Profile.. action instead of the
Run... action
- in the Profile... launch configuration, under the Monitor tab, select Line
Code Coverage under the Java Profiling section.
By running line coverage from the Profile action you can explicitly set the
packages and classes you want to instrument. ( select the Java Profiling
section and then Edit Options action. Make sure you exclude java* and
com.ibm*; the probe engine cannot instrument some of the java classes since
this may create circular dependencies at class load time)

Valentina



"Prince Singh" <prince.pajero@gmail.com> wrote in message
news:e9fg54$944$1@utils.eclipse.org...

> While running the JUnit Plugin test after enabling the code coverage tool
> from the Package explorer, I get this:-
>
> Error occurred during initialization of VM
> Could not find agent library on the library path or in the local
> directory: piLLCAgent
>
> The agent controller is configured properly and running.
>
> Using: eclipse 3.2
> TPTP 4.2
> Agent Controller 4.2
Re: line coverage tool: library piLLCAgent [message #77563 is a reply to message #77548] Mon, 17 July 2006 09:01 Go to previous message
Eclipse User
Originally posted by: prince.pajero.gmail.com

Hi Valentina,

Yes, I'm using Java 1.5

And using the Profile action solves the problem.

Most probably it is not linked with the issue that you mentioned. It
seems to me that the problem might be there when run with Java 1.5

I'll try to run using Java 1.4 and post the results again.



Valentina Popescu wrote:
> The line level coverage is collected using a probe instrumentation
> technique. From the exception you get it seems that the probe
> instrumentation fails to execute.
> This may be linked with defect
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=130923
>
> What is the jvm version used by your Eclipse client ? There is a known issue
> when running line coverage with java 5.
>
> Can you try this workaround:
> - launch your JUnit application by using the Profile.. action instead of the
> Run... action
> - in the Profile... launch configuration, under the Monitor tab, select Line
> Code Coverage under the Java Profiling section.
> By running line coverage from the Profile action you can explicitly set the
> packages and classes you want to instrument. ( select the Java Profiling
> section and then Edit Options action. Make sure you exclude java* and
> com.ibm*; the probe engine cannot instrument some of the java classes since
> this may create circular dependencies at class load time)
>
> Valentina
>
>
>
> "Prince Singh" <prince.pajero@gmail.com> wrote in message
> news:e9fg54$944$1@utils.eclipse.org...
>
>> While running the JUnit Plugin test after enabling the code coverage tool
>> from the Package explorer, I get this:-
>>
>> Error occurred during initialization of VM
>> Could not find agent library on the library path or in the local
>> directory: piLLCAgent
>>
>> The agent controller is configured properly and running.
>>
>> Using: eclipse 3.2
>> TPTP 4.2
>> Agent Controller 4.2
>
>
Previous Topic:commons-logging.jar not loaded
Next Topic:Test guidelines
Goto Forum:
  


Current Time: Wed Aug 20 04:49:34 EDT 2014

Powered by FUDForum. Page generated in 0.01947 seconds