Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » (no subject)
(no subject) [message #723324] Thu, 08 September 2011 10:06 Go to next message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Hi all,

I have a problem regarding some plugins which are not accepted because of
the versioning.

A plugin-based PDE export from inside Eclipse does work. Now I am trying to
cope with a feature-based build using Buckminster.

During materialisation for a feature-based build job I get messages like:

org.eclipse.dltk.core[3.0.0.v20110609-1525,3.0.0.v20110609-1525]: Version
3.0.0.qualifier rejected: Not designated by
[3.0.0.v20110609-1525,3.0.0.v20110609-1525]

I searched for this error, but it revealed not much information. In the
class
org.eclipse.buckminster.core/src/java/org/eclipse/buckminster/core/version/AbstractSCCSVersionFinder.java
I found this code which might be related:

if (!(versionRange == null || versionRange.isIncluded(version))) {
// Discriminated by our designator
//
logDecision(ResolverDecisionType.VERSION_REJECTED, version,
NLS.bind(Messages.Not_designated_by_0, versionRange));
continue;
}

So it searches for the replaced qualifier, compares it with qualifier as
string? My main problem is that I can't really understand the cause of the
problem preventing me from searching solutions.

For example let's take the plugin
org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]

My feature includes it like:
<import plugin="org.eclipse.dltk.launching" version="3.0.0"
match="greaterOrEqual"/>


Here is the log Buckminster has shown for it:

Using resolver Local resolver
Trying provider local(materialized)
No materialization found for
org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]

Trying provider local(workspace)
No open workspace project found that corresponds to
org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]

Trying provider local(target)
Rejecting provider eclipse.platform(plugin/org.eclipse.dltk.launching): No
component match was found

Using resource map
file:/var/lib/jenkins/jobs/DLTK_test/workspace/scm/dltktest.build/build.rmap
Using search path dltk.helpers
Trying provider local({0}/scm/{1}
[/var/lib/jenkins/jobs/DLTK_test/workspace/scm/org.eclipse.dltk.launching])
Found match
Using provider local({0}/scm/{1}
[/var/lib/jenkins/jobs/DLTK_test/workspace/scm/org.eclipse.dltk.launching])
Version 3.0.0.qualifier rejected: Not designated by
[3.0.0.v20110423,3.0.0.v20110423]
No provider was found that could resolve the request

Redirecting to resource map
file:/var/lib/jenkins/jobs/DLTK_test/workspace/scm/dltktest.build/build/build_eclipse.rmap
Using search path eclipse.platform
Trying provider
p2(http://download.eclipse.org/eclipse/updates/3.7[http://download.eclipse.org/eclipse/updates/3.7])
Rejecting provider
p2(http://download.eclipse.org/eclipse/updates/3.7[http://download.eclipse.org/eclipse/updates/3.7]):
No component match was found
No provider was found that could resolve the request
Using search path eclipse.main
Trying provider
p2(http://download.eclipse.org/releases/indigo[http://download.eclipse.org/releases/indigo])
Found match 3.0.0.v20110423
Using provider
p2(http://download.eclipse.org/releases/indigo[http://download.eclipse.org/releases/indigo])


I also wondered from where the version 3.0.0.v20110423 is taken from - and
why it is considered in my feature-based build. I searched the whole
workspace for this particular version number, but found nothing. Seems like
this version is required by another plugin of Eclipse. As written above the
feature includes "3.0.0". The plugin manifest contains "3.0.0.qualifier".

Any idea how to let Buckminster not block the newer version? Maybe a version
converter is the way to go?

Thank you very much for reading this.

Regards,
Axel
(no subject) [message #723333 is a reply to message #723324] Thu, 08 September 2011 10:58 Go to previous messageGo to next message
Thomas Hallgren is currently offline Thomas Hallgren
Messages: 3229
Registered: July 2009
Senior Member
Hi Axel,

A component with a version like 3.0.0.qualifier is either in source form or has been incorrectly built. A version
requirement like [3.0.0.v20110609-1525,3.0.0.v20110609-1525] seems to be asking for an explicit version of that
component. So question is, where does this requirement stem from? Who added the qualifier?

Buckminster can add a qualifier during a build, but never during a resolution so if you see versions with expanded
qualifiers during resolution, then you can be certain that somewhere such a requirement exists. Somewhere, some
component in the transitive scope of your resolution, is requesting
org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423].

- thomas


On 2011-09-08 12:06, Axel Guckelsberger wrote:
> Hi all,
>
> I have a problem regarding some plugins which are not accepted because of
> the versioning.
>
> A plugin-based PDE export from inside Eclipse does work. Now I am trying to
> cope with a feature-based build using Buckminster.
>
> During materialisation for a feature-based build job I get messages like:
>
> org.eclipse.dltk.core[3.0.0.v20110609-1525,3.0.0.v20110609-1525]: Version
> 3.0.0.qualifier rejected: Not designated by
> [3.0.0.v20110609-1525,3.0.0.v20110609-1525]
>
> I searched for this error, but it revealed not much information. In the
> class
> org.eclipse.buckminster.core/src/java/org/eclipse/buckminster/core/version/AbstractSCCSVersionFinder.java
> I found this code which might be related:
>
> if (!(versionRange == null || versionRange.isIncluded(version))) {
> // Discriminated by our designator
> //
> logDecision(ResolverDecisionType.VERSION_REJECTED, version,
> NLS.bind(Messages.Not_designated_by_0, versionRange));
> continue;
> }
>
> So it searches for the replaced qualifier, compares it with qualifier as
> string? My main problem is that I can't really understand the cause of the
> problem preventing me from searching solutions.
>
> For example let's take the plugin
> org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]
>
> My feature includes it like:
> <import plugin="org.eclipse.dltk.launching" version="3.0.0"
> match="greaterOrEqual"/>
>
>
> Here is the log Buckminster has shown for it:
>
> Using resolver Local resolver
> Trying provider local(materialized)
> No materialization found for
> org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]
>
> Trying provider local(workspace)
> No open workspace project found that corresponds to
> org.eclipse.dltk.launching[3.0.0.v20110423,3.0.0.v20110423]
>
> Trying provider local(target)
> Rejecting provider eclipse.platform(plugin/org.eclipse.dltk.launching): No
> component match was found
>
> Using resource map
> file:/var/lib/jenkins/jobs/DLTK_test/workspace/scm/dltktest.build/build.rmap
> Using search path dltk.helpers
> Trying provider local({0}/scm/{1}
> [/var/lib/jenkins/jobs/DLTK_test/workspace/scm/org.eclipse.dltk.launching])
> Found match
> Using provider local({0}/scm/{1}
> [/var/lib/jenkins/jobs/DLTK_test/workspace/scm/org.eclipse.dltk.launching])
> Version 3.0.0.qualifier rejected: Not designated by
> [3.0.0.v20110423,3.0.0.v20110423]
> No provider was found that could resolve the request
>
> Redirecting to resource map
> file:/var/lib/jenkins/jobs/DLTK_test/workspace/scm/dltktest.build/build/build_eclipse.rmap
> Using search path eclipse.platform
> Trying provider
> p2(http://download.eclipse.org/eclipse/updates/3.7[http://download.eclipse.org/eclipse/updates/3.7])
> Rejecting provider
> p2(http://download.eclipse.org/eclipse/updates/3.7[http://download.eclipse.org/eclipse/updates/3.7]):
> No component match was found
> No provider was found that could resolve the request
> Using search path eclipse.main
> Trying provider
> p2(http://download.eclipse.org/releases/indigo[http://download.eclipse.org/releases/indigo])
> Found match 3.0.0.v20110423
> Using provider
> p2(http://download.eclipse.org/releases/indigo[http://download.eclipse.org/releases/indigo])
>
>
> I also wondered from where the version 3.0.0.v20110423 is taken from - and
> why it is considered in my feature-based build. I searched the whole
> workspace for this particular version number, but found nothing. Seems like
> this version is required by another plugin of Eclipse. As written above the
> feature includes "3.0.0". The plugin manifest contains "3.0.0.qualifier".
>
> Any idea how to let Buckminster not block the newer version? Maybe a version
> converter is the way to go?
>
> Thank you very much for reading this.
>
> Regards,
> Axel
>
(no subject) [message #724040 is a reply to message #723333] Sat, 10 September 2011 13:05 Go to previous message
Axel Guckelsberger is currently offline Axel Guckelsberger
Messages: 224
Registered: July 2009
Senior Member
Hi Thomas,

thanks for your explaination.

Regards,
Axel
Previous Topic:Re: How to configure a reader to read from a target platform directory
Next Topic:can't update features in buckminster
Goto Forum:
  


Current Time: Mon Oct 20 22:50:06 GMT 2014

Powered by FUDForum. Page generated in 0.01871 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software