Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Double deploy from pickup directory in Virgo Tomcat Server 3.0
Double deploy from pickup directory in Virgo Tomcat Server 3.0 [message #723268] Thu, 08 September 2011 08:25 Go to next message
Alexey Romanov is currently offline Alexey Romanov
Messages: 263
Registered: May 2010
Senior Member
When I start VTS 3.0 from startup.bat, I get
W:\1\virgo-tomcat-server-3.0.0.RELEASE\bin>startup.bat
WARNING: jmxPermissions.vbs did not update the permissions of W:\1\VIRGO-~2.REL\
config\org.eclipse.virgo.kernel.jmxremote.access.properties. Check the file has
the correct permissions.
[2011-09-08 11:58:03.109] startup-tracker              <KE0001I> Kernel starting.
[2011-09-08 11:58:06.379] startup-tracker              <KE0002I> Kernel started.
[2011-09-08 11:58:06.682] system-artifacts             <DE0000I> Installing plan
'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
[2011-09-08 11:58:07.472] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.core' version '1.2.1'.
[2011-09-08 11:58:07.771] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.extender' version '1.2.1'.
[2011-09-08 11:58:07.864] system-artifacts             <DE0000I> Installing bundle 'org.springframework.osgi.io' version '1.2.1'.
[2011-09-08 11:58:07.943] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:07.995] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:08.228] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'.
[2011-09-08 11:58:08.443] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'.
[2011-09-08 11:58:08.449] system-artifacts             <DE0000I> Installing configuration 'osgi.console.telnet' version '0.0.0'.
[2011-09-08 11:58:08.455] system-artifacts             <DE0000I> Installing configuration 'osgi.console.ssh' version '0.0.0'.
[2011-09-08 11:58:09.636] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.core' version '1.2.1'.
[2011-09-08 11:58:09.638] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.extender' version '1.2.1'.
[2011-09-08 11:58:09.640] system-artifacts             <DE0001I> Installed bundle 'org.springframework.osgi.io' version '1.2.1'.
[2011-09-08 11:58:09.641] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:09.643] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:09.644] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'.
[2011-09-08 11:58:09.646] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.equinox.util' version '1.0.200.v20100503'.
[2011-09-08 11:58:09.648] system-artifacts             <DE0001I> Installed configuration 'osgi.console.telnet' version '0.0.0'.
[2011-09-08 11:58:09.649] system-artifacts             <DE0001I> Installed configuration 'osgi.console.ssh' version '0.0.0'.
[2011-09-08 11:58:09.651] system-artifacts             <DE0001I> Installed plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
[2011-09-08 11:58:09.685] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
[2011-09-08 11:58:09.693] system-artifacts             <DE0004I> Starting bundle
 'org.springframework.osgi.core' version '1.2.1'.
[2011-09-08 11:58:09.696] start-signalling-1           <DE0005I> Started bundle
'org.springframework.osgi.core' version '1.2.1'.
[2011-09-08 11:58:09.697] system-artifacts             <DE0004I> Starting bundle
 'org.springframework.osgi.extender' version '1.2.1'.
[2011-09-08 11:58:10.151] start-signalling-1           <DE0005I> Started bundle
'org.springframework.osgi.extender' version '1.2.1'.
[2011-09-08 11:58:10.155] system-artifacts             <DE0004I> Starting bundle
 'org.springframework.osgi.io' version '1.2.1'.
[2011-09-08 11:58:10.157] start-signalling-1           <DE0005I> Started bundle
'org.springframework.osgi.io' version '1.2.1'.
[2011-09-08 11:58:10.159] system-artifacts             <DE0004I> Starting bundle
 'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:10.161] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.virgo.kernel.agent.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:10.164] system-artifacts             <DE0004I> Starting bundle
 'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:10.179] system-artifacts             <DE0004I> Starting bundle
 'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'.
[2011-09-08 11:58:10.287] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.equinox.ds' version '1.3.0.v20110124-0830'.
[2011-09-08 11:58:10.287] system-artifacts             <DE0004I> Starting bundle
 'org.eclipse.equinox.util' version '1.0.200.v20100503'.
[2011-09-08 11:58:10.311] system-artifacts             <DE0004I> Starting config
uration 'osgi.console.telnet' version '0.0.0'.
[2011-09-08 11:58:10.323] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.virgo.kernel.deployer.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:10.323] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.equinox.util' version '1.0.200.v20100503'.
[2011-09-08 11:58:10.431] system-artifacts             <DE0005I> Started configuration 'osgi.console.telnet' version '0.0.0'.
[2011-09-08 11:58:10.434] system-artifacts             <DE0004I> Starting configuration 'osgi.console.ssh' version '0.0.0'.
[2011-09-08 11:58:10.450] system-artifacts             <DE0005I> Started configuration 'osgi.console.ssh' version '0.0.0'.
[2011-09-08 11:58:10.452] system-artifacts             <DE0005I> Started plan 'org.eclipse.virgo.kernel.userregion.springdm' version '3.0.0'.
[2011-09-08 11:58:10.583] system-artifacts             <DE0000I> Installing plan
 'org.eclipse.virgo.web.tomcat' version '3.0.0'.
[2011-09-08 11:58:10.593] system-artifacts             <DE0000I> Installing configuration 'org.eclipse.virgo.web' version '0.0.0'.
[2011-09-08 11:58:10.782] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.core' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.046] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.gemini.web.tomcat' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.125] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.161] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.241] system-artifacts             <DE0000I> Installing bundle 'org.eclipse.virgo.web.tomcat.support' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.703] system-artifacts             <DE0001I> Installed configuration 'org.eclipse.virgo.web' version '0.0.0'.
[2011-09-08 11:58:11.706] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.core' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.708] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.gemini.web.tomcat' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.710] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.712] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.714] system-artifacts             <DE0001I> Installed bundle 'org.eclipse.virgo.web.tomcat.support' version '3.0.0.RELEASE'.
[2011-09-08 11:58:11.716] system-artifacts             <DE0001I> Installed plan
'org.eclipse.virgo.web.tomcat' version '3.0.0'.
[2011-09-08 11:58:11.747] system-artifacts             <DE0004I> Starting plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'.
[2011-09-08 11:58:11.749] system-artifacts             <DE0004I> Starting configuration 'org.eclipse.virgo.web' version '0.0.0'.
[2011-09-08 11:58:11.794] system-artifacts             <DE0005I> Started configuration 'org.eclipse.virgo.web' version '0.0.0'.
[2011-09-08 11:58:11.798] system-artifacts             <DE0004I> Starting bundle
'org.eclipse.gemini.web.core' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.832] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.gemini.web.core' version '2.0.0.RELEASE'.
[2011-09-08 11:58:11.835] system-artifacts             <DE0004I> Starting bundle
'org.eclipse.gemini.web.tomcat' version '2.0.0.RELEASE'.
[2011-09-08 11:58:12.731] system-artifacts             <TC0000I> Starting Tomcat.
[2011-09-08 11:58:12.763] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme http on port 8989.
[2011-09-08 11:58:12.772] system-artifacts             <TC0010I> Creating HTTP/1.1 connector with scheme https on port 8443.
[2011-09-08 11:58:12.776] system-artifacts             <TC0010I> Creating AJP/1.3 connector with scheme http on port 8010.
[2011-09-08 11:58:12.781] system-artifacts             <TC0001I> Started Tomcat.
[2011-09-08 11:58:12.802] system-artifacts             <DE0004I> Starting bundle
'org.eclipse.virgo.web.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:12.811] system-artifacts             <DE0004I> Starting bundle
'org.eclipse.virgo.web.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:12.820] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.virgo.web.dm' version '3.0.0.RELEASE'.
[2011-09-08 11:58:12.831] system-artifacts             <DE0005I> Started bundle
'org.eclipse.virgo.web.tomcat.support' version '3.0.0.RELEASE'.
[2011-09-08 11:58:12.997] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.gemini.web.tomcat' version '2.0.0.RELEASE'.
[2011-09-08 11:58:13.011] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.virgo.web.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:13.013] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.web.tomcat' version '3.0.0'.
[2011-09-08 11:58:13.016] sync Event Dispatcher Thread <UR0001I> User region ready.
[2011-09-08 11:58:13.122] deployer-recovery            <DE0000I> Installing plan
'org.eclipse.virgo.apps.admin.plan' version '3.0.0'.
[2011-09-08 11:58:13.300] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.224] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.475] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.477] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.479] deployer-recovery            <DE0001I> Installed plan
'org.eclipse.virgo.apps.admin.plan' version '3.0.0'.
[2011-09-08 11:58:16.487] deployer-recovery            <DE0004I> Starting plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'.
[2011-09-08 11:58:16.490] deployer-recovery            <DE0004I> Starting bundle
'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.543] deployer-recovery            <DE0004I> Starting bundle
'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:16.548] start-signalling-2           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE' with context path '/admin'.
[2011-09-08 11:58:16.640] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.404] start-signalling-2           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE' with context path
'/admin'.
[2011-09-08 11:58:17.407] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.410] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'.
[2011-09-08 11:58:17.525] deployer-recovery            <DE0000I> Installing par
'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.529] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.531] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.636] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.676] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.679] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.681] deployer-recovery            <DE0001I> Installed par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.701] deployer-recovery            <DE0004I> Starting par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.706] deployer-recovery            <DE0004I> Starting bundle
'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.715] deployer-recovery            <DE0004I> Starting bundle
'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.722] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.724] start-signalling-2           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE' with context path '/org.eclipse.virgo.apps.repository'.
[2011-09-08 11:58:17.765] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'.
[2011-09-08 11:58:17.976] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.069] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.142] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.155] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.162] start-signalling-1           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE' with context path '/'.
[2011-09-08 11:58:18.387] start-signalling-1           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE' with context path '/'.
[2011-09-08 11:58:18.389] start-signalling-1           <DE0005I> Started bundle
'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.478] start-signalling-2           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE' with context path '/org.eclipse.virgo.apps.repository'.
[2011-09-08 11:58:18.480] start-signalling-2           <DE0005I> Started bundle
'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'.
[2011-09-08 11:58:18.483] start-signalling-2           <DE0005I> Started par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'.
[2011-09-08 11:58:19.168] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.admin-3.0.0.RELEASE.plan'.
[2011-09-08 11:58:19.169] fs-watcher                   <HD0005I> Hot deploy not performed because file 'org.eclipse.virgo.apps.admin-3.0.0.RELEASE.plan' is already deployed.
[2011-09-08 11:58:19.171] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE.par'.
[2011-09-08 11:58:19.172] fs-watcher                   <HD0005I> Hot deploy not
performed because file 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE.par' is already deployed.
[2011-09-08 11:58:19.174] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.splash-3.0.0.RELEASE.jar'.
[2011-09-08 11:58:19.176] fs-watcher                   <HD0005I> Hot deploy not performed because file 'org.eclipse.virgo.apps.splash-3.0.0.RELEASE.jar' is already deployed.

If started from tooling, instead of "Hot deploy not performed" I see
[2011-09-08 11:59:34.657] sync Event Dispatcher Thread <UR0001I> User region ready. 
[2011-09-08 11:59:34.736] deployer-recovery            <DE0000I> Installing plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-09-08 11:59:34.925] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:37.884] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.129] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.130] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.131] deployer-recovery            <DE0001I> Installed plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-09-08 11:59:38.139] deployer-recovery            <DE0004I> Starting plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-09-08 11:59:38.142] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.195] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.200] start-signalling-2           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE' with context path '/admin'. 
[2011-09-08 11:59:38.294] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.612] deployer-recovery            <DE0000I> Installing par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.616] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.620] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.788] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.790] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.792] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.794] deployer-recovery            <DE0001I> Installed par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.819] deployer-recovery            <DE0004I> Starting par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.823] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.832] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.837] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:38.842] start-signalling-1           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-09-08 11:59:38.864] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-synthetic.context' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:39.470] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.core' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:39.623] deployer-recovery            <DE0000I> Installing bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:39.703] deployer-recovery            <DE0001I> Installed bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:39.743] deployer-recovery            <DE0004I> Starting bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:39.759] start-signalling-3           <WE0000I> Starting web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE' with context path '/'. 
[2011-09-08 11:59:40.118] start-signalling-2           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE' with context path '/admin'. 
[2011-09-08 11:59:40.120] start-signalling-2           <DE0005I> Started bundle 'org.eclipse.virgo.apps.admin.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:40.122] start-signalling-2           <DE0005I> Started plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0'. 
[2011-09-08 11:59:40.149] start-signalling-3           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE' with context path '/'. 
[2011-09-08 11:59:40.151] start-signalling-3           <DE0005I> Started bundle 'org.eclipse.virgo.apps.splash' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:40.376] start-signalling-1           <WE0001I> Started web bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE' with context path '/org.eclipse.virgo.apps.repository'. 
[2011-09-08 11:59:40.378] start-signalling-1           <DE0005I> Started bundle 'org.eclipse.virgo.apps.repository-3.0.0.RELEASE-org.eclipse.virgo.apps.repository.web' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:40.380] start-signalling-1           <DE0005I> Started par 'org.eclipse.virgo.apps.repository' version '3.0.0.RELEASE'. 
[2011-09-08 11:59:40.781] fs-watcher                   <HD0001I> Hot deployer processing 'INITIAL' event for file 'org.eclipse.virgo.apps.admin-3.0.0.RELEASE.plan'. 
[2011-09-08 11:59:44.575]  TCP Connection(2)-127.0.0.1 <DE0000I> Installing bundle 'poim_resources' version '0.0.0'. 
[2011-09-08 11:59:44.593]  TCP Connection(2)-127.0.0.1 <DE0001I> Installed bundle 'poim_resources' version '0.0.0'. 
[2011-09-08 11:59:44.604]  TCP Connection(2)-127.0.0.1 <DE0004I> Starting bundle 'poim_resources' version '0.0.0'. 
[2011-09-08 11:59:44.617] start-signalling-1           <WE0000I> Starting web bundle 'poim_resources' version '0.0.0' with context path '/poim_resources'. 
[2011-09-08 11:59:44.647] fs-watcher                   <HD0002E> Hot deploy failed for file 'org.eclipse.virgo.apps.admin-3.0.0.RELEASE.plan'. org.eclipse.virgo.kernel.deployer.core.DeploymentException: The artifact plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0' in scope 'null' at URI 'file:/W:/1/virgo-tomcat-server-3.0.0.RELEASE/pickup/org.eclipse.virgo.apps.admin-3.0.0.RELEASE.plan' cannot be stored in the runtime artifact model as it clashes with the artifact plan 'org.eclipse.virgo.apps.admin.plan' version '3.0.0' in scope 'null' which is already present.
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.doInstall(PipelinedApplicationDeployer.java:159)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.install(PipelinedApplicationDeployer.java:136)
	at org.eclipse.virgo.kernel.deployer.core.internal.PipelinedApplicationDeployer.deploy(PipelinedApplicationDeployer.java:203)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deploy(HotDeploymentFileSystemListener.java:174)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.deployIfNotDeployed(HotDeploymentFileSystemListener.java:186)
	at org.eclipse.virgo.kernel.deployer.hot.HotDeploymentFileSystemListener.onChange(HotDeploymentFileSystemListener.java:87)
	at org.eclipse.virgo.util.io.FileSystemChecker.notifyListeners(FileSystemChecker.java:245)
	at org.eclipse.virgo.util.io.FileSystemChecker.check(FileSystemChecker.java:166)
	at org.eclipse.virgo.kernel.deployer.hot.WatchTask.run(WatchTask.java:58)
	at java.lang.Thread.run(Thread.java:662)
Re: Double deploy from pickup directory in Virgo Tomcat Server 3.0 [message #723310 is a reply to message #723268] Thu, 08 September 2011 09:54 Go to previous messageGo to next message
Alexey Romanov is currently offline Alexey Romanov
Messages: 263
Registered: May 2010
Senior Member
After clearing the /work directory, it happens the other way around: exception from startup.bat and "Hot deploy not performed" from tooling...
Re: Double deploy from pickup directory in Virgo Tomcat Server 3.0 [message #725102 is a reply to message #723310] Wed, 14 September 2011 00:01 Go to previous message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
This looks odd. If you are just using a pristine Virgo installation and can reproduce the problem without manually clearing directories, then it looks like a bug in the way the tooling launches Virgo - perhaps you could capture a bug report.

[Updated on: Wed, 14 September 2011 00:01]

Report message to a moderator

Previous Topic:JSF 2.0
Next Topic:VTS 3.0 can't resolve constraint satisfied by a package in /repository/usr
Goto Forum:
  


Current Time: Thu Sep 18 12:00:36 GMT 2014

Powered by FUDForum. Page generated in 0.12928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software