Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Maven repository for Virgo 3.0.0 artifacts
Maven repository for Virgo 3.0.0 artifacts [message #722955] Wed, 07 September 2011 09:54 Go to next message
Lorie Pisicchio is currently offline Lorie Pisicchio
Messages: 44
Registered: October 2010
Member
Hello!
It seems that new artifacts for Virgo 3.0.0.RELEASE have not been published to the maven repository.
I have checked the repository, and it contains only 2.1.0.RELEASE artifacts.

I am using the following repositories in my pom.xml :
	<repositories>
		<repository>
            <id>org.eclipse.virgo.maven.repository.bundles.release</id>
            <name>Eclipse Virgo Bundles Maven Repository</name>
            <url>http://zodiac.springsource.com/maven/bundles/release</url>
        </repository>
        <repository>
            <id>org.eclipse.virgo.maven.repository.libraries.release</id>
            <name>Eclipse Virgo Libraries Maven Repository</name>
            <url>http://zodiac.springsource.com/maven/libraries/release</url>
        </repository>
        <repository>
            <id>com.springsource.repository.bundles.release</id>
            <name>EBR Spring Release Repository</name>
            <url>http://repository.springsource.com/maven/bundles/release</url>
        </repository>
        <repository>
            <id>com.springsource.repository.bundles.external</id>
            <name>EBR External Release Repository</name>
            <url>http://repository.springsource.com/maven/bundles/external</url>
        </repository>
	</repositories>


Best Regards,
Lorie.
Re: Maven repository for Virgo 3.0.0 artifacts [message #722966 is a reply to message #722955] Wed, 07 September 2011 10:27 Go to previous messageGo to next message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

The Zodiac repository is no longer used by the Virgo project, it was a stepping stone between SpringSource and Eclipse when the project moved over. The new one to use is at http://build.eclipse.org/rt/virgo/

Unfortunately no releases have been published there under Maven either, just Ivy. I'm looking in to this.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Maven repository for Virgo 3.0.0 artifacts [message #723006 is a reply to message #722966] Wed, 07 September 2011 12:17 Go to previous messageGo to next message
Lorie Pisicchio is currently offline Lorie Pisicchio
Messages: 44
Registered: October 2010
Member
Hi!
Thanx for you quick reply, and please, let me know as soon as 3.0.0 version will be available on maven repository.

Best Regards,
Lorie.
Re: Maven repository for Virgo 3.0.0 artifacts [message #725601 is a reply to message #723006] Thu, 15 September 2011 10:22 Go to previous messageGo to next message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

I've figured out what needs to be done for this and raised a bug for it. I will make future comments on that bug so please add yourself to the CC list to keep updated.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=357763

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Maven repository for Virgo 3.0.0 artifacts [message #855611 is a reply to message #722966] Wed, 25 April 2012 00:40 Go to previous messageGo to next message
Cameron Ross is currently offline Cameron Ross
Messages: 31
Registered: May 2010
Member
How up to date is this Maven repository?
Re: Maven repository for Virgo 3.0.0 artifacts [message #856410 is a reply to message #855611] Wed, 25 April 2012 16:28 Go to previous message
Violeta Georgieva is currently offline Violeta Georgieva
Messages: 242
Registered: October 2010
Senior Member
Hi,

The bug is resolved.
Do you have some specific problems? If yes share them with us.

Regards
Violeta
Previous Topic:unable to deploy roo 1.1.0 war on virgo web server 2.1.0
Next Topic:Loading a vanilla war file fails until WABheaders=defaulted is set
Goto Forum:
  


Current Time: Thu Oct 23 22:10:56 GMT 2014

Powered by FUDForum. Page generated in 0.01861 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software