Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » OSGI nor found BIRT3.7 JBOSS
OSGI nor found BIRT3.7 JBOSS [message #722847] Tue, 06 September 2011 18:46 Go to next message
Sarah  is currently offline Sarah
Messages: 4
Registered: September 2011
Junior Member
Hi

I am using eclipse Helios and JBoss-seam to deploy my web app.
I added birt 3.7 using the eclipse install new software feature.
When I run the report I get this error.
I thought BIRT 3,7 does not use OSGI anymore?
Any suggestions?




org.eclipse.birt.core.exception.BirtException: Cant startup the OSGI framework
at org.eclipse.birt.core.framework.Platform.startup(Platform.java:91)
at org.eclipse.birt.report.service.ReportEngineService.setEngineContext(ReportEngineService.java:328)
at org.eclipse.birt.report.service.BirtViewerReportService.setContext(BirtViewerReportService.java:1022)
at org.eclipse.birt.report.listener.ViewerServletContextListener.contextInitialized(ViewerServletContextListener.java:62)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4701)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
Caused by: org.eclipse.birt.core.exception.CoreException
at org.eclipse.birt.core.framework.osgi.OSGILauncher.startup(OSGILauncher.java:90)
Re: OSGI nor found BIRT3.7 JBOSS [message #722850 is a reply to message #722847] Tue, 06 September 2011 19:33 Go to previous messageGo to next message
Sarah  is currently offline Sarah
Messages: 4
Registered: September 2011
Junior Member
I was trying to update the BIRT through the eclipse update manager and I got this error

Your original request has been modified.
"BIRT Chart Framework" is already installed, so an update will be performed instead.
"Eclipse BIRT Chart Context Sensitive Help Documentation" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: BIRT Chart Framework 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5 (org.eclipse.birt.chart.feature.group 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5)
Software currently installed: BIRT Framework 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k (org.eclipse.birt.feature.group 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k)
Only one of the following can be installed at once:
BIRT Core Package 2.6.0.v20100526 (org.eclipse.birt.core 2.6.0.v20100526)
BIRT Core Package 2.6.2.r262_v20110209 (org.eclipse.birt.core 2.6.2.r262_v20110209)
BIRT Core Package 3.7.0.v20110815-0857 (org.eclipse.birt.core 3.7.0.v20110815-0857)
BIRT Core Package 3.7.0.v20110519 (org.eclipse.birt.core 3.7.0.v20110519)
BIRT Core Package 3.7.0.v20110608 (org.eclipse.birt.core 3.7.0.v20110608)
BIRT Core Package 2.6.1.v20100819 (org.eclipse.birt.core 2.6.1.v20100819)
Cannot satisfy dependency:
From: BIRT Chart Framework 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5 (org.eclipse.birt.chart.feature.group 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5)
To: org.eclipse.birt.core [3.7.0.v20110608]
Cannot satisfy dependency:
From: BIRT Framework 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k (org.eclipse.birt.feature.group 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k)
To: org.eclipse.birt.core [3.7.0.v20110519]



Sp I want back through the update manager and I saw that I have some earlier versions installed.
I clicked on already installed and I did not find any birt 2.6 jars installed.
How do I remove the old versions?
Re: OSGI nor found BIRT3.7 JBOSS [message #723539 is a reply to message #722850] Thu, 08 September 2011 14:37 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Can you open a bugzilla entry for this?

JAson

On 9/6/2011 7:33 PM, Sarah wrote:
> I was trying to update the BIRT through the eclipse update manager and I
> got this error
>
> Your original request has been modified.
> "BIRT Chart Framework" is already installed, so an update will be
> performed instead.
> "Eclipse BIRT Chart Context Sensitive Help Documentation" is already
> installed, so an update will be performed instead.
> Cannot complete the install because of a conflicting dependency.
> Software being installed: BIRT Chart Framework
> 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5
> (org.eclipse.birt.chart.feature.group 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5)
> Software currently installed: BIRT Framework
> 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k
> (org.eclipse.birt.feature.group
> 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k)
> Only one of the following can be installed at once: BIRT Core Package
> 2.6.0.v20100526 (org.eclipse.birt.core 2.6.0.v20100526)
> BIRT Core Package 2.6.2.r262_v20110209 (org.eclipse.birt.core
> 2.6.2.r262_v20110209)
> BIRT Core Package 3.7.0.v20110815-0857 (org.eclipse.birt.core
> 3.7.0.v20110815-0857)
> BIRT Core Package 3.7.0.v20110519 (org.eclipse.birt.core 3.7.0.v20110519)
> BIRT Core Package 3.7.0.v20110608 (org.eclipse.birt.core 3.7.0.v20110608)
> BIRT Core Package 2.6.1.v20100819 (org.eclipse.birt.core 2.6.1.v20100819)
> Cannot satisfy dependency:
> From: BIRT Chart Framework 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5
> (org.eclipse.birt.chart.feature.group 3.7.0.v20110603-7r9e1FQCnvKN67BslXE5)
> To: org.eclipse.birt.core [3.7.0.v20110608]
> Cannot satisfy dependency:
> From: BIRT Framework 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k
> (org.eclipse.birt.feature.group
> 3.7.0.v20110329-B7F907AGS6mD_gcl4-07XxVEeM9k)
> To: org.eclipse.birt.core [3.7.0.v20110519]
>
>
>
> Sp I want back through the update manager and I saw that I have some
> earlier versions installed.
> I clicked on already installed and I did not find any birt 2.6 jars
> installed.
> How do I remove the old versions?
Re: OSGI nor found BIRT3.7 JBOSS [message #723616 is a reply to message #723539] Thu, 08 September 2011 20:45 Go to previous messageGo to next message
Sarah  is currently offline Sarah
Messages: 4
Registered: September 2011
Junior Member
Ok so I read some where that Birt 3.7 can only be used with eclipse 3.7 (indigo)
So I downloaded the new version and added the seam facets to my web project. I am using apache tomcat 7.
When i run the server i get this error.

09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class org.eclipse.birt.report.listener.ViewerHttpSessionListener
java.lang.ClassNotFoundException: org.eclipse.birt.report.listener.ViewerHttpSessionListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4638)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class org.eclipse.birt.report.listener.ViewerServletContextListener
java.lang.ClassNotFoundException: org.eclipse.birt.report.listener.ViewerServletContextListener
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4638)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)
09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
SEVERE: Skipped installing application listeners due to previous error(s)
09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext startInternal
SEVERE: Error listenerStart
Re: OSGI nor found BIRT3.7 JBOSS [message #724558 is a reply to message #723616] Mon, 12 September 2011 10:20 Go to previous message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Sarah,

What is contained in the deployed apps WEB-INF/lib?
Does it contain all the jars from the birt runtime download's
reportengine/lib directory?

Jason

On 9/8/2011 8:45 PM, Sarah wrote:
> Ok so I read some where that Birt 3.7 can only be used with eclipse 3.7
> (indigo)
> So I downloaded the new version and added the seam facets to my web
> project. I am using apache tomcat 7.
> When i run the server i get this error.
>
> 09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
> SEVERE: Error configuring application listener of class
> org.eclipse.birt.report.listener.ViewerHttpSessionListener
> java.lang.ClassNotFoundException:
> org.eclipse.birt.report.listener.ViewerHttpSessionListener
> at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
>
> at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
>
> at
> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4638)
>
> at
> org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
> at
> org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
> at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
> at java.util.concurrent.FutureTask.run(FutureTask.java:138)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>
> at java.lang.Thread.run(Thread.java:662)
> 09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
> SEVERE: Error configuring application listener of class
> org.eclipse.birt.report.listener.ViewerServletContextListener
> java.lang.ClassNotFoundException:
> org.eclipse.birt.report.listener.ViewerServletContextListener
> at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
>
> at
> org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
>
> at
> org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
>
> at
> org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4638)
>
> at
> org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
> at
> org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
> at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
> at java.util.concurrent.FutureTask.run(FutureTask.java:138)
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>
> at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>
> at java.lang.Thread.run(Thread.java:662)
> 09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext listenerStart
> SEVERE: Skipped installing application listeners due to previous error(s)
> 09-Sep-2011 02:38:17 org.apache.catalina.core.StandardContext startInternal
> SEVERE: Error listenerStart
Previous Topic:split(".") does not work
Next Topic:error configuring application listener
Goto Forum:
  


Current Time: Wed Aug 20 20:37:34 EDT 2014

Powered by FUDForum. Page generated in 0.01764 seconds