Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » B3 » CCE when running demo build
CCE when running demo build [message #722109] Sun, 04 September 2011 13:37 Go to next message
Marcel Bruch is currently offline Marcel Bruch
Messages: 230
Registered: July 2009
Senior Member
Hi,

I'm trying to run the demo builds from SVN but unfortunately I get a classcastexception when running from IDE:

java.lang.ClassCastException: org.eclipse.b3.aggregator.impl.ValidationSetImpl cannot be cast to org.eclipse.b3.aggregator.Aggregation
at org.eclipse.b3.aggregator.impl.ContributionImpl.getAllMavenMappings(ContributionImpl.java:499)
at org.eclipse.b3.aggregator.engine.Builder.mavenInitializeMirroring(Builder.java:1402)
at org.eclipse.b3.aggregator.engine.Builder.initializeArtifactMirroring(Builder.java:1009)
at org.eclipse.b3.aggregator.engine.Builder.run(Builder.java:1654)
at org.eclipse.b3.aggregator.presentation.AggregatorActionBarContributor$BuildAggregationAction$1.run(AggregatorActionBarContributor.java:292)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)


I used the latest build from your update site. Any ideas?

Examples used:
http://dev.eclipse.org/svnroot/modeling/org.eclipse.emft.b3/trunk/org.eclipse.b3.aggregator.samples/buckminster_helios_maven.b3aggr


tw: @MarcelBruch
tw: @Recommenders
Re: CCE when running demo build [message #722169 is a reply to message #722109] Sun, 04 September 2011 21:57 Go to previous messageGo to next message
Henrik Lindberg is currently offline Henrik Lindberg
Messages: 2500
Registered: July 2009
Senior Member
b3 recently migrated to git. Don't know if that has anything to do with
it - one would expect that if the files are still accessible in the SVN
repo that they could be read.

Will see what people say about this tomorrow when they are back to work.

- henrik

On 9/4/11 3:37 PM, Marcel Bruch wrote:
> Hi,
> I'm trying to run the demo builds from SVN but unfortunately I get a
> classcastexception when running from IDE:
>
> java.lang.ClassCastException:
> org.eclipse.b3.aggregator.impl.ValidationSetImpl cannot be cast to
> org.eclipse.b3.aggregator.Aggregation
> at
> org.eclipse.b3.aggregator.impl.ContributionImpl.getAllMavenMappings(ContributionImpl.java:499)
>
> at
> org.eclipse.b3.aggregator.engine.Builder.mavenInitializeMirroring(Builder.java:1402)
>
> at
> org.eclipse.b3.aggregator.engine.Builder.initializeArtifactMirroring(Builder.java:1009)
>
> at org.eclipse.b3.aggregator.engine.Builder.run(Builder.java:1654)
> at
> org.eclipse.b3.aggregator.presentation.AggregatorActionBarContributor$BuildAggregationAction$1.run(AggregatorActionBarContributor.java:292)
>
> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
>
>
> I used the latest build from your update site. Any ideas?
>
> Examples used:
> http://dev.eclipse.org/svnroot/modeling/org.eclipse.emft.b3/trunk/org.eclipse.b3.aggregator.samples/buckminster_helios_maven.b3aggr
>
Re: CCE when running demo build [message #722206 is a reply to message #722169] Mon, 05 September 2011 04:38 Go to previous message
Marcel Bruch is currently offline Marcel Bruch
Messages: 230
Registered: July 2009
Senior Member
Thanks. I'm away for a week from today. I'll retry then.

BTW:
Regarding building a Maven repository: Are there any information available how version ranges are mapped to OSGI Versions? How are package imports mapped? I couldn't find any information on the Wiki page about this.

Thanks,
Marcel


tw: @MarcelBruch
tw: @Recommenders
Previous Topic:[b3 0.2.0] "Registry Directory not available..."
Next Topic:How to proceed with validation errors in a b3aggr
Goto Forum:
  


Current Time: Mon Oct 20 13:11:36 GMT 2014

Powered by FUDForum. Page generated in 0.01977 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software