Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Editing AUT Configuration in New Project wiz is very slow
Editing AUT Configuration in New Project wiz is very slow [message #720456] Tue, 30 August 2011 15:56 Go to next message
jubula_newbie  is currently offline jubula_newbie Friend
Messages: 4
Registered: August 2011
Junior Member
New Project Wizard, AUT page:
Typing something in the "AUT ID" field causes the entire application to hang for a long time, while saying "(Not Responding)" in the title bar.

This happens both when using the stand-alone Jubula application as well as when having Jubula installed under my Eclipse Indigo.

The long delay is also seen when using the Project Properties, while trying to edit an existing AUT configuration.

Is there by any chance a bug-fix available for this?

Environment:

Java 1.6.0_26
Windows XP
I have started the AUT Agent and connected to it.


Re: Editing AUT Configuration in New Project wiz is very slow [message #720709 is a reply to message #720456] Wed, 31 August 2011 06:06 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Are you working with an AUT Agent on a remote system? If so, perhaps it is the same problem noted here:
forum http://www.eclipse.org/forums/index.php/t/237017/
Re: Editing AUT Configuration in New Project wiz is very slow [message #720712 is a reply to message #720709] Wed, 31 August 2011 06:23 Go to previous messageGo to next message
jubula_newbie  is currently offline jubula_newbie Friend
Messages: 4
Registered: August 2011
Junior Member
Thanks for your reply.

Everything is running on my local PC. But the symptom looks the same as for the message you refer to: Every time I type in a single letter or I paste the contents of the clipboard into the "AUT ID" field, there is a timeout of maybe a minute or more.

It is my first try with Jubula, so it is a completely fresh install. However, Jubula look very promising, so I would really like to get it going.
Re: Editing AUT Configuration in New Project wiz is very slow [message #720936 is a reply to message #720712] Wed, 31 August 2011 14:00 Go to previous messageGo to next message
jubula_newbie  is currently offline jubula_newbie Friend
Messages: 4
Registered: August 2011
Junior Member
I am trying out the "Accessing the prepared Project" in the User Manual:

Importing the "samples" and "bound_modules_samples" projects => OK
Opened the "samples" project. => OK
Start the AUT Agent => OK
connect to the AUT Agent => OK
and start the AUT => FAIL!

When connecting to the AUT Agent, I see the message at the status bar: "Resolving Startable AUTs"

However, there are no AUTs found when pressing the arrow button next to the "Start AUT" button. So I cannot start any of the sample AUTs from within Jubula.

Is this yet another symptom of the same problem? Does it help you narrowing in what the problem could be?
Re: Editing AUT Configuration in New Project wiz is very slow [message #721191 is a reply to message #720936] Thu, 01 September 2011 07:06 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Hi,

Maybe some of the hints in this section could help:
http://help.eclipse.org/indigo/topic/org.eclipse.jubula.client.ua.help/html/manual/node240.html

If you don't have any AUTs being offered, then I suspect it could be something to do with the language:
http://help.eclipse.org/indigo/topic/org.eclipse.jubula.client.ua.help/html/manual/node71.html

Or that you are connected to an AUT Agent that is not called localhost (an AUT configuration is specified for a specific Agent, and if you are not connected to that Agent, then the configuration will not be offered to start).

Hope this helps!
Alex
Re: Editing AUT Configuration in New Project wiz is very slow [message #721312 is a reply to message #721191] Thu, 01 September 2011 12:30 Go to previous messageGo to next message
jubula_newbie  is currently offline jubula_newbie Friend
Messages: 4
Registered: August 2011
Junior Member
Thanks for your reply. I have reached a step forward:

On my PC, I have a VPN SecureClient. Apparently, it has applied a "Security Policy" to the PC. I tried to disable the security policy and restarted Jubula and the AUT Agent. After connecting to the AUT Agent and opening either the Sample project or the one I defined on my own, Jubula gave me a list of AUTs to choose from when pressing the arrow button next to the "Start AUT" button. Great!

Editing an AUT configuration still causes a lot of long delays.

However, this morning I tried to install Jubula as well as my RCP project on a Windows-7, 64bit PC. And here everything worked right out of the box!

So the delay problem seems to stick to my old Windows-XP PC.

I am still required to also test my RCP application on Windows-XP, so maybe I will have to try finding another PC one and hope that things will work better there. Meanwhile I will go on working with Jubula on Windows-7.
Re: Editing AUT Configuration in New Project wiz is very slow [message #722337 is a reply to message #721312] Mon, 05 September 2011 12:15 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1193
Registered: July 2009
Senior Member
Hi,

A hint that might help: I heard from a colleague today that this may be an issue when using the H2 (embedded) database. For your XP tests you might want to try using Oracle instead. (We generally recommend not using the H2 DB for productive testing anyway.)

Hope that helps!
Alex
Previous Topic:Referenced Testcase could not be found
Next Topic:AUT Agend does not start
Goto Forum:
  


Current Time: Tue Dec 23 03:53:39 GMT 2014

Powered by FUDForum. Page generated in 0.01867 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software