Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » problem with large html in text element
problem with large html in text element [message #720114] Mon, 29 August 2011 19:05 Go to next message
eminaguil is currently offline eminaguil
Messages: 8
Registered: February 2011
Junior Member
Hi,
I got a report with a single record in a table, some elements in detail rows and the last detail row contains a text element with an html as content type. All the rows are 100% height

The problem is that if the html takes 2 pages, when you see the preview you see the same report as page 1 and page 2, and when you print the report as pdf, you got 4 pages, the report in page 1 and 2 and then it repeats.

If the html in the report has n pages in the preview it shows n pages of the same report and in pdf it shows n*n pages.

I´m using Birt 3.7 on apache-tomcat-7.0.19, same problem with 2.6 on apache-tomcat-7.0.6 . I've tested in FF3 up to FF6 and IE8

Best regards

___________
Edwin
Re: problem with large html in text element [message #720361 is a reply to message #720114] Tue, 30 August 2011 09:06 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason Weathersby
Messages: 9167
Registered: July 2009
Senior Member

Edwin,

Can you log a bugzilla entry for this?

Jason

On 8/29/2011 7:05 PM, eminaguil wrote:
> Hi,
> I got a report with a single record in a table, some elements in detail
> rows and the last detail row contains a text element with an html as
> content type. All the rows are 100% height
>
> The problem is that if the html takes 2 pages, when you see the preview
> you see the same report as page 1 and page 2, and when you print the
> report as pdf, you got 4 pages, the report in page 1 and 2 and then it
> repeats.
>
> If the html in the report has n pages in the preview it shows n pages of
> the same report and in pdf it shows n*n pages.
>
> I´m using Birt 3.7 on apache-tomcat-7.0.19, same problem with 2.6 on
> apache-tomcat-7.0.6 . I've tested in FF3 up to FF6 and IE8
>
> Best regards
>
> ___________
> Edwin
Re: problem with large html in text element [message #720483 is a reply to message #720361] Tue, 30 August 2011 13:06 Go to previous message
eminaguil is currently offline eminaguil
Messages: 8
Registered: February 2011
Junior Member
It´s done
Bug 356229 has been added to the database

Thanks in advance Jason

__________________
Edwin
Previous Topic:Problem with some Fonts in created docs
Next Topic:Export data option on BIRT report
Goto Forum:
  


Current Time: Thu Jul 24 09:19:09 EDT 2014

Powered by FUDForum. Page generated in 0.02469 seconds