Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » WebService datasource/dataset against JBoss AS 6/7 generated WebService/WSDL
WebService datasource/dataset against JBoss AS 6/7 generated WebService/WSDL [message #717776] Mon, 22 August 2011 10:04 Go to next message
Nicklas Karlsson is currently offline Nicklas KarlssonFriend
Messages: 29
Registered: July 2009
Junior Member
Anyone have experiences with using @WebService exposed services with BIRT? I have a simple

@Stateless
@WebService
@Typed({})
public class WebMarelaReportWebService implements WebMarelaReport
{
	@Inject
	@Lahi
	private WebMarelaReport report;

	public Raportti haeKulutusraportti(String installaatio, String lahde, String asiakas, String alkaa, String loppuu, String raporttiavain)
	{
		return report.haeKulutusraportti(installaatio, lahde, asiakas, alkaa, loppuu, raporttiavain);
	}

	public Kulutusanalyysiraportti haeKulutusanalyysiraportti(String installaatio, String asiakas, String alkaa, String loppuu, String raporttiavain)
	{
		return report.haeKulutusanalyysiraportti(installaatio, asiakas, alkaa, loppuu, raporttiavain);
	}


and I have verified with SoapUI that it works as expected.

I create a WebService datasource and ping it, fine. Then I try creating a dataset against that datasource. I browse down to the "haeKulutusRaportti"-operation and click next but I see no parameters? Any theories? SoapUI detected them fine.

I edit the parameters in and move on. I try the "Use operation response schema defined in the data source WSDL" and go next but in the row mapping I don't see any subelements of the "haeKulutusraporttiResponse". Back

I try the "Use schema from response" and go next and I see a rowmapping that goes to "return" but no subelements.

I grab the SoapUI response and try use that as a sample data but that gives me a "XML data source file is invalid".

So at this time I'm pretty stuck and would love some help (wsdl attached)
  • Attachment: OSTi.xml
    (Size: 9.14KB, Downloaded 93 times)
Re: WebService datasource/dataset against JBoss AS 6/7 generated WebService/WSDL [message #717903 is a reply to message #717776] Mon, 22 August 2011 16:51 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Are your parameters defined as shown in this article?
http://www.birt-exchange.org/org/devshare/designing-birt-reports/461-birt-web-service-oda-article/

Jason

On 8/22/2011 6:04 AM, Nicklas Karlsson wrote:
> Anyone have experiences with using @WebService exposed services with BIRT? I have a simple
>
>
> @Stateless
> @WebService
> @Typed({})
> public class WebMarelaReportWebService implements WebMarelaReport
> {
> @Inject
> @Lahi
> private WebMarelaReport report;
>
> public Raportti haeKulutusraportti(String installaatio, String lahde, String asiakas, String alkaa, String loppuu, String raporttiavain)
> {
> return report.haeKulutusraportti(installaatio, lahde, asiakas, alkaa, loppuu, raporttiavain);
> }
>
> public Kulutusanalyysiraportti haeKulutusanalyysiraportti(String installaatio, String asiakas, String alkaa, String loppuu, String raporttiavain)
> {
> return report.haeKulutusanalyysiraportti(installaatio, asiakas, alkaa, loppuu, raporttiavain);
> }
>
>
> and I have verified with SoapUI that it works as expected.
>
> I create a WebService datasource and ping it, fine. Then I try creating a dataset against that datasource. I browse down to the "haeKulutusRaportti"-operation and click next but I see no parameters? Any theories? SoapUI detected them fine.
>
> I edit the parameters in and move on. I try the "Use operation response schema defined in the data source WSDL" and go next but in the row mapping I don't see any subelements of the "haeKulutusraporttiResponse". Back
>
> I try the "Use schema from response" and go next and I see a rowmapping that goes to "return" but no subelements.
>
> I grab the SoapUI response and try use that as a sample data but that gives me a "XML data source file is invalid".
>
> So at this time I'm pretty stuck and would love some help (wsdl attached)
Re: WebService datasource/dataset against JBoss AS 6/7 generated WebService/WSDL [message #717931 is a reply to message #717903] Mon, 22 August 2011 18:35 Go to previous messageGo to next message
Nicklas Karlsson is currently offline Nicklas KarlssonFriend
Messages: 29
Registered: July 2009
Junior Member
Thanks for you reply!

I actually got it working my manually editing in the <arg0/> ... <arg5/>. Not sure why SoapUI could detect them from the WSDL where BIRT couldn't. I got the rows and columns mapped by saving a SoapUI sample response (Save AS, not copy&paste if someone else tries this) and then I could see the whole XPath down to the response fields. But BIRT couldn't parse this info from the reponse by itself...
Re: WebService datasource/dataset against JBoss AS 6/7 generated WebService/WSDL [message #717981 is a reply to message #717931] Mon, 22 August 2011 22:07 Go to previous message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Thanks for the update

On 8/22/2011 2:35 PM, Nicklas Karlsson wrote:
> Thanks for you reply!
>
> I actually got it working my manually editing in the <arg0/> ...
> <arg5/>. Not sure why SoapUI could detect them from the WSDL where BIRT
> couldn't. I got the rows and columns mapped by saving a SoapUI sample
> response (Save AS, not copy&paste if someone else tries this) and then I
> could see the whole XPath down to the response fields. But BIRT couldn't
> parse this info from the reponse by itself...
Previous Topic:Display Multiple Line Field
Next Topic:OpenOffice-Formats are missing from WebViewer in Birt 3.7 Deployment
Goto Forum:
  


Current Time: Wed Nov 26 14:16:21 GMT 2014

Powered by FUDForum. Page generated in 0.01821 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software