Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » How to install Java code generator for Papyrus
How to install Java code generator for Papyrus [message #717155] Fri, 19 August 2011 09:00 Go to next message
copci  is currently offline copci
Messages: 1
Registered: August 2011
Junior Member
I am trying to install this java code generator for Papyrus. I tried to install it on two different versions of Eclipse(Indigo and Helios) and to use three different Papyrus MDT versions(0.7, 0.8 and 0.9). I have also installed Acceleo, as recommended on Papyrus Add-ins site. Unfortunately, the same error keeps occuring in all these attemps:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214)
  Missing requirement: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214) requires 'com.cea.papyrus.feature.feature.group 1.9.0' but it could not be found


Do you have any idea of what can cause this error?

Thanks a lot
Re: How to install Java code generator for Papyrus [message #722111 is a reply to message #717155] Sun, 04 September 2011 09:45 Go to previous message
Luis Espinal is currently offline Luis Espinal
Messages: 1
Registered: September 2011
Junior Member
I'm having the exact same issue:

Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214)
Missing requirement: Java code generator for Papyrus 1.3.3.200911231214 (com.cea.papyrus.gen.java.feature.group 1.3.3.200911231214) requires 'com.cea.papyrus.feature.feature.group 1.9.0' but it could not be found


In fact, I'm having that same issue with any and all of the Papyrus plug-ins. For instance, if I try to install the MARTE profile:

Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: UML profile for MARTE 1.2.2.200911231304 (com.cea.papyrus.marte.feature.group 1.2.2.200911231304)
Missing requirement: UML profile for MARTE 1.2.2.200911231304 (com.cea.papyrus.marte.feature.group 1.2.2.200911231304) requires 'com.cea.papyrus.feature.feature.group 1.11.0' but it could not be found


In every case, feature X cannot be installed because a 'feature' is missing. But I've already tried everything (installing MDT on Helios and/or Indigo, and installing Papyrus from the 'Install Modeling Components' option).

I'm currently removing Papyrus to install it directly from the Papyrus update site (as opposed to through the 'Install Modeling Components' option). Let's see how it goes.
Previous Topic:CallEvent to trigger stateMachine transition ?
Next Topic:Create custom diagram type from profile
Goto Forum:
  


Current Time: Wed Aug 27 13:07:36 EDT 2014

Powered by FUDForum. Page generated in 0.03222 seconds