Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » OS version specific plugin fragments
OS version specific plugin fragments [message #716968] Thu, 18 August 2011 22:36
Richard Adams is currently offline Richard Adams
Messages: 77
Registered: July 2009
Location: Edinburgh
Member
Hello,
In our RCP app we have a plugin that uses 3rd party native code libraries, which we supply in plugin fragments for various OSs. This has worked fine, but now we have a problem that in the latest version of the libraries, they need different binaries for different versions of Mac OSX ( 10.5 & 10.6).
There doesn't seem to be a way to specify this in the feature manifest 'environment combinations' tab as they're both using the same OS (there's only 1 option - 'MacOSX') , window system, language and architecture (x86)).
For various reasons we need to use the 32 bit version of these libraries even on 10.6, so we can't distinguish between the libraries on the basis of their target architecture.

Has anyone come across a solution to this (I'd imagine it might involve some dynamic loading of a fragment depending on the OS version but don't know where to start with this).
Thanks

Richard


Previous Topic:Poor performance when drawing a Polyline in an Eclipse View
Next Topic:Headless/multi-platform build - what is the preferred way to do that?
Goto Forum:
  


Current Time: Tue Sep 16 07:39:49 GMT 2014

Powered by FUDForum. Page generated in 0.01624 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software