Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Technology Project and PMC » Photran for Galileo?
Photran for Galileo? [message #75901] Sat, 11 July 2009 19:08 Go to next message
Dan Thurman is currently offline Dan Thurman
Messages: 57
Registered: July 2009
Member
I could not locate anything for Photran newsgroup,
so if this is the wrong newsgroup for Photran,
please let me know?

Anyway, I manually installed the latest Photran
in Galileo, and it *seems* to work in constructing
a Fortran project, but unfortunately the editor
breaks when attempting to create a source-file.

So the question is, is Photran going to become
available under Galileo and if so, when is the
target date?

Thanks!
Dan
Re: Photran for Galileo? [message #75923 is a reply to message #75901] Sun, 12 July 2009 03:11 Go to previous messageGo to next message
Wayne Beaton is currently offline Wayne Beaton
Messages: 499
Registered: July 2009
Senior Member
The Photran project has been merged into the Parallel Tools Project.

http://eclipse.org/ptp/

Perhaps you can find your answers there.

HTH,

Wayne

Dan Thurman wrote:
> I could not locate anything for Photran newsgroup,
> so if this is the wrong newsgroup for Photran,
> please let me know?
>
> Anyway, I manually installed the latest Photran
> in Galileo, and it *seems* to work in constructing
> a Fortran project, but unfortunately the editor
> breaks when attempting to create a source-file.
>
> So the question is, is Photran going to become
> available under Galileo and if so, when is the
> target date?
>
> Thanks!
> Dan
Re: Photran for Galileo? [message #75937 is a reply to message #75923] Sun, 12 July 2009 19:46 Go to previous message
Dan Thurman is currently offline Dan Thurman
Messages: 57
Registered: July 2009
Member
On Sat, 11 Jul 2009 23:11:40 -0400, Wayne Beaton wrote:

> The Photran project has been merged into the Parallel Tools Project.
>
> http://eclipse.org/ptp/
>
> Perhaps you can find your answers there.
>
> HTH,
>
> Wayne
>
> Dan Thurman wrote:
>> I could not locate anything for Photran newsgroup, so if this is the
>> wrong newsgroup for Photran, please let me know?
>>
>> Anyway, I manually installed the latest Photran in Galileo, and it
>> *seems* to work in constructing a Fortran project, but unfortunately
>> the editor breaks when attempting to create a source-file.
>>
>> So the question is, is Photran going to become available under Galileo
>> and if so, when is the target date?
>>
>> Thanks!
>> Dan

Well, I followed that link, and then it leads to
Photran as if it was separated out of the PTP,
then there is a note saying that they are planning
to complete porting to Galileo in Sept 09.

Not wanting to wait until Sept 09, I tried to see if
it were possible to download the most current Photran
& and the older CDT v5.0.1/2 zipped jars, adding the
path information to the "local source archives",
selected "Photran", and let it fly. Interestingly,
"Photran" entered into dependency testing, and then
displayed installation error (and refused to install)
as follows:

============================================================ ======
Cannot complete the install because of a conflicting dependency.
Software being installed: Photran End-User Runtime 4.0.5.200906291151
(org.eclipse.photran.feature.group 4.0.5.200906291151)
Software currently installed: Eclipse C/C++ Development Tools
6.0.0.200906161748 (org.eclipse.cdt.feature.group 6.0.0.200906161748)
Only one of the following can be installed at once:
C/C++ Development Tools GDB/MI CDI Debugger Core 6.0.0.200906161748
(org.eclipse.cdt.debug.mi.core 6.0.0.200906161748)
org.eclipse.cdt.debug.mi.core 5.0.1.200809120802
Cannot satisfy dependency:
From: Eclipse C/C++ Development Tools 5.0.1.200809120802
(org.eclipse.cdt.feature.group 5.0.1.200809120802)
To: org.eclipse.cdt.gnu.debug.feature.group
Cannot satisfy dependency:
From: Eclipse C/C++ Development Tools 6.0.0.200906161748
(org.eclipse.cdt.feature.group 6.0.0.200906161748)
To: org.eclipse.cdt.gnu.debug.feature.group [6.0.0.200906161748]
Cannot satisfy dependency:
From: CDT GNU Toolchain Debug Support 5.0.1.200809120802
(org.eclipse.cdt.gnu.debug.feature.group 5.0.1.200809120802)
To: org.eclipse.cdt.debug.mi.core [5.0.0,6.0.0)
Cannot satisfy dependency:
From: CDT GNU Toolchain Debug Support 6.0.0.200906161748
(org.eclipse.cdt.gnu.debug.feature.group 6.0.0.200906161748)
To: org.eclipse.cdt.debug.mi.core [6.0.0,7.0.0)
Cannot satisfy dependency:
From: Photran End-User Runtime 4.0.5.200906291151
(org.eclipse.photran.feature.group 4.0.5.200906291151)
To: org.eclipse.cdt.feature.group [5.0.1,6.0.0)
============================================================ ======

Ah well, too bad. Looks like I will have to wait
for Sept 09 as there are too many dependencies that
are incompatible with Galileo's configurations.

FWIW,
Dan
Re: Photran for Galileo? [message #601958 is a reply to message #75901] Sun, 12 July 2009 03:11 Go to previous message
Wayne Beaton is currently offline Wayne Beaton
Messages: 499
Registered: July 2009
Senior Member
The Photran project has been merged into the Parallel Tools Project.

http://eclipse.org/ptp/

Perhaps you can find your answers there.

HTH,

Wayne

Dan Thurman wrote:
> I could not locate anything for Photran newsgroup,
> so if this is the wrong newsgroup for Photran,
> please let me know?
>
> Anyway, I manually installed the latest Photran
> in Galileo, and it *seems* to work in constructing
> a Fortran project, but unfortunately the editor
> breaks when attempting to create a source-file.
>
> So the question is, is Photran going to become
> available under Galileo and if so, when is the
> target date?
>
> Thanks!
> Dan
Re: Photran for Galileo? [message #601964 is a reply to message #75923] Sun, 12 July 2009 19:46 Go to previous message
Dan Thurman is currently offline Dan Thurman
Messages: 57
Registered: July 2009
Member
On Sat, 11 Jul 2009 23:11:40 -0400, Wayne Beaton wrote:

> The Photran project has been merged into the Parallel Tools Project.
>
> http://eclipse.org/ptp/
>
> Perhaps you can find your answers there.
>
> HTH,
>
> Wayne
>
> Dan Thurman wrote:
>> I could not locate anything for Photran newsgroup, so if this is the
>> wrong newsgroup for Photran, please let me know?
>>
>> Anyway, I manually installed the latest Photran in Galileo, and it
>> *seems* to work in constructing a Fortran project, but unfortunately
>> the editor breaks when attempting to create a source-file.
>>
>> So the question is, is Photran going to become available under Galileo
>> and if so, when is the target date?
>>
>> Thanks!
>> Dan

Well, I followed that link, and then it leads to
Photran as if it was separated out of the PTP,
then there is a note saying that they are planning
to complete porting to Galileo in Sept 09.

Not wanting to wait until Sept 09, I tried to see if
it were possible to download the most current Photran
& and the older CDT v5.0.1/2 zipped jars, adding the
path information to the "local source archives",
selected "Photran", and let it fly. Interestingly,
"Photran" entered into dependency testing, and then
displayed installation error (and refused to install)
as follows:

============================================================ ======
Cannot complete the install because of a conflicting dependency.
Software being installed: Photran End-User Runtime 4.0.5.200906291151
(org.eclipse.photran.feature.group 4.0.5.200906291151)
Software currently installed: Eclipse C/C++ Development Tools
6.0.0.200906161748 (org.eclipse.cdt.feature.group 6.0.0.200906161748)
Only one of the following can be installed at once:
C/C++ Development Tools GDB/MI CDI Debugger Core 6.0.0.200906161748
(org.eclipse.cdt.debug.mi.core 6.0.0.200906161748)
org.eclipse.cdt.debug.mi.core 5.0.1.200809120802
Cannot satisfy dependency:
From: Eclipse C/C++ Development Tools 5.0.1.200809120802
(org.eclipse.cdt.feature.group 5.0.1.200809120802)
To: org.eclipse.cdt.gnu.debug.feature.group
Cannot satisfy dependency:
From: Eclipse C/C++ Development Tools 6.0.0.200906161748
(org.eclipse.cdt.feature.group 6.0.0.200906161748)
To: org.eclipse.cdt.gnu.debug.feature.group [6.0.0.200906161748]
Cannot satisfy dependency:
From: CDT GNU Toolchain Debug Support 5.0.1.200809120802
(org.eclipse.cdt.gnu.debug.feature.group 5.0.1.200809120802)
To: org.eclipse.cdt.debug.mi.core [5.0.0,6.0.0)
Cannot satisfy dependency:
From: CDT GNU Toolchain Debug Support 6.0.0.200906161748
(org.eclipse.cdt.gnu.debug.feature.group 6.0.0.200906161748)
To: org.eclipse.cdt.debug.mi.core [6.0.0,7.0.0)
Cannot satisfy dependency:
From: Photran End-User Runtime 4.0.5.200906291151
(org.eclipse.photran.feature.group 4.0.5.200906291151)
To: org.eclipse.cdt.feature.group [5.0.1,6.0.0)
============================================================ ======

Ah well, too bad. Looks like I will have to wait
for Sept 09 as there are too many dependencies that
are incompatible with Galileo's configurations.

FWIW,
Dan
Previous Topic:Photran for Galileo?
Next Topic:New Process Framework Proposal comitter
Goto Forum:
  


Current Time: Wed Sep 24 00:29:24 GMT 2014

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software