Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » at() in OCLinEcore
at() in OCLinEcore [message #716023] Tue, 16 August 2011 04:34 Go to next message
AmenieV  is currently offline AmenieV
Messages: 13
Registered: June 2011
Junior Member
Hi,

I open my file.ecore with OCLinEcore, and I try to call at() but I see error caused by at(), it seems that the OCLinEcore editor don't know this function
because when I try it in OCL interactive consol,it works without problems.

Regards,
Re: at() in OCLinEcore [message #716200 is a reply to message #716023] Tue, 16 August 2011 12:20 Go to previous message
Ed Willink is currently offline Ed Willink
Messages: 4014
Registered: July 2009
Senior Member
Hi

You really must learn to report errors in a way that they can be understood.

How did you use at(). As quoted without arguments it is clearly an
error. GIven the wrong -> . navigation it could be an error.

What error did you get.

Which OCL Console did you use.

Which OCL version are you using?

Regards

Ed Willink

On 16/08/2011 09:34, AmenieV wrote:
> Hi,
>
> I open my file.ecore with OCLinEcore, and I try to call at() but I see
> error caused by at(), it seems that the OCLinEcore editor don't know
> this function
> because when I try it in OCL interactive consol,it works without
> problems.
>
> Regards,
Previous Topic:check OCL constraints as program constraints
Next Topic:extract elements from a collection
Goto Forum:
  


Current Time: Thu Jul 31 15:53:06 EDT 2014

Powered by FUDForum. Page generated in 0.01508 seconds