Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » cannot be read the detail 'width' from the ecore file using EOL(How to get the value of the detail 'width' from the ecore file using EOL ?)
cannot be read the detail 'width' from the ecore file using EOL [message #715465] Sun, 14 August 2011 01:18 Go to next message
vrm  is currently offline vrm
Messages: 31
Registered: June 2011
Member
When using EOL , it seems it does not identify width as a valid detail for an annotation.For instance,for the below annotation :

@gmf.link(label="name", source="source", target="target", target.decoration="arrow", width="2")

when running the EOL code to print out the details,it does not include width .
Is this a bug or am I missing something here ?
Re: cannot be read the detail 'width' from the ecore file using EOL [message #715555 is a reply to message #715465] Sun, 14 August 2011 09:22 Go to previous messageGo to next message
Antonio Garcia-Dominguez is currently offline Antonio Garcia-Dominguez
Messages: 304
Registered: January 2010
Senior Member
Could you post the code that you are using to access the ECore annotations, so we can have a look?

Re: cannot be read the detail 'width' from the ecore file using EOL [message #715596 is a reply to message #715555] Sun, 14 August 2011 14:16 Go to previous messageGo to next message
vrm  is currently offline vrm
Messages: 31
Registered: June 2011
Member
sample code that prints the details ( key and value) for the below annotation
@gmf.link(label="name", source="source", target="target", target.decoration="arrow", width="2")

EOL Code
operation Any printDetails()
{
for(ann in self.eAnnotations)
for(det in ann.details)
println(det.key + " " + det.value);
}

the output is below :

label name
source source
target target
target.decoration arrow

the 'width' is not pulled out from the annotated ecore file.
Re: cannot be read the detail 'width' from the ecore file using EOL [message #715632 is a reply to message #715596] Sun, 14 August 2011 19:52 Go to previous message
vrm  is currently offline vrm
Messages: 31
Registered: June 2011
Member
Sorry,please ignore this query.I got this working . I just realized that I had the wrong copy of the model loaded.
Previous Topic:(no subject)
Next Topic:[EVL] replace automated messages with mine
Goto Forum:
  


Current Time: Tue Jul 29 09:00:49 EDT 2014

Powered by FUDForum. Page generated in 0.01775 seconds