Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Bug with Undo after RenameEClassFeature
Bug with Undo after RenameEClassFeature [message #714718] Thu, 11 August 2011 11:18 Go to next message
Christian B is currently offline Christian BFriend
Messages: 68
Registered: August 2011
Member
Hi,


I am pretty sure the following behavior is not intended:


  1. Change name of any EClass with RenameEClassFeature
  2. Undo the change
  3. Now the pictogram element is out of date and if you update it, the name is the updated one (the one before the Undo)


I tried to figure out the behaviour by comparing the DirectEditFeature (where the Undo works correct) and the RenameEClassFeature, but was not able to...

Any Ideas?




Re: Bug with Undo after RenameEClassFeature [message #714727 is a reply to message #714718] Thu, 11 August 2011 11:43 Go to previous messageGo to next message
Matthias Gorning is currently offline Matthias GorningFriend
Messages: 81
Registered: April 2010
Location: Germany
Member
About which example in which version do you talk? Please, provide a little more context.
Re: Bug with Undo after RenameEClassFeature [message #714729 is a reply to message #714727] Thu, 11 August 2011 11:51 Go to previous messageGo to next message
Christian B is currently offline Christian BFriend
Messages: 68
Registered: August 2011
Member
sorry!

I refer to the tutorial of 0.8.0. It happens also in the plugin org.eclipse.grapiti.examples.tutorial (Version 0.8.0.v20110607-1252)

[Updated on: Thu, 11 August 2011 11:53]

Report message to a moderator

Re: Bug with Undo after RenameEClassFeature [message #714740 is a reply to message #714729] Thu, 11 August 2011 12:18 Go to previous messageGo to next message
Matthias Gorning is currently offline Matthias GorningFriend
Messages: 81
Registered: April 2010
Location: Germany
Member
You're right. This looks a little bit strange. Please, can you open a bugzilla for this problem?
Re: Bug with Undo after RenameEClassFeature [message #714742 is a reply to message #714740] Thu, 11 August 2011 12:19 Go to previous messageGo to next message
Tim Kaiser is currently offline Tim KaiserFriend
Messages: 118
Registered: July 2009
Senior Member
i tried it out as well and looks like a bug also from my side!
Re: Bug with Undo after RenameEClassFeature [message #714753 is a reply to message #714742] Thu, 11 August 2011 12:49 Go to previous messageGo to next message
Christian B is currently offline Christian BFriend
Messages: 68
Registered: August 2011
Member
I reported the bug via bugzilla Smile

https://bugs.eclipse.org/bugs/show_bug.cgi?id=354484
Re: Bug with Undo after RenameEClassFeature [message #715064 is a reply to message #714753] Fri, 12 August 2011 09:24 Go to previous message
Matthias Gorning is currently offline Matthias GorningFriend
Messages: 81
Registered: April 2010
Location: Germany
Member
It's fixed in the master branch.
Previous Topic:Properties and Listeners
Next Topic:Putting it all together
Goto Forum:
  


Current Time: Tue Nov 25 01:59:04 GMT 2014

Powered by FUDForum. Page generated in 0.02801 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software