Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Cannot open PerfmonAgent subnodes in AgentControl view
Cannot open PerfmonAgent subnodes in AgentControl view [message #75504] Thu, 29 June 2006 08:58 Go to next message
Eclipse User
Originally posted by: martin.schuetz.vmasch.at

I'm trying to monitor Windows System Trace (Perfmon - RAC_v6-0-1-3) with
TPTP 4.0.1 (Eclipse 3.1.1 on Windows XP) - unfortunately without success.
After starting the PerfmonAgent.exe I can add the agent in the "Profile"
window and when I click "Start monitoring" the agent appears in the
AgentControl view. But I only can expand the "PerfmonAgent" node - no
subnodes (e.g. "Processor" as described at
http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. tptp.platform.doc.user/tasks/simple_t_launchingAgent.htm )
....

PerfmonAgent-console shows the following:
Using Resource DLL "sysperf.dll", Communications DLL "rac.dll"
Sending agent name from the collection DLL - PerfmonAgent
PerfmonAgent received agentname of PerfmonAgent
Setting the agent name is the transfer DLL to PerfmonAgent
Loading RAC libraries
Getting RAC functions
Initializing RAC bindings
Connecting to RAC - PerfmonAgent - 1151478506071
Starting RAC listener
Allocating message block
RAC Startup succesful
Allocating buffer
RAC Command 00000050
RAC Agent Controller available
RAC Command 00000050
RAC Agent Controller available
RAC Command 00000050
RAC Agent Controller available
No agent monitoring yet (freq:3000ms)
No agent monitoring yet (freq:3000ms)
RAC Command 0000001A
Received an unrecognised RA_CUSTOM_COMMAND event,
name=var_string?HOST?localhost, value=var_string?HOST?localhost
RAC Command 00000050
RAC Agent Controller available
RAC Command 0000001A
Received an unrecognised RA_CUSTOM_COMMAND event,
name=var_string?PORT?10002, value=var_string?PORT?10002
RAC Command 00000050
RAC Agent Controller available
RAC Command 0000001A
RAC Command 00000050
RAC Agent Controller available
RAC Command 00000017
RAC Agent Started Monitoring 0
RAC Command 00000050
RAC Agent Controller available
RAC Command 0000001A
RAC Command 00000050
RAC Agent Controller available
Perfmon Datacollection:Collecting from host (null)
RAC Command 0000001A
Received an unrecognised RA_CUSTOM_COMMAND event, name=updatetree?238?true,
value=updatetree?238?true
RAC Command 00000050
RAC Agent Controller available
RAC Command 0000001A
Received an unrecognised RA_CUSTOM_COMMAND event, name=updatetree?230?true,
value=updatetree?230?true
RAC Command 00000050
RAC Agent Controller available

Anyone experienced the same problems?
What's going wrong?


Thanks,
Martin
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75535 is a reply to message #75504] Thu, 29 June 2006 09:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: RGuschin.computel.ru

Same problem :(

Martin Schuetz wrote:
> I'm trying to monitor Windows System Trace (Perfmon - RAC_v6-0-1-3) with
> TPTP 4.0.1 (Eclipse 3.1.1 on Windows XP) - unfortunately without success.
> After starting the PerfmonAgent.exe I can add the agent in the "Profile"
> window and when I click "Start monitoring" the agent appears in the
> AgentControl view. But I only can expand the "PerfmonAgent" node - no
> subnodes (e.g. "Processor" as described at
> http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. tptp.platform.doc.user/tasks/simple_t_launchingAgent.htm )
> ....
>
> PerfmonAgent-console shows the following:
> Using Resource DLL "sysperf.dll", Communications DLL "rac.dll"
> Sending agent name from the collection DLL - PerfmonAgent
> PerfmonAgent received agentname of PerfmonAgent
> Setting the agent name is the transfer DLL to PerfmonAgent
> Loading RAC libraries
> Getting RAC functions
> Initializing RAC bindings
> Connecting to RAC - PerfmonAgent - 1151478506071
> Starting RAC listener
> Allocating message block
> RAC Startup succesful
> Allocating buffer
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 00000050
> RAC Agent Controller available
> No agent monitoring yet (freq:3000ms)
> No agent monitoring yet (freq:3000ms)
> RAC Command 0000001A
> Received an unrecognised RA_CUSTOM_COMMAND event,
> name=var_string?HOST?localhost, value=var_string?HOST?localhost
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 0000001A
> Received an unrecognised RA_CUSTOM_COMMAND event,
> name=var_string?PORT?10002, value=var_string?PORT?10002
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 0000001A
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 00000017
> RAC Agent Started Monitoring 0
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 0000001A
> RAC Command 00000050
> RAC Agent Controller available
> Perfmon Datacollection:Collecting from host (null)
> RAC Command 0000001A
> Received an unrecognised RA_CUSTOM_COMMAND event, name=updatetree?238?true,
> value=updatetree?238?true
> RAC Command 00000050
> RAC Agent Controller available
> RAC Command 0000001A
> Received an unrecognised RA_CUSTOM_COMMAND event, name=updatetree?230?true,
> value=updatetree?230?true
> RAC Command 00000050
> RAC Agent Controller available
>
> Anyone experienced the same problems?
> What's going wrong?
>
>
> Thanks,
> Martin
>
>
> From - Thu
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75586 is a reply to message #75535] Thu, 29 June 2006 11:46 Go to previous messageGo to next message
Eclipse User
Originally posted by: lars.nospam.org

Hi,

Its been a while since I used 3.1.1 and TPTP 4.01, but here are some
suggestions:

1 The list of available topics can sometimes take time to appear! Wait
for a while....

2. The default severe name is localhost (defined in the Settings tab for
the Windows Perform) - perhaps this is not the case for you machine?
(for my company it is not)

/Lars





"Rodion Guschin" <RGuschin@computel.ru> skrev i meddelandet
news:e80jsk$r65$1@utils.eclipse.org...
> Same problem :(
>
> Martin Schuetz wrote:
>> I'm trying to monitor Windows System Trace (Perfmon - RAC_v6-0-1-3) with
>> TPTP 4.0.1 (Eclipse 3.1.1 on Windows XP) - unfortunately without success.
>> After starting the PerfmonAgent.exe I can add the agent in the "Profile"
>> window and when I click "Start monitoring" the agent appears in the
>> AgentControl view. But I only can expand the "PerfmonAgent" node - no
>> subnodes (e.g. "Processor" as described at
>> http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. tptp.platform.doc.user/tasks/simple_t_launchingAgent.htm )
>> ....
>>
>> PerfmonAgent-console shows the following:
>> Using Resource DLL "sysperf.dll", Communications DLL "rac.dll"
>> Sending agent name from the collection DLL - PerfmonAgent
>> PerfmonAgent received agentname of PerfmonAgent
>> Setting the agent name is the transfer DLL to PerfmonAgent
>> Loading RAC libraries
>> Getting RAC functions
>> Initializing RAC bindings
>> Connecting to RAC - PerfmonAgent - 1151478506071
>> Starting RAC listener
>> Allocating message block
>> RAC Startup succesful
>> Allocating buffer
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 00000050
>> RAC Agent Controller available
>> No agent monitoring yet (freq:3000ms)
>> No agent monitoring yet (freq:3000ms)
>> RAC Command 0000001A
>> Received an unrecognised RA_CUSTOM_COMMAND event,
>> name=var_string?HOST?localhost, value=var_string?HOST?localhost
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 0000001A
>> Received an unrecognised RA_CUSTOM_COMMAND event,
>> name=var_string?PORT?10002, value=var_string?PORT?10002
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 0000001A
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 00000017
>> RAC Agent Started Monitoring 0
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 0000001A
>> RAC Command 00000050
>> RAC Agent Controller available
>> Perfmon Datacollection:Collecting from host (null)
>> RAC Command 0000001A
>> Received an unrecognised RA_CUSTOM_COMMAND event,
>> name=updatetree?238?true, value=updatetree?238?true
>> RAC Command 00000050
>> RAC Agent Controller available
>> RAC Command 0000001A
>> Received an unrecognised RA_CUSTOM_COMMAND event,
>> name=updatetree?230?true, value=updatetree?230?true
>> RAC Command 00000050
>> RAC Agent Controller available
>>
>> Anyone experienced the same problems?
>> What's going wrong?
>>
>>
>> Thanks,
>> Martin From - Thu
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75756 is a reply to message #75586] Fri, 30 June 2006 02:19 Go to previous messageGo to next message
Eclipse User
Originally posted by: martin.schuetz.vmasch.at

Now I've tried with Eclipse 3.2.0 and TPTP 4.2 ... all worked fine!

"Lars Ohl
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75773 is a reply to message #75586] Fri, 30 June 2006 02:55 Go to previous messageGo to next message
Eclipse User
Originally posted by: RGuschin.computel.ru

Thanks :) changing host name works for me.
Another question - where can i see Perfmon logs like one Martin Schuetz
posted. I don`t have an idea where to look for.

Lars Ohlén wrote:
> Hi,
>
> Its been a while since I used 3.1.1 and TPTP 4.01, but here are some
> suggestions:
>
> 1 The list of available topics can sometimes take time to appear! Wait
> for a while....
>
> 2. The default severe name is localhost (defined in the Settings tab for
> the Windows Perform) - perhaps this is not the case for you machine?
> (for my company it is not)
>
> /Lars
>
>
>
>
>
> "Rodion Guschin" <RGuschin@computel.ru> skrev i meddelandet
> news:e80jsk$r65$1@utils.eclipse.org...
>> Same problem :(
>>
>> Martin Schuetz wrote:
>>> I'm trying to monitor Windows System Trace (Perfmon - RAC_v6-0-1-3) with
>>> TPTP 4.0.1 (Eclipse 3.1.1 on Windows XP) - unfortunately without success.
>>> After starting the PerfmonAgent.exe I can add the agent in the "Profile"
>>> window and when I click "Start monitoring" the agent appears in the
>>> AgentControl view. But I only can expand the "PerfmonAgent" node - no
>>> subnodes (e.g. "Processor" as described at
>>> http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. tptp.platform.doc.user/tasks/simple_t_launchingAgent.htm )
>>> ....
>>>
>>> PerfmonAgent-console shows the following:
>>> Using Resource DLL "sysperf.dll", Communications DLL "rac.dll"
>>> Sending agent name from the collection DLL - PerfmonAgent
>>> PerfmonAgent received agentname of PerfmonAgent
>>> Setting the agent name is the transfer DLL to PerfmonAgent
>>> Loading RAC libraries
>>> Getting RAC functions
>>> Initializing RAC bindings
>>> Connecting to RAC - PerfmonAgent - 1151478506071
>>> Starting RAC listener
>>> Allocating message block
>>> RAC Startup succesful
>>> Allocating buffer
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> No agent monitoring yet (freq:3000ms)
>>> No agent monitoring yet (freq:3000ms)
>>> RAC Command 0000001A
>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>> name=var_string?HOST?localhost, value=var_string?HOST?localhost
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 0000001A
>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>> name=var_string?PORT?10002, value=var_string?PORT?10002
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 0000001A
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 00000017
>>> RAC Agent Started Monitoring 0
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 0000001A
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> Perfmon Datacollection:Collecting from host (null)
>>> RAC Command 0000001A
>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>> name=updatetree?238?true, value=updatetree?238?true
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>> RAC Command 0000001A
>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>> name=updatetree?230?true, value=updatetree?230?true
>>> RAC Command 00000050
>>> RAC Agent Controller available
>>>
>>> Anyone experienced the same problems?
>>> What's going wrong?
>>>
>>>
>>> Thanks,
>>> Martin From - Thu
>
>
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75839 is a reply to message #75773] Fri, 30 June 2006 09:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: lars.nospam.org

Hi ,

You can see the Perform printouts if you manually start the PerfomAgent.exe
with the -v (for verbose) option.

/Lars





"Rodion Guschin" <RGuschin@computel.ru> wrote in message
news:e82ht8$rvb$1@utils.eclipse.org...
> Thanks :) changing host name works for me.
> Another question - where can i see Perfmon logs like one Martin Schuetz
> posted. I don`t have an idea where to look for.
>
> Lars Ohl
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75856 is a reply to message #75839] Fri, 30 June 2006 10:02 Go to previous messageGo to next message
Eclipse User
Originally posted by: RGuschin.computel.ru

Hi, thanks for answering :)

Manually? How?

Rodion

Lars Ohlén wrote:
> Hi ,
>
> You can see the Perform printouts if you manually start the PerfomAgent.exe
> with the -v (for verbose) option.
>
> /Lars
>
>
>
>
>
> "Rodion Guschin" <RGuschin@computel.ru> wrote in message
> news:e82ht8$rvb$1@utils.eclipse.org...
>> Thanks :) changing host name works for me.
>> Another question - where can i see Perfmon logs like one Martin Schuetz
>> posted. I don`t have an idea where to look for.
>>
>> Lars Ohlén wrote:
>>> Hi,
>>>
>>> Its been a while since I used 3.1.1 and TPTP 4.01, but here are some
>>> suggestions:
>>>
>>> 1 The list of available topics can sometimes take time to appear! Wait
>>> for a while....
>>>
>>> 2. The default severe name is localhost (defined in the Settings tab
>>> for the Windows Perform) - perhaps this is not the case for you machine?
>>> (for my company it is not)
>>>
>>> /Lars
>>>
>>>
>>>
>>>
>>>
>>> "Rodion Guschin" <RGuschin@computel.ru> skrev i meddelandet
>>> news:e80jsk$r65$1@utils.eclipse.org...
>>>> Same problem :(
>>>>
>>>> Martin Schuetz wrote:
>>>>> I'm trying to monitor Windows System Trace (Perfmon - RAC_v6-0-1-3)
>>>>> with TPTP 4.0.1 (Eclipse 3.1.1 on Windows XP) - unfortunately without
>>>>> success.
>>>>> After starting the PerfmonAgent.exe I can add the agent in the
>>>>> "Profile" window and when I click "Start monitoring" the agent appears
>>>>> in the AgentControl view. But I only can expand the "PerfmonAgent"
>>>>> node - no subnodes (e.g. "Processor" as described at
>>>>> http://help.eclipse.org/help31/index.jsp?topic=/org.eclipse. tptp.platform.doc.user/tasks/simple_t_launchingAgent.htm )
>>>>> ....
>>>>>
>>>>> PerfmonAgent-console shows the following:
>>>>> Using Resource DLL "sysperf.dll", Communications DLL "rac.dll"
>>>>> Sending agent name from the collection DLL - PerfmonAgent
>>>>> PerfmonAgent received agentname of PerfmonAgent
>>>>> Setting the agent name is the transfer DLL to PerfmonAgent
>>>>> Loading RAC libraries
>>>>> Getting RAC functions
>>>>> Initializing RAC bindings
>>>>> Connecting to RAC - PerfmonAgent - 1151478506071
>>>>> Starting RAC listener
>>>>> Allocating message block
>>>>> RAC Startup succesful
>>>>> Allocating buffer
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> No agent monitoring yet (freq:3000ms)
>>>>> No agent monitoring yet (freq:3000ms)
>>>>> RAC Command 0000001A
>>>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>>>> name=var_string?HOST?localhost, value=var_string?HOST?localhost
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 0000001A
>>>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>>>> name=var_string?PORT?10002, value=var_string?PORT?10002
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 0000001A
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 00000017
>>>>> RAC Agent Started Monitoring 0
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 0000001A
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> Perfmon Datacollection:Collecting from host (null)
>>>>> RAC Command 0000001A
>>>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>>>> name=updatetree?238?true, value=updatetree?238?true
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>> RAC Command 0000001A
>>>>> Received an unrecognised RA_CUSTOM_COMMAND event,
>>>>> name=updatetree?230?true, value=updatetree?230?true
>>>>> RAC Command 00000050
>>>>> RAC Agent Controller available
>>>>>
>>>>> Anyone experienced the same problems?
>>>>> What's going wrong?
>>>>>
>>>>>
>>>>> Thanks,
>>>>> Martin From - Thu
>
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75873 is a reply to message #75856] Fri, 30 June 2006 10:32 Go to previous messageGo to next message
Eclipse User
Originally posted by: martin.schuetz.vmasch.at

You can find PerfmonAgent.exe in the bin-directory of the
AgentController-package - I've downloaded V6.0.1.3 from
http://www-128.ibm.com/developerworks/autonomic/probdet1.htm l

Regards,
Martin

>Hi, thanks for answering :)
>
>Manually? How?
>
>Rodion
>
Re: Cannot open PerfmonAgent subnodes in AgentControl view [message #75939 is a reply to message #75873] Fri, 30 June 2006 14:09 Go to previous message
Eclipse User
Originally posted by: graymagi.gmail.com

I've already got Perfmoneagent :)
What i'm doing:
Start ACServer.exe.
Start PerfMonAgent.exe -v
Start eclipse, connect to localhost:10002, start monitoring, even can
see some information about my host, but still no logs in PerfmonAgent
window.... strange isn't it?

Rodion

Martin Schuetz wrote:
> You can find PerfmonAgent.exe in the bin-directory of the
> AgentController-package - I've downloaded V6.0.1.3 from
> http://www-128.ibm.com/developerworks/autonomic/probdet1.htm l
>
> Regards,
> Martin
>
>> Hi, thanks for answering :)
>>
>> Manually? How?
>>
>> Rodion
>>
>
>
Previous Topic:Analysis rules problem
Next Topic:Does hyades work with Java 1.5 and RCP?
Goto Forum:
  


Current Time: Thu Apr 17 05:48:40 EDT 2014

Powered by FUDForum. Page generated in 0.01715 seconds