Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » [E4XMI Editor] Find Contribution Class Dialog
[E4XMI Editor] Find Contribution Class Dialog [message #710988] Fri, 05 August 2011 12:52 Go to next message
Jared Fordham is currently offline Jared Fordham
Messages: 2
Registered: July 2009
Junior Member
I was going through Tom's E4 tutorial [1] and went through some steps using the E4XMI editor. When I hit the class URI [Find Button] on a Part Node, the "Find Contribution Class" dialog shows up. It does the search filtering on keystroke, but with the text box selected the arrow keys don't work to navigate the search results. You have to use tab or the mouse to put focus on the list box in order to use the arrow keys to navigate the list box.

Screen shots and eclipse configuration attached.

If you do the workflow in the Open Type Dialog (Control + Shift + T) you can see that the arrow keys are "forwarded" to the list box.

Minor usability issue. I don't see any existing bug, though I may not be searching successfully. Should I log a bug? [2] Can anybody suggest a component?

[1] tomsondev.bestsolution.at/2010/07/28/eclipse-4-0-and-tutorial-on-writing-e4-rcp-application-released/

[2] bugs.eclipse.org/bugs/enter_bug.cgi?product=E4
Re: [E4XMI Editor] Find Contribution Class Dialog [message #711040 is a reply to message #710988] Fri, 05 August 2011 13:37 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas Schindl
Messages: 5242
Registered: July 2009
Senior Member
Please file a bug under
https://bugs.eclipse.org/bugs/enter_bug.cgi?product=e4&component=UI&short_desc=[Tooling]

Tom

Am 05.08.11 18:52, schrieb Jared Fordham:
> I was going through Tom's E4 tutorial [1] and went through some steps using the E4XMI editor. When I hit the class URI [Find Button] on a Part Node, the "Find Contribution Class" dialog shows up. It does the search filtering on keystroke, but with the text box selected the arrow keys don't work to navigate the search results. You have to use tab or the mouse to put focus on the list box in order to use the arrow keys to navigate the list box.
>
> Screen shots and eclipse configuration attached.
>
> If you do the workflow in the Open Type Dialog (Control + Shift + T) you can see that the arrow keys are "forwarded" to the list box.
>
> Minor usability issue. I don't see any existing bug, though I may not be searching successfully. Should I log a bug? [2] Can anybody suggest a component?
>
> [1] tomsondev.bestsolution.at/2010/07/28/eclipse-4-0-and-tutorial-on-writing-e4-rcp-application-released/
>
> [2] bugs.eclipse.org/bugs/enter_bug.cgi?product=E4
Re: [E4XMI Editor] Find Contribution Class Dialog [message #714025 is a reply to message #711040] Tue, 09 August 2011 12:07 Go to previous message
Jared Fordham is currently offline Jared Fordham
Messages: 2
Registered: July 2009
Junior Member
Thanks for taking a look Tom.

bugs.eclipse.org/bugs/show_bug.cgi?id=354053
Previous Topic:RCP ERROR
Next Topic:Save/Restore of 3.x views in E4
Goto Forum:
  


Current Time: Fri Jul 25 09:48:16 EDT 2014

Powered by FUDForum. Page generated in 0.01688 seconds