Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Where to get the required version of Spring IDE?
Where to get the required version of Spring IDE? [message #710731] Fri, 05 August 2011 10:57 Go to next message
Alexey Romanov is currently offline Alexey Romanov
Messages: 263
Registered: May 2010
Senior Member
Instructions at http://wiki.eclipse.org/Virgo/Tooling say to get Spring IDE from http://dist.springframework.org/snapshot/IDE/nightly, but Eclipse doesn't find anything there (at least for me). The version at http://dist.springframework.org/release/IDE is 2.3.0, while Virgo IDE requires 2.8.0. I've tried http://dist.springframework.org/milestone/IDE, but it doesn't seem to exist.
Re: Where to get the required version of Spring IDE? [message #710753 is a reply to message #710731] Fri, 05 August 2011 11:28 Go to previous messageGo to next message
Borislav Kapukaranov is currently offline Borislav Kapukaranov
Messages: 80
Registered: September 2010
Member
If you download the latest STS from here and install the latest Virgo Tools from here it should work like a charm.

I tried that yesterday.
If you want to just use Eclipse you have to add to the default set of update sites the update site of STS as the Virgo tooling still isn't decoupled from that.

HTH,
Borislav
Re: Where to get the required version of Spring IDE? [message #712463 is a reply to message #710753] Sun, 07 August 2011 09:20 Go to previous messageGo to next message
Martin Lippert is currently offline Martin Lippert
Messages: 123
Registered: July 2009
Senior Member
Hey Alexey!

You don't need to install anything from the Spring IDE nightly update site by yourself, please just add that site to the list of available update sites and use the Virgo milestone site to install the Virgo tooling. All the necessary Spring IDE parts will be installed from the nightly Spring IDE site automatically for you.

I guess the reason why you are not seeing anything when selecting the Spring IDE nightly site from the install new software dialog is that its components are not categorized, so when you deselect "group items by category" you will see all the bits and pieces from Spring IDE. But again, you don't need all that stuff and you don't need to install all that manually. Let Eclipse figure out for you which pieces it needs from Spring IDE.

HTH,
Martin
Re: Where to get the required version of Spring IDE? [message #712470 is a reply to message #712463] Sun, 07 August 2011 09:30 Go to previous messageGo to next message
Alexey Romanov is currently offline Alexey Romanov
Messages: 263
Registered: May 2010
Senior Member
Borislav: Thanks!

Martin: Hm, I've tried that but saw errors about non-existent Virgo Runtime. Do I need to download Virgo itself separately?
Re: Where to get the required version of Spring IDE? [message #713705 is a reply to message #712470] Mon, 08 August 2011 20:43 Go to previous messageGo to next message
Julien Chouinard is currently offline Julien Chouinard
Messages: 6
Registered: July 2011
Junior Member
Yes, you have to download the Virgo, unzip it somewhere and configure a new server with that virgo folder.
Re: Where to get the required version of Spring IDE? [message #713835 is a reply to message #713705] Tue, 09 August 2011 07:07 Go to previous message
Alexey Romanov is currently offline Alexey Romanov
Messages: 263
Registered: May 2010
Senior Member
Right, thanks. I've found http://www.eclipse.org/virgo/documentation/virgo-documentation-2.1.0.RELEASE/docs/virgo-getting-started/htmlsingle/virgo-getting-started.html with a more complete explanation.
Previous Topic:Application Deployer crashing on undeploy
Next Topic:Documentation about Spring Security / Virgo integration
Goto Forum:
  


Current Time: Sat Oct 25 21:26:24 GMT 2014

Powered by FUDForum. Page generated in 0.11247 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software